Author Topic: Can't open a CDE session  (Read 483 times)

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Can't open a CDE session
« on: October 25, 2016, 09:33:38 pm »
Hi there,

When I heard that CDE was included in SparkyLinux, I decided to give the distro a try with VirtualBox. The problem is that the MATE session is working fine but when I try to open a CDE session, it is automatically closed and I bounce back at the login screen. I tried as a normal user and as root but nothing changed. FYI, I installed  CDE via sudo apt-get update && sudo apt-get install cde-desktop and I also tried sudo apt-get update && sudo apt-get install sparky-aptus sparky-desktop and then via APTus from the Menu-> System-> APTus-> Desktop-> CDE as explained on <http://sparkylinux.org/cde-common-desktop-environment/>, but the result is the same.

You can see what happens on this short video. What am I doing wrong? Thanks in advance for your help.

Host OS: Ubuntu 16.10 amd64
VirtualBox version: 5.1.6_Ubuntu r110634
SparkyLinux installed from sparkylinux-4.4-x86_64-minimalcli.iso and updated afterwards.

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: Can't open a CDE session
« Reply #1 on: October 25, 2016, 10:01:22 pm »
Hi
You should check the ~HOME/.xsession-errors file looking for errors after failed login.
Nothing is easy as it looks.

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Re: Can't open a CDE session
« Reply #2 on: October 26, 2016, 12:20:47 am »
Here's the output of that file. Hope it will be useful.

Code: [Select]
Xsession: X session started for tizizi at Tue Oct 25 17:49:21 EDT 2016
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/tizizi/.Xauthority
localuser:tizizi being added to access control list
gpgconf: warning: can not open config file /home/tizizi/.gnupg/gpg-agent.conf: No such file or directory
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting USER=tizizi
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/tizizi
dbus-update-activation-environment: setting DESKTOP_SESSION=cde-desktop
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=tizizi
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting GDM_LANG=en_US.utf8
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=cde-desktop
dbus-update-activation-environment: setting XAUTHORITY=/home/tizizi/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/tizizi
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=cde-desktop
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/tizizi

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: Can't open a CDE session
« Reply #3 on: October 26, 2016, 04:11:04 pm »
1. Did you make full system upgrade?

2. Log in to other desktop if you have it. If not, run the system in recovery mode.
Check ownership of the ~HOME/.Xauthority :
Code: [Select]
ls -l /home/tizizi/.Xauthority
If not belongs to you, change it:
Code: [Select]
chown tizizi:tizizi /home/tizizi/.XauthorityYou can also re-vert the file:
Code: [Select]
mv /home/tizizi/.Xauthority /home/tizizi/.Xauthority.back
touch /home/tizizi/.Xauthority
chown tizizi:tizizi /home/tizizi/.Xauthority

Then reboot and check it out.
Nothing is easy as it looks.

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Re: Can't open a CDE session
« Reply #4 on: October 26, 2016, 07:48:47 pm »
Yes, the system is fully up-to-date. I did a sudo apt-get update && sudo apt-get upgrade and also used the system updater from the MATE desktop to make sure everything was updated.

As you suggested, I used a MATE session to enter the commands. Here's the result:
Code: [Select]

tizizi@localhost:~$ ls -l /home/tizizi/.Xauthority
-rw------- 1 tizizi tizizi 66 Oct 26 13:13 /home/tizizi/.Xauthority
tizizi@localhost:~$ chown tizizi:tizizi /home/tizizi/.Xauthority
tizizi@localhost:~$ ls -l /home/tizizi/.Xauthority
-rw------- 1 tizizi tizizi 66 Oct 26 13:13 /home/tizizi/.Xauthority
tizizi@localhost:~$ mv /home/tizizi/.Xauthority /home/tizizi/.Xauthority.back
tizizi@localhost:~$ touch /home/tizizi/.Xauthority
tizizi@localhost:~$ chown tizizi:tizizi /home/tizizi/.Xauthority
tizizi@localhost:~$ ls -l /home/tizizi/.Xauthority
-rw-r--r-- 1 tizizi tizizi 0 Oct 26 13:19 /home/tizizi/.Xauthority
tizizi@localhost:~$

Then I rebooted but the result is the same, I can't stay logged in if the desktop is CDE, as shown by the video linked in the first message of this thread. Please note that I also tried to log in as root but again, the result was the same.

Offline Dai_trying

  • Newbie
  • *
  • Posts: 39
Re: Can't open a CDE session
« Reply #5 on: October 26, 2016, 09:29:34 pm »
This may or may not be relevant here, but I have had similar problems logging in if there were insufficient free space on the hdd, it would just deny my log-in without saying why.

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: Can't open a CDE session
« Reply #6 on: October 26, 2016, 09:32:44 pm »
An another reason can be, as Dai_trying said, if your root partition is full.
Log in recovery mode again and remove all debs to make some free space:
Code: [Select]
apt-get clean
Nothing is easy as it looks.

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Re: Can't open a CDE session
« Reply #7 on: October 26, 2016, 09:53:37 pm »
I executed apt-get clean, but this hasn't solved the problem. Here's the output of free and df commands, in case it would be helpful:
Code: [Select]
tizizi@localhost:~$ free
              total        used        free      shared  buff/cache   available
Mem:        1020452      273500      501748        7780      245204      601876
Swap:       5401608           0     5401608
tizizi@localhost:~$ df --human-readable
Filesystem      Size  Used Avail Use% Mounted on
udev            479M     0  479M   0% /dev
tmpfs           100M  3.4M   97M   4% /run
/dev/sda1        15G  3.2G   11G  23% /
tmpfs           499M  108K  499M   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           499M     0  499M   0% /sys/fs/cgroup
tmpfs           100M   24K  100M   1% /run/user/1000
/dev/sr0        547M  547M     0 100% /media/cdrom
tizizi@localhost:~$

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Re: Can't open a CDE session
« Reply #8 on: October 27, 2016, 01:54:22 pm »
Now that’s weird: I created a new 32 bit virtual machine in VirtualBox and installed sparkylinux-4.4-i686-minimalcli.iso but the result is still the same with CDE. I also created a 32bit VirtualBox virtual machine on another computer running Ubuntu 16.04.1 amd64 and again, the result was the same.

I have no idea why this doesn’t work, but I think it’s starting to smell like either a VirtualBox or an Ubuntu issue. In a month's time I’ll have access to my Fedora/Windows 10 box and I’ll give SparkyLinux with CDE a new try. Unless we can figure out the problem before then, this could be a nice way to eliminate the Ubuntu hypothesis.

Offline zizban

  • Newbie
  • *
  • Posts: 2
Re: Can't open a CDE session
« Reply #9 on: October 29, 2016, 07:42:44 pm »
Hi, I'm the documentation guy/wiki wrangler for the cdesktopenv.

I tested the SparkyLinux CDE build on straight Debian and it worked fine. There are some issues with it but none that affect logging in (It doesn't set the CDE host name correctly so the Applications Manager doesn't function).

I always tested CDE on bare metal, never in a VM. I'm not sure a VM would effect anything but to be sure, try it on bare metal.

Perhaps try a minimal Sparky install and go from there.

Offline tizizi

  • Newbie
  • *
  • Posts: 6
Re: Can't open a CDE session
« Reply #10 on: November 01, 2016, 04:08:42 pm »
I tried a few more things with SparkyLinux and CDE, and to summarize, after trying a VM in QEMU and even compiling CDE from source, the problem is still there. But when I followed zizban's advice and "installed" CDE on a live session along with lightdm, a simple sudo service lightdm start allowed me to log in without any issues. So apparently for some reason, CDE on SparkyLinux doesn’t like to be used on a VM.

Here are more details: I created a 64 bit image on AQEMU on Ubuntu 16.10 amd64 and installed sparkylinux-4.4-x86_64-minimalcli.iso. During the install process I chose CDE, and got bounced back to the greeter every time I tried to log in. The command line options of QEMU were:
Code: [Select]
/usr/bin/qemu-system-x86_64 \
    -monitor stdio \
    -soundhw ac97 \
    -k fr \
    -machine accel=kvm \
    -m 1027 \
    -cdrom /home/tizizi/Downloads/sparkylinux-4.4-x86_64-minimalcli.iso \
    -hda /home/tizizi/.aqemu/Linux_x86_64_HDA.img \
    -boot once=d,menu=on \
    -net nic,vlan=0 \
    -net user,vlan=0 \
    -rtc base=localtime \
    -name "Linux x86_64"
and
Code: [Select]
/usr/bin/qemu-system-x86_64 \
    -monitor stdio \
    -soundhw ac97 \
    -k fr \
    -machine accel=tcg \
    -m 1027 \
    -cdrom /home/tizizi/Downloads/sparkylinux-4.4-x86_64-minimalcli.iso \
    -hda /home/tizizi/.aqemu/Linux_x86_64_HDA.img \
    -boot once=d,menu=on \
    -net nic,vlan=0 \
    -net user,vlan=0 \
    -rtc base=localtime \
    -name "Linux x86_64"

I also managed to build CDE from source on SparkyLinux (and on Ubuntu 16.04 amd64, both in VirtualBox with Ubuntu 16.10 as the host OS). The interesting thing is that my first session on Ubuntu worked almost fine whereas on SparkyLinux, CDE built from source still had the same login problem.

The thing that’s left to try is possibly on VMs on Fedora and/or Windows 10 like i said previously. Needless to say, feel free to yell at me if I missed something or if I can be of use in this case.

Offline paxmark1

  • Full Member
  • ***
  • Posts: 207
Re: Can't open a CDE session
« Reply #11 on: November 01, 2016, 10:40:37 pm »
I knew next to nothing about CDE.  So I looked a little.    I saw the page with the info for sparky, and then off to the arch linux wiki - often good stuff there. 
https://wiki.archlinux.org/index.php/Common_Desktop_Environment

Quote
Note: CDE is only supported on 32-bit systems, 64-bit support is still experimental.
  Considering how old the code base is, if you want to kick the can again, maybe try it as 32 bit. 
Don't make a FrankenDebian

Offline zizban

  • Newbie
  • *
  • Posts: 2
Re: Can't open a CDE session
« Reply #12 on: November 04, 2016, 01:33:46 am »
If you have questions about CDE, ask on the mailing list. Note the SparkyLinux build is unofficial, those questions should be directed at the packager.

To the last poster: You are looking at the Archlinux instructions. CDE is broken on Archlinux. CDE runs just fine on 32 and 64 chips, ARM and PowerPC (32 and 64 bit).