Author Topic: Fully upgrade to Sparky Linux 4.4  (Read 1241 times)

Offline penguin

  • Newbie
  • *
  • Posts: 13
Fully upgrade to Sparky Linux 4.4
« on: August 21, 2016, 08:35:35 pm »
Sparky Linux 4.4 is out from 20 August.

Any way to fully upgrade Sparky 4.3 to Sparky 4.4.

Thanks in advance.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Fully upgrade to Sparky Linux 4.4
« Reply #1 on: August 21, 2016, 11:16:43 pm »
Simply do as usually:
Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade
Nothing is easy as it looks.

Offline penguin

  • Newbie
  • *
  • Posts: 13
Re: Fully upgrade to Sparky Linux 4.4
« Reply #2 on: August 23, 2016, 07:39:51 am »
thanks.

I do it usually....but I have not seen any of new changes(presented in Sparky 4.4) reflected in my Sparky 4.3...anyway.Sparky is so solid !

Offline berliner58

  • Newbie
  • *
  • Posts: 8
Re: Fully upgrade to Sparky Linux 4.4
« Reply #3 on: September 14, 2016, 09:33:46 am »
I did the dist upgrade but now I have several problems.
I have Sparky with Mate desktop

1. Caja doesn't work anymore. It says it is starting, then it disappears.

2. The Menu is not working correctly. It jumps.  When I have the mouse over a button, the menu changes it's size. So the mouse suddenly is over another button then according to that button the whole menu changes the size.

Offline jidan

  • Newbie
  • *
  • Posts: 12
Re: Fully upgrade to Sparky Linux 4.4
« Reply #4 on: September 14, 2016, 09:26:17 pm »
@ berliner58

This is because a known conflict between the latest version(s) of GTK3 and MATE. Hope MATE developers solve those major problems with a new full compatible version of MATE. 

Offline berliner58

  • Newbie
  • *
  • Posts: 8
Re: Fully upgrade to Sparky Linux 4.4
« Reply #5 on: September 14, 2016, 10:27:48 pm »
Thank you, @jidan.
So I just wait. I am using the Double Commander instead of the non-functional Caja.

Offline randalhoctor

  • Newbie
  • *
  • Posts: 2
Re: Fully upgrade to Sparky Linux 4.4
« Reply #6 on: September 15, 2016, 03:43:50 am »
I'm upgrading from 4.3. Adding xfce4 is the only mod I have made.
When I upgrade I get 0B/358mb to add. After this an additional 18.6mb will be used
It runs and give same report.
The changelog shows "...long list...Use 'apt autoremove' to remove them.
I run apt autoremove and get this error:
After this operation, 18.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
apt-listchanges: APT_HOOK_INFO_FD environment variable is incorrectly defined
(Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2).
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -ne 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -ne 10
root@s5133w:/home/rsr#

I'm stuck.  Any ideas?

Offline jidan

  • Newbie
  • *
  • Posts: 12
Re: Fully upgrade to Sparky Linux 4.4
« Reply #7 on: September 16, 2016, 06:15:57 pm »
@ berliner58

As far as I checked, our favor DE MATE doesn't met the requirements of the last testing GTK3 version and it seems to be a great battle for the future of MATE.
I'm waiting for the new, corrected MATE, stable and issue-free as we knew it and love it.
Till then, Sparky support 20+ options for a stable DE, such as LXDE if youre looking for a light DE, XFCE, Cinnamon etc.
You just have to go to APTus Desktop, make your choice and install it. Then logout and login choosing the new-installed desktop. You can login back to MATE after upgrades to check it's progress.

If you prefer to stay in MATE but caja doesn't work, you can install pcmanfm, the lightweight file manager of LXDE.

Testing new software sometimes getting hard. usually with a happy end.
« Last Edit: September 16, 2016, 06:17:44 pm by jidan »

Offline berliner58

  • Newbie
  • *
  • Posts: 8
Re: Fully upgrade to Sparky Linux 4.4
« Reply #8 on: September 17, 2016, 11:10:13 am »
@jidan,
since the jumping of the Menu in MATE was too disturbing and not acceptable anymore, I use AptUS to install XFCE .

I am using Xfce now and I am pleased with it.
I first tried LXDE but Bitmask did't work in LXDE and I find it difficult to add a programm-starter to the task-bar. LXDE is too complicated for me.
In Xfce or Mate I just right-click and choose "Add to task-bar" and there it goes.

Thanks for your advice.

@randalhoctor,
sorry, I have no advice for you since Xfce works fine for me.

Offline jidan

  • Newbie
  • *
  • Posts: 12
Re: Fully upgrade to Sparky Linux 4.4
« Reply #9 on: September 17, 2016, 01:08:00 pm »
@berliner58

XFCE is a stable and usefull DE but you can easily fix your LXDE session as well.
You can always go to ~/.config/autostart to edit your startup scripts manually.
There's also the (Menu-System tools) "Sparky Center LXDE" tool doing the job. Just run it, go to "Default-Default applications for LXsession"-Autostart and check/uncheck your startup applications.
If you use Bitmask you have to open it from menu, login and reboot your system in LXDE. Once you reboot with bitmask running it will add itself in autostart list.
After you change your DE with logout/login, you have to re-edit the autostart list as loading a different DE affects it.

Anyway, if youre pleased with XFCE there's no need to use LXDE at all.

Offline berliner58

  • Newbie
  • *
  • Posts: 8
Re: Fully upgrade to Sparky Linux 4.4
« Reply #10 on: September 29, 2016, 07:30:13 pm »
jidan,
thanks for your help and explanations.

In the meanwhile I installed the Cinnamon Desktop.
For me it is the best choice.

I am just not able to create a quick-start-button in the LXQt Desktop  panel. I have googled and read the LXQt websites, but nobody explains it, they all seem to know how to do it. After searching for hours I gave up.

The cinnamon desktop is newbie-friendly.  I just right-click on the app and select " add to panel " and there the quick-start-button is placed where I want to have it. No google-search and wasting hours reading in forums and not finding a solution.

Offline MadEducator

  • Newbie
  • *
  • Posts: 3
Re: Fully upgrade to Sparky Linux 4.4
« Reply #11 on: October 01, 2016, 10:03:19 pm »
Hello, all. I hope this is the right place to ask. I'm running Sparkylinux Game Over 4.3 (well now it's 4.4) in a triple boot with Peppermint and Windows 7. The Linux distros are on a separate drive from Windows. All was working well until last night.

I'm new to linux in general and of late Sparky has been acting weird (taking too long to respond, having the screen flicker occasionally and freezing).

Last night I've refreshed packages, and updated the system through AptUs. But this morning, all I can boot into is the command line. I'm afraid I don't know enough about the command line to use it to fix what's wrong.

Can anyone please give me suggestions on how to proceed? I would greatly appreciate any help at all.

Update: I saw something similar in this thread so I used the advice given here and there and it worked. Here's my reply there http://sparkylinux.org/forum/index.php/topic,3657.msg8585.html#msg8585 .

Thanks for the good info. :)
« Last Edit: October 01, 2016, 10:41:41 pm by MadEducator »