Author Topic: KDE Updater systemtray applet not working  (Read 1071 times)

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
KDE Updater systemtray applet not working
« on: July 29, 2016, 10:56:57 pm »
 :( don`t know how to upload a image here

KDE systemtray applet gives error: org.kde.discovernotifier is not installed

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
Re: KDE Updater systemtray applet not working
« Reply #1 on: August 20, 2016, 06:26:57 pm »
Hello? anybody? .... did the dist upgrade, Am on Tyche so I guess that means 4.4 and STILL I get this error with the sistem tray udater applet

OK it is NOT life or death, but I like things to work as they should  ::)

Offline paxmark1

  • Full Member
  • ***
  • Posts: 207
Re: KDE Updater systemtray applet not working
« Reply #2 on: August 21, 2016, 04:02:50 am »
It is KDE and you are in for a bit more of a bumpy ride.  It is under very intense development still and at least for the next few months.  Things will smooth out some when the freeze arrives and hopefully a production ready version of all the new QT5 goodies and other development will grace Debian stable.  At least your upgrades did not call for the deletion of a hundred or more packages as people in unstable  faced ( and probably delayed).   

http://forum.siduction.org/index.php?topic=6325.0

https://www.kde.org/announcements/kde-frameworks-5.25.0.php
Don't make a FrankenDebian

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
Re: KDE Updater systemtray applet not working
« Reply #3 on: August 22, 2016, 03:11:52 pm »
Uhhh OK. I am on unstable and have sparky repos enabled and have latest kernel. I am having quite a lot of fun .... thats on a testing notebook LOL

Now, being as it is, I love Sparky KDE, what version should I use for production machines? I guess just 4.4 testing as it comes? Or should I avoid KDE?

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1462
    • SparkyLinux
Re: KDE Updater systemtray applet not working
« Reply #4 on: August 22, 2016, 08:51:36 pm »
A production machine?
My answer is simply: Debian 'stable' :)
Nothing is easy as it looks.

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
Re: KDE Updater systemtray applet not working
« Reply #5 on: August 22, 2016, 09:57:00 pm »
It's an IT environment (hardware and networking shop), all off us can take some bugs and we like to be on the edge with software (most don´t like falling of haha). I changed to unstable a time ago and it has not affected my work (we all do regular bakups, both of data and system images)... so .. how different or how more buggy is testing than stable? put another way: ¿how "older" is soft in stable than in testing? ....
Please take in consideration that I am considering sparky KDE for newer desktops and notebooks and sparky LXLE for netbooks and older notebooks....
(We will retain some PC´s and notebooks with Win10 for compatibility sake with some programs)

I really would appreciate your opinion!!! :-)

Offline paxmark1

  • Full Member
  • ***
  • Posts: 207
Re: KDE Updater systemtray applet not working
« Reply #6 on: August 24, 2016, 12:38:02 am »
Well, mentioning sid and kde

https://forum.siduction.org/index.php?topic=6325.0

The people commenting there have much more expertise than I do.  And they have been using cutting edge KDE for years.  Pretty bumpy ride right now in sid for KDE.   

If you really need QT5 and the latest in C, python and perl, a very aggressive plan would be to ride out Stretch here in testing  (XFCE, LXDE or LXQT are safer bets), make it through to the freeze, and then keep your /etc/apt/source.list  at Stretch when it goes stable.  This also gets you a better base of systemd than Jessie-stable. If security is paramount, you need to be using stable.  You will get more options for free support with a pure Debian /etc/apt/sources.list.  You can always pick out the good things you like from Sparky and install by hand. 
Don't make a FrankenDebian

Offline paxmark1

  • Full Member
  • ***
  • Posts: 207
Re: KDE Updater systemtray applet not working
« Reply #7 on: August 26, 2016, 11:30:43 pm »
Back on topic of systray

https://forum.siduction.org/index.php?topic=6334.msg51976

kf 5.25.0 qt 5.6.1 systray missing in action!

Don't make a FrankenDebian

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
Re: KDE Updater systemtray applet not working
« Reply #8 on: August 27, 2016, 12:56:49 am »
mmm, ok, NOPE security is not paramout, we have a guy that manages an BSD based firewall, and critic trafic goes via pgp

Offline OlliFri

  • Newbie
  • *
  • Posts: 1
Re: KDE Updater systemtray applet not working
« Reply #9 on: September 04, 2016, 08:48:55 pm »
Hallo Sparkys  :)
I am new here, and my English is very bad.
English read - ok
but write - grrrrrrrrrrr  ;D
I think Sparky is a super Distri! For me it is the best i have everytime see.
But Plasma 5.6 is very buggy. I hope Plasma 5.7 comes next time.
Gruß Olli

Offline ElQuia

  • Jr. Member
  • **
  • Posts: 99
Re: KDE Updater systemtray applet not working
« Reply #10 on: September 16, 2016, 01:38:49 am »
As of today update, still getting:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.discovernotifier/contents/ui/main.qml:23:1:module "org.kde.discovernotifier" is not installed

 :(