Author Topic: HP Laserjet P1102w  (Read 710 times)

Offline colonel

  • Newbie
  • *
  • Posts: 28
HP Laserjet P1102w
« on: June 19, 2016, 07:30:18 am »
Am always printing by going to gmail and sending messages to hpeprint.com server Can't I do this direct from Sparky? :-\

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 253
Re: HP Laserjet P1102w
« Reply #1 on: June 19, 2016, 02:30:16 pm »
In a web browser

http://localhost:631/

search debian wiki cups   

also you might try

Code: [Select]
aptitude show system-config-printer
Package: system-config-printer           
Version: 1.5.7-2
New: yes
State: not installed
Priority: optional
Section: gnome
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: all
Uncompressed Size: 1,010 k
Depends: gir1.2-gdkpixbuf-2.0, gir1.2-glib-2.0, gir1.2-gtk-3.0, gir1.2-notify-0.7, gir1.2-packagekitglib-1.0, gir1.2-pango-1.0, python3-cups (>= 1.9.60),
         python3-cupshelpers (= 1.5.7-2), python3-dbus, python3-gi, system-config-printer-common (= 1.5.7-2), python3:any (>= 3.3.2-2~)
Recommends: cups-pk-helper, python3-smbc, system-config-printer-udev
Suggests: gnome-software (>= 3.16.5-2)
Description: graphical interface to configure the printing system
 System-config-printer is a GUI written in Python using GTK+ to configure a CUPS server. Its primary use is to configure the printing system on the local host, but
 can also be used to setup a remote printer.
 
 In terms of features, it aims to be as complete as the CUPS web administration tool, while being integrated to the desktop.
Homepage: http://cyberelk.net/tim/software/system-config-printer/
Tags: interface::graphical

Usage of the above is more suited to a DE that has GTK+ .  Otherwise you might install many, many dependencies.

One way to check is via apt-get -s install foo     ##it merely simulates and does not have to be performed via sudo or root

Code: [Select]
apt-get -s install system-config-printer
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 libpackagekit-glib2-18
  python3-cairo python3-gi system-config-printer-common
Suggested packages:
  gnome-software
Recommended packages:
  packagekit cups-pk-helper python3-smbc gir1.2-gnomekeyring-1.0
The following NEW packages will be installed:
  gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 libpackagekit-glib2-18
  python3-cairo python3-gi system-config-printer system-config-printer-common
0 upgraded, 12 newly installed, 0 to remove and 6 not upgraded.
Inst gir1.2-atk-1.0 (2.20.0-1 Debian:unstable [amd64])
Inst gir1.2-freedesktop (1.48.0-2 Debian:unstable [amd64])
Inst gir1.2-gdkpixbuf-2.0 (2.34.0-1 Debian:unstable [amd64])
Inst gir1.2-pango-1.0 (1.40.1-1 Debian:unstable [amd64])
Inst gir1.2-gtk-3.0 (3.20.6-1 Debian:unstable [amd64])
Inst gir1.2-notify-0.7 (0.7.6-2 Debian:unstable [amd64])
Inst libpackagekit-glib2-18 (1.1.1-1 Debian:unstable [amd64])
Inst gir1.2-packagekitglib-1.0 (1.1.1-1 Debian:unstable [amd64])
Inst python3-cairo (1.10.0+dfsg-5+b1 Debian:unstable [amd64])
Inst python3-gi (3.20.1-1 Debian:unstable [amd64])
Inst system-config-printer-common (1.5.7-2 Debian:unstable [all])
Inst system-config-printer (1.5.7-2 Debian:unstable [all])
Conf gir1.2-atk-1.0 (2.20.0-1 Debian:unstable [amd64])
Conf gir1.2-freedesktop (1.48.0-2 Debian:unstable [amd64])
Conf gir1.2-gdkpixbuf-2.0 (2.34.0-1 Debian:unstable [amd64])
Conf gir1.2-pango-1.0 (1.40.1-1 Debian:unstable [amd64])
Conf gir1.2-gtk-3.0 (3.20.6-1 Debian:unstable [amd64])
Conf gir1.2-notify-0.7 (0.7.6-2 Debian:unstable [amd64])
Conf libpackagekit-glib2-18 (1.1.1-1 Debian:unstable [amd64])
Conf gir1.2-packagekitglib-1.0 (1.1.1-1 Debian:unstable [amd64])
Conf python3-cairo (1.10.0+dfsg-5+b1 Debian:unstable [amd64])
Conf python3-gi (3.20.1-1 Debian:unstable [amd64])
Conf system-config-printer-common (1.5.7-2 Debian:unstable [all])
Conf system-config-printer (1.5.7-2 Debian:unstable [all])

« Last Edit: June 19, 2016, 02:35:46 pm by paxmark1 »
Don't make a FrankenDebian

Offline colonel

  • Newbie
  • *
  • Posts: 28
Re: HP Laserjet P1102w
« Reply #2 on: June 28, 2016, 06:22:18 am »
Thanks but still not working