Author Topic: After apt-get dist-upgrade mate apps using gtk fail  (Read 787 times)

Offline kulturedyobbo

  • Newbie
  • *
  • Posts: 12
  • Linux user 1999. PHP/MySQL http://barwinski.net
After apt-get dist-upgrade mate apps using gtk fail
« on: June 04, 2016, 02:23:22 am »
Hi there

When I updated my system yesterday with "apt-get dist-upgrade" (03rd June 2016), I found that my mate apps such as pluma and eye of mate no longer worked. When I executed them from the command line, I got this message:

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

My OS is Sparky Linux, OS version 4, OS Code Name: Tyche, Kernel: 4.5.0-2-amd64.

My version of Pluma is 1.14.0-1 and eye of mate 3.20.2-1. I have tried uninstalling and reinstalling all of mate with no luck.

Cheers

Offline jidan

  • Newbie
  • *
  • Posts: 12
Re: After apt-get dist-upgrade mate apps using gtk fail
« Reply #1 on: June 04, 2016, 12:36:35 pm »
Problem with MATE 1.14.0 after upgrade here too.
Pluma, caja, eye of mate works fine after I included sid repositories, update and run:
Code: [Select]
sudo apt-get install --reinstall mate-desktop-environment
sudo apt-get install --reinstall mate-desktop-environment-extras
This also upgrades Marco to unstable version.
Some panel applets like mate-sensors and mate-system-monitor dissapeared so I upgrade them too to unstable (1.14) version.
Now everything seems to work fine except those two applets.
As they are pinned on a second autohidden left-oriented panel, sometimes when I mouseover/mouseout that panel, i have a "quit unexpectedly" error and they dissapear but they appear again after I choose reload.
Any suggestions?

Online paxmark1

  • Full Member
  • ***
  • Posts: 206
Re: After apt-get dist-upgrade mate apps using gtk fail
« Reply #2 on: June 04, 2016, 06:37:37 pm »
Wait.  Check out the irc for mate.  Wait.  Huge changes in GTK3 land is documented  in many places.  It can take a couple days for things to settle down in unstable and testing.
Don't make a FrankenDebian

Offline kulturedyobbo

  • Newbie
  • *
  • Posts: 12
  • Linux user 1999. PHP/MySQL http://barwinski.net
Re: After apt-get dist-upgrade mate apps using gtk fail
« Reply #3 on: June 05, 2016, 12:33:21 pm »
I found the problem. It was a sync problem with my mirror. I was using the mirror "http://mirror.overthewire.com.au/debian/" in my city which updated pluma to version 1.14 but still left mate-desktop at version 1.12. Pluma 1.14 needs mate-desktop 1.14. When I changed my  mirror to "http://ftp.nc.debian.org/debian/", and updated, the problem was solved. The thing is, I also received a dozen or so more package updates, which implies more than just these mate apps are out of sync.

Another thing, I also tried the mirror "http://mirror.cse.unsw.edu.au/debian/", but just like "http://mirror.overthewire.com.au/debian/", it to was out of sync. It seems that at the moment, only mirrors which contain "debian.org" are properly in sync, and I have since found out that Debian itself only has control of these mirrors with "debian.org".

Offline jidan

  • Newbie
  • *
  • Posts: 12
Re: After apt-get dist-upgrade mate apps using gtk fail
« Reply #4 on: June 05, 2016, 06:01:17 pm »
MATE version 1.12.1 (the version i had before upgrade) uses GTK3 as well. So, those apps keeps running after upgrade to 1.14. You may had a version older than 1.12.1 using GTK 2.
Now I use the unstable version of MATE with some issues with some applets. I'll be waiting for them to get solved or I'll downgrade my MATE back to 1.12.1.
« Last Edit: June 05, 2016, 06:04:26 pm by jidan »