Author Topic: Solved: systemd-230 logout kills background processes  (Read 624 times)

Offline paxmark1

  • Full Member
  • ***
  • Posts: 209
Solved: systemd-230 logout kills background processes
« on: May 28, 2016, 04:03:56 pm »
Systemd 230-1 is not in testing yet.  I have had no problems with it except for

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=825394

example for me is a tmux session under /home/pax/   Ctl-Alt-F1 or "systemctl stop lightdm"  kills the non graphical running processes of user pax. 

Fix is (from Dizzie at vsido irc) "You can disable it, look at the systemd config file. KillUserProcesses=no in /etc/systemd/logind.conf"  I will be applying it to three machines, I sometimes have my openvpn under a tmux and also closed ended but long running processes like unsion, rsync, etc.  Technically not a bug, it is a design flaw.  apt-listbugs will probably not catch this but hopefully a message will pop up and tell you about the change when this hits testing. 

Please, no systemd flame replies. 

Many here will not be affected by this. 

edit. It is now in testing.   /etc/systemd/journald.conf  also has minor changes, I accepted but I like persistent as opposed to auto.  RateLimitInterval became RateLimitIntervalSec    As always - man journald.conf
« Last Edit: November 24, 2016, 05:47:23 am by paxmark1 »
Don't make a FrankenDebian

Offline paxmark1

  • Full Member
  • ***
  • Posts: 209
Re: systemd-230 logout kills background processes
« Reply #1 on: May 30, 2016, 03:52:26 am »
Systemd 230-1 is not in testing yet.  I have had no problems with it except for

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=825394

example for me is a tmux session under /home/pax/   Ctl-Alt-F1 or "systemctl stop lightdm"  kills the non graphical running processes of user pax. 

Fix is (from Dizzie at vsido irc) "You can disable it, look at the systemd config file. KillUserProcesses=no in /etc/systemd/logind.conf"  I will be applying it to three machines, I sometimes have my openvpn under a tmux and also closed ended but long running processes like unsion, rsync, etc.  Technically not a bug, it is a design flaw (for my usage).  apt-listbugs will probably not catch this but hopefully a message will pop up and tell you about the change when this hits testing. 

edit add from logind.conf "Note that setting KillUserProcesses=yes will break tools like screen(1) and tmux(1), unless they are moved out of the session scope. See example in systemd-run(1)."  end edit.

Please, no systemd flame replies. 

Many here will not be affected by this. 

edit. systemd-230-1 is now in testing.   /etc/systemd/journald.conf  also has minor changes, I accepted but I like persistent as opposed to auto.  RateLimitInterval became RateLimitIntervalSec    As always - man journald.conf
Don't make a FrankenDebian

Offline paxmark1

  • Full Member
  • ***
  • Posts: 209
Re: systemd-230 logout kills background processes
« Reply #2 on: May 31, 2016, 11:34:23 pm »
I was having problems with the editing function.  Oh, well. 

Here is another take on the systemd-230 KillUser setting. 

http://news.siduction.org/2016/05/debian-fell-over/
Don't make a FrankenDebian

Offline statmonkey

  • Newbie
  • *
  • Posts: 4
Re: systemd-230 logout kills background processes
« Reply #3 on: June 06, 2016, 05:03:30 pm »
Many thanks for posting this.  Systemd flame wars aside, somewhat regrettable decision.  Good to see the siduction guys still active.