Author Topic: Tried to 'add-apt-repository' and.. couldn't.  (Read 782 times)

Offline twodogs

  • Newbie
  • *
  • Posts: 7
Tried to 'add-apt-repository' and.. couldn't.
« on: May 16, 2016, 10:39:57 pm »
So, I was wondering.. why wouldn't 'software-properties-common' be installed by default.  Just wondering.


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #1 on: May 16, 2016, 11:04:34 pm »
Re-branding Debian into Sparky made conflicts with the package.
Nothing is easy as it looks.

Offline twodogs

  • Newbie
  • *
  • Posts: 7
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #2 on: May 17, 2016, 01:59:20 am »
Re-branding Debian into Sparky made conflicts with the package.

So,  to add a repository (I'm trying to add TLP for example) I need to edit /etc/apt/sources.list manually?

Is there a way I can do this in the terminal?  Perhaps a Sparky way? ;)

Offline paxmark1

  • Full Member
  • ***
  • Posts: 202
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #3 on: May 17, 2016, 04:44:02 am »
https://wiki.debian.org/SourcesList

sudo nano sudo nano /etc/apt/sources.list       or       sudo  vim /etc/apt/sources.list  or   sudo geany    .

or you can nest it inside the directory sources.list.d     via any of your favourite editors.    There is lots of examples on the web. 

p.s.  don't make a FrankenDebian   If it is a Ubuntu ppa ...   

And about the terminal -  tlp mentions that

"TLP is a pure command line tool with automated background tasks, it does not contain a GUI."


   
Don't make a FrankenDebian

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #4 on: May 17, 2016, 02:23:43 pm »
You can also use APTus-> Repository-> Manage custom repos.
Edit any existing list, for example sid.list, remove the contects, add yours repos and save the file with a new name.
Nothing is easy as it looks.

Offline twodogs

  • Newbie
  • *
  • Posts: 7
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #5 on: May 17, 2016, 03:04:36 pm »
https://wiki.debian.org/SourcesList

sudo nano sudo nano /etc/apt/sources.list       or       sudo  vim /etc/apt/sources.list  or   sudo geany    .

or you can nest it inside the directory sources.list.d     via any of your favourite editors.    There is lots of examples on the web. 

p.s.  don't make a FrankenDebian   If it is a Ubuntu ppa ...   

And about the terminal -  tlp mentions that

"TLP is a pure command line tool with automated background tasks, it does not contain a GUI."


 

I'm familiar with how to modify sources.list manually.  Apparently, that is the only way to add a ppa to Sparky (besides using the APTus tool).

On the command line, one should be able to type 'sudo apt-add-repository ...' and all is well.  But on Sparky, that is not the case.  You have to either use a 'Sparky' tool or do it manually.  To me, that is not easy.  That just sounds like a workaround.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Tried to 'add-apt-repository' and.. couldn't.
« Reply #6 on: May 17, 2016, 03:24:29 pm »
What about Synaptic-> Settings-> Repository ?
Nothing is easy as it looks.