Author Topic: My SparkyLinux impresions ...Google-Earth version 6 and some other applications  (Read 951 times)

Offline penguin

  • Newbie
  • *
  • Posts: 13
Hi to all !
Great Distro. Really Great ! Hats off to pavroo. The system is lean and fast. I like it.
At the period of the two last months, I have tried a lot of distros.A lot. My first contact with linux was years and years ago.Roundly 14 years ago.First with Mandrake,Suse, Redhat,Ubuntu,Slackware,Xandros etc. But I have not been stuck to it.I have used Windows that is transformed in a burden system. Who said that Vista was a bad system? Vista was left behind internationally. Windows XP is still my favorite. .Shame. I have never liked Windows 7.It is not only opinion. I think that I am a good tester that have been in contact with computer in 1990, programing my diploma with Turbo Pascal 7.As I said ,at the period of the last 2 months I tried to find a right distro.... Peppermint,Xubuntu,Lubuntu,Arch,Manjaro,Antergos,Slackware,Debian,Mint,Vector Linux,LXDE,Simply Linux,Antix, etc. First. The most of the articles in the internet are totally bullshit. Many of them are copy+paste.Try distros and you will find a tons/stupid of bugs that nobody have related, no body has fixed. Also the infamous Debian has a bug when you try to install boot loader ( when you try to install it HDD from live section) and the version of xfce4 in Debian 8.4 is not updated. Slackware still suffer from bad font display. Bugs in Manjaro, bugs in Arch.The most perfect installer in my opinion is offered by Ubuntu. I have got back any time to Xubuntu 14.04.4. For me is preferred rock solid linux. Mint is not as faster as Ubuntu.Manjaro applies huge updates every times and after them you will find that some programs are not running anymore or other problems appear. But lets come back to Sparky. I wanted to try a rolling distro, to live in the cutting edge with linux. I have tried rolling ditros as Arch, Antergos,Manjaro... I do not want to pass in details to explain my experience with them. I have posted in their forums. I found Sparky. I have installed and uninstalled it, roundly one month before.Something did not convinced me...I have tried again...back to Xubuntu...and I said. I will stay some time to Sparky again. Some of the problems noticed by me in the first touch with Sparky still are not resolved.
if you try to install Google-Earth 6 , or Google-Earth 7 in APTus( I don not like version 7 because of non correct display, probably from my Intel graphic card.The same problem as related in this forum by another user is still pending.The installer stopped and saying : Something is wrong! Probably you have stopped installation or the repository server is down. I have downloaded google-earth_6.0.3_stable_i386 or googleearth_6.2.2.6613-r0_amd64 deb files that perfectly installed in Xubuntu 14.0.4. Opening these files with debi packager said: Error dependency is not satisfiable lsb-core >=3.2. The same problem happened in the new Xubuntu 16.04 (So shame that Xubuntu has gone out in new version with so many non fixed problems). As I remembered the same problem was in Arch or Manjaro ( but I have installed deb file in Manjaro using Manjaro i686 instead of amd64 version in my laptop). The same problem I get when i used Sparky i686. I have installed Xnview from Sparky repositories, roundly 2 weeks ago . Xnview was installed but does not runs. The same happened with Bricscad V13 deb file. The only linux system where I am able to install everything and runthese softwares is Xubuntu 14.04.4.
Great, that you removed Clementine as player. I prefer gmusicbrowser or Qmmp. Please try to update gmusicbrowser from version 1.1.13 to 1.1.15 to have possibility to use equalizer.Something goes wrong with 1.1.15.When I have installed this version (gstreamer does not loaded and the results is was voice) . As i see now the gmusicbrowser in the repository now is 1.1.14 and works great but seems that this version cannot find lyrics in the server(and this is not Sparky fault).1.1.15 works great in Xubuntu. WPS office is worked great,Really fast, but the icons are missing in whiskey menu (I fixed missing icons by creating/copying new icons in /usr/share/icons/ultra-flat-icons/apps/scalable/ . You can change things by opening icons found in /usr/share/applications/ by a text editor - You need to open and edit as Root )
I like to stay with Sparky, because i like it. Lean and fast. Hope for faster solutions.

 
« Last Edit: May 12, 2016, 10:07:52 pm by penguin »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Hi
Problem with Google Eartch depends on missing dependencies.
It's Debian testing base, so it happens sometimes.
Refresh package list and try again now.

All the music players (excluding smtube) are placed in Debian testing repository, I can not upgrade them.
What I can do is checking the players versions on the developers pages and put them to Sparky repos, if available.
Nothing is easy as it looks.

Offline penguin

  • Newbie
  • *
  • Posts: 13
HI.

Thanks for your work and your response.I have tried to install lsb-core.It refused to be installed.I just refreshed packaged list and...bump.I arrived to install lsb-core_4.1+Debian13+nmu1_amd64.deb. Now is asking for another library ia32-libs.During install of ia32-libs is asking for another dependency. I installed what was required and I am stuck now to ia32-libs-i386_0.4_i386.deb dependence that refused to be installed without any explanation.
Anyway.... I will try to refresh packages and wait for resolving of the problem or I will try to find solution in the web.

pawroo. As you said: Happens because is Debian testing.
I want to thank you for this great job. lean and fast system.

Offline Wombat

  • Newbie
  • *
  • Posts: 17
Just installed Google Earth (7) from  Aptus Extra after seeing this post ....never worked before....thanks!

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
@penguin The Google Earth 6 is available for 32 bit machines only.
If you are installing it on 64 bit system, make sure you have all needed 32 libs already installed.

The installation required lsb-core and lsb-security, so I put both to sparky repos.
The 32 libs can be installed form Debian's testing repos.
Nothing is easy as it looks.

Offline penguin

  • Newbie
  • *
  • Posts: 13
Yes...pavroo and Wombat. I arrived to install google-earth 7, but not from APTus Extra.

For all folk an alternative way to install google-earth 7 (64 bit ) but not from APTus Extra.

Search and grab from Internet google-earth-stable_current_amd64.deb ( google -earth 7 - 64 bit) / 46.4 MB (46,385,468 bytes).
1-Open file by Gdebi Package Installer ( to install it ).
2-If you get a notification in the red letters about lsb-core >=32 means that library is missing.You need to install lsb_core library first.
3-Strongly recommended to refresh repositories in APTus, before continuing with installing procedure.
4-Grab lsb_core from internet in follow link: https://packages.debian.org/lsb-core (lsb-core 4.1+Debian13+nmu1) or search for it in Synaptic Package Manager.
5-Install lsb_core by your choose.
6-Try to install google-earth 7 (the deb file mentioned above). If you get another notification in the red letters...means that something is missing . 7- Keep in mind.If installation stops because of a missing library,you need to find and install it and get back to previous step.
8- The last one. If something is going wrong and in APTus said that google-earth is installed but in fact not, just needs to fix broken packages simply : APTus>Fix Broken Packages by Aptus and retry with installation.

The latest trick.Just found :) !
To avoid glitches ( non correct display during rendering ).
Open Google-Earth 7
Go to Tools
Go to Options
Texture Colors
Untick Compress - Restart.
Done.
Hope this helps.

« Last Edit: May 12, 2016, 05:45:06 pm by penguin »