Author Topic: Openshot not able to work with MP4s  (Read 834 times)

Offline Shalva

  • Newbie
  • *
  • Posts: 2
Openshot not able to work with MP4s
« on: April 11, 2016, 12:59:25 pm »
Hi,

I'm really liking Sparky but I've got this problem withy Openshot not being able to import MP4s. I guess it's some legal thing about codecs.

If I try to add an MP4 to work on, I get a popup message saying "Openshot does not support this file format" which is silly because I was using Openshot on Fedora 23 last week and importing MP4s without any trouble,

I was hoping to upgrade to the latest Openshot using an Ubuntu PPA but coming up against problems there too, I get an error message:

Code: [Select]
Error: could not find a distribution template for Sparky/Tyche
I believe it looks in /etc/lsb-release and doesn't recognise what it sees there.

Offline paxmark1

  • Full Member
  • ***
  • Posts: 209
Re: Openshot not able to work with MP4s
« Reply #1 on: April 12, 2016, 12:02:28 am »
Just a hint, using Ubuntu ppa's with Debian testing is a very easy way to get a system that is broken and not fixable.  Search Frankendebian.   

For openshot (version 1.4.3-1.2) in testing and unstable unstable the listed bugs are. 
https://bugs.debian.org/cgi-bin/pkgreport.cgi?dist=unstable;package=openshot

One listed bug is that bug reports for openshot go to openshot and not  Debian, so check the openshot buglist. 

Package page is here.       https://packages.debian.org/stretch/openshot

Do you have debmultimedia  enabled?  I love it in stable, but my preference is to avoid it in unstable and testing.  Another possibility  is  a missing gstreamer... .  Are you using ffmpeg or avconv?     

peace out

Don't make a FrankenDebian

Offline Wombat

  • Newbie
  • *
  • Posts: 17
Re: Openshot not able to work with MP4s
« Reply #2 on: April 12, 2016, 03:52:08 am »
Am able to import MP4 video to Openshot on this system - KDE Sparky Testing.

Have you these codecs mpeg4, msmpeg4, msmpeg4v2 in your Openshot preferences- AV Formats?
Possibly installed from Sparky Aptus Extra/ Codecs in the system menu, or when VLC was installed. Try those sources and then reload from within Open Shot  - in the same AV Format location...OpenShot-Menu-Edit-Preferences-AV Formats-Reload Codecs
« Last Edit: April 12, 2016, 04:14:51 am by Wombat »

Offline Shalva

  • Newbie
  • *
  • Posts: 2
Re: Openshot not able to work with MP4s
« Reply #3 on: April 12, 2016, 12:51:39 pm »
Hi thanks for the helpful replies but reinstalling codecs from Sparky APTus didn't work to fix my Openshot MP4 problem.

Now, another problem, I have tried several ways to install Google Earth, from the Google  website, and triend both 6 & 7 from APTus and every time I run into a dependency problem and the install fails.

I think I'm going to install the new Ubuntu 16.04, I just want to get things done, sorry but Sparky was not a good experience for me.

.

Offline Wombat

  • Newbie
  • *
  • Posts: 17
Re: Openshot not able to work with MP4s
« Reply #4 on: April 13, 2016, 12:50:18 am »
Kdenlive may have been a better editor to start off with. There is a multitude of codecs, you just need to find the ones compatible with your particular mp4's.

I too have been unable to install Google Earth  since upgrading to 64bit and KDE on a clean install although google earth carried over on an upgrade to SparkyKDE from SparkyLXDE  using the  Desktop Tab icon in Aptus on our main PC which is also 64 bit - so it can be done.

Both the Openshot and Google Earth problems are  probably outside the domain of  whatever distro compiler you use.
« Last Edit: April 13, 2016, 01:38:03 am by Wombat »