Author Topic: Can see the wifi, can't connect  (Read 670 times)

Offline Skotches

  • Newbie
  • *
  • Posts: 5
Can see the wifi, can't connect
« on: February 12, 2016, 03:42:00 am »
So I had been running GameOver for awhile on my old system and today got the new hardware in and gutted the old system and threw in the new one.  The only thing I really kept was the case so its technically an entirely new system.  I installed Sparky and found that the onboard wifi doesn't want to work ("device not ready") - Qualcomm Atheros QCA6174; That was kind of a buzz kill but I still had the old USB adapter I had been using with the old system (Atheros UB91C).  That one shows me the list of nearby wifi networks including my own.  The first time I try to connect to it it asks me for the passkey and then grinds for about 30 seconds and doesn't connect.

I went ahead and installed xubuntu which connected fine but I really don't like the feel of it and it has its own problem of not being able to play any sound.

I know this is not enough to go by, so let me know what I should put into the terminal.

Thanks much
kevin

Offline Skotches

  • Newbie
  • *
  • Posts: 5
Re: Can see the wifi, can't connect
« Reply #1 on: February 12, 2016, 04:07:08 am »
$ lspci -nn -n
...
09:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 32)
...

$ lspci | grep Network
09:00.0 Network controller: Qualcomm Atheros Device 003e (rev 32)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Can see the wifi, can't connect
« Reply #2 on: February 12, 2016, 12:21:13 pm »
Check is the module loaded:
Code: [Select]
lsmod | grep ath10kIf not, try to load it:
Code: [Select]
modprobe -r ath10k
modprobe ath10k
Then check it again.
Nothing is easy as it looks.

Offline Skotches

  • Newbie
  • *
  • Posts: 5
Re: Can see the wifi, can't connect
« Reply #3 on: February 12, 2016, 05:51:05 pm »
Thanks for your response

Code: [Select]
$ lsmod | grep ath10k
ath10k_pci          40960  0
ath10k_core        208896  1 ath10k_pci
ath                 32768  4 ath9k_common,ath9k_htc,ath10k_core,ath9k_hw
mac80211           626688  2 ath9k_htc,ath10k_core
cfg80211           540672  5 ath,ath9k_common,mac80211,ath9k_htc,ath10k_core

$ sudo modprobe -r ath10k
sudo: error while loading shared libraries: /usr/lib/sudo/libsudo_util.so.0: can not read file data: Input/output error

Offline Skotches

  • Newbie
  • *
  • Posts: 5
Re: Can see the wifi, can't connect
« Reply #4 on: February 13, 2016, 05:36:48 am »
So I broke down and bought a 50 foot ethernet cable today.  Getting faster than 1meg/sec speeds so in retrospect its working a lot faster than my wireless used to.  Gunna stick with that, although I wouldn't mind having the wireless working again, not that it would help unless someone accidentally tripped over the cord and broke it.  I'll check back every now and again if someone has an idea of what to try.  Thanks!

kevin