Author Topic: new install of Sparky Linux 4.2 GameOver, can't run Steam  (Read 846 times)

Offline kira1000

  • Newbie
  • *
  • Posts: 2
new install of Sparky Linux 4.2 GameOver, can't run Steam
« on: January 24, 2016, 10:17:59 pm »
Hello, as the title says, I just got Sparky Linux installed and upgraded, however I am unable to run Steam.  I ran it once and the "terms and conditions" box appeared which I ticked and agreed with, then...nothing.  I tried running it again and it still did not work, when I ran it in a command-line (and piping it to a document) I got the following output:

Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
sh: 1: /home/ki/.local/share/Steam/steam_msg.sh: not found
Assert( Assertion Failed: Could not open connection to X ):updateui_xwin.cpp:337

Installing breakpad exception handler for appid(steam)/version(1.0)
crash_20160124234122_3.dmp[23236]: Uploading dump (out-of-process)
/tmp/dumps/crash_20160124234122_3.dmp
crash_20160124234122_3.dmp[23236]: Finished uploading minidump (out-of-process): success = no
crash_20160124234122_3.dmp[23236]: error: libcurl.so: cannot open shared object file: No such file or directory
crash_20160124234122_3.dmp[23236]: file ''/tmp/dumps/crash_20160124234122_3.dmp'', upload no: ''libcurl.so: cannot open shared object file: No such file or directory''
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-01-24 23:41:22] Startup - updater built Nov 17 2015 12:33:46
updateui_xwin.cpp (337) : Assertion Failed: Could not open connection to X
main.cpp (514) : Assertion Failed: failed to initialize update status ui, or create initial window

Does anyone know what is wrong?  Any assistance is appreciated.

Offline frank392

  • Newbie
  • *
  • Posts: 6
Re: new install of Sparky Linux 4.2 GameOver, can't run Steam
« Reply #1 on: January 25, 2016, 11:58:15 pm »
Thank you for posting, I have the same problem!

Offline paxmark1

  • Full Member
  • ***
  • Posts: 201
Re: new install of Sparky Linux 4.2 GameOver, can't run Steam
« Reply #2 on: January 26, 2016, 01:12:33 am »
I don't steam 

quick duckduckgo shows many distros with the same error message.  Times like that , try the source

https://github.com/ValveSoftware/steam-for-linux/issues/
Don't make a FrankenDebian

Offline kira1000

  • Newbie
  • *
  • Posts: 2
Re: new install of Sparky Linux 4.2 GameOver, can't run Steam
« Reply #3 on: January 26, 2016, 03:38:18 am »
Well, I fixed that particular error by using
sudo apt-get install libcurl3:i386
and
sudo apt-get install xfonts-100dpi:i386, xfonts-75dpi:i386 and xfonts-scalable:i386 (in separate commands obviously)

Now however, I get this message:

Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
sh: 1: /home/ki/.local/share/Steam/steam_msg.sh: not found
Assert( Assertion Failed: Could not open connection to X ):updateui_xwin.cpp:337

Installing breakpad exception handler for appid(steam)/version(1.0)
crash_20160125204732_3.dmp[2545]: Uploading dump (out-of-process)
/tmp/dumps/crash_20160125204732_3.dmp
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-01-25 20:47:32] Startup - updater built Nov 17 2015 12:33:46
updateui_xwin.cpp (337) : Assertion Failed: Could not open connection to X
main.cpp (514) : Assertion Failed: failed to initialize update status ui, or create initial window
crash_20160125204732_3.dmp[2545]: Finished uploading minidump (out-of-process): success = yes
crash_20160125204732_3.dmp[2545]: response: CrashID=bp-f2dab442-1abc-448a-86a9-8b93a2160125
crash_20160125204732_3.dmp[2545]: file ''/tmp/dumps/crash_20160125204732_3.dmp'', upload yes: ''CrashID=bp-f2dab442-1abc-448a-86a9-8b93a2160125''

If no-one here has a clue, will check ont he official git issue tracker.