Author Topic: custom SparkyLinux ISO that made the locale of the correspondence is in English  (Read 1066 times)

Offline balloon

  • Newbie
  • *
  • Posts: 29
  • Japanese translator
I have recently used the Custom ISO Builder, attempts to ISO generation of Japanese users.

First of all I am trying to generate the custom ISO in SparkyLinux.
I went the chroot, and execution of locale-gen and change of /etc/default/locale.
However, ISO generated by this is output in English.
I have added "locale" of the options in GRUB to try. but still it does not improve.

Do you have suggestions for this problem?
BALLOON a.k.a. Fu-sen. (ふうせん Fu-sen.) in Japan

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1462
    • SparkyLinux
To change the default locale do:
Code: [Select]
dpkg-reconfigure localesUncheck en_US.UTF8 and check yours - ja_JP.
The target system should has 1 locale configured only to start new iso with it.

p.s.
There is a problem with the live installer - it crashed if live iso runs with different locales than English, but the old installer works fine with any.
Nothing is easy as it looks.

Offline balloon

  • Newbie
  • *
  • Posts: 29
  • Japanese translator
I think it also has already tried. But it does not improve.
(I forgot to perform the described...)

Quote
p.s.
There is a problem with the live installer - it crashed if live iso runs with different locales than English, but the old installer works fine with any.
When I tried, it did not encounter a crash. It may be a condition other than the locale.
« Last Edit: January 04, 2016, 04:39:56 am by balloon »
BALLOON a.k.a. Fu-sen. (ふうせん Fu-sen.) in Japan

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1462
    • SparkyLinux
I made a test and I have to confirm - it can't be done this way.
I suggest to install sparky on a virtual machine or a additionl partition with your locales.
Then install fonts, fcitx, live-installer, sparky-backup-sys and add grub-efi files as the Sparky-backup-sys info says to your home directory.
Then build a new iso from the installed system. 

If any problems, just let me know.
Nothing is easy as it looks.

Offline balloon

  • Newbie
  • *
  • Posts: 29
  • Japanese translator
I tried some of the distributions ISO over a period of several days, make specific this problem.
BALLOON a.k.a. Fu-sen. (ふうせん Fu-sen.) in Japan

Offline balloon

  • Newbie
  • *
  • Posts: 29
  • Japanese translator
I was able to solve this problem today.
Set in the locale the boot options in Debian live:
Code: [Select]
locales=ja_JP.UTF-8It was able to liveboot SparkyLinux in Japanese to do this.
https://dl.dropboxusercontent.com/u/1125999/SparkyLinux/VirtualBox_sparkylinux_16_01_2016_14_33_37.jpg
This is a particularly effective means "Rescue" ISO.
BALLOON a.k.a. Fu-sen. (ふうせん Fu-sen.) in Japan

Offline balloon

  • Newbie
  • *
  • Posts: 29
  • Japanese translator
After that, I was further investigated.
As a result, I found that it is possible to add the LOCALES to the /etc/live as a set of Live user.
https://dl.dropboxusercontent.com/u/1125999/SparkyLinux/Screenshot%20from%202016-01-16%2019-57-25.jpg
BALLOON a.k.a. Fu-sen. (ふうせん Fu-sen.) in Japan