Author Topic: module fglrx not found please help  (Read 1345 times)

Offline travica77

  • Newbie
  • *
  • Posts: 27
module fglrx not found please help
« on: December 25, 2015, 12:13:24 pm »
Hello.
i'm upgrading my system and then installed new kernel 4.3... after reboot computer wont start. I log in to my shell and startx it show this:
modprobe:Fatal: Module fglrx not found. fglrx: No matching device section for instance BUSID PCI: 0@0:1:1) found

my graphics card is: advance micro devices AMD/ATI Kaveri Radeon R5
« Last Edit: December 25, 2015, 12:16:13 pm by travica77 »

Offline kc1di

  • Newbie
  • *
  • Posts: 4
Re: module fglrx not found please help
« Reply #1 on: December 25, 2015, 12:26:53 pm »
according to my search that module is only in sid repository so far. you may have to get it from there.

You should be able to boot to your old kernel if you haven't deleted it yet .
Living somewhere in Maine USA
Registered Linux User #462608

Offline travica77

  • Newbie
  • *
  • Posts: 27
Re: module fglrx not found please help
« Reply #2 on: December 25, 2015, 01:25:55 pm »
hm but in sid repo is acual the same drive as in testing. here is my log xorg. 

[    85.712]
X.Org X Server 1.17.3
Release Date: 2015-10-26
[    85.712] X Protocol Version 11, Revision 0
[    85.712] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[    85.712] Current Operating System: Linux sparkuros 4.3.0-1-amd64 #1 SMP Debian 4.3.3-2 (2015-12-17) x86_64
[    85.712] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.3.0-1-amd64 root=UUID=d3fd795b-d1c6-4e21-bcc5-5cd28c949b1b ro quiet splash
[    85.712] Build Date: 27 October 2015  11:41:02PM
[    85.712] xorg-server 2:1.17.3-2 (http://www.debian.org/support)
[    85.712] Current version of pixman: 0.33.4
[    85.712]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    85.712] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    85.713] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 25 12:20:59 2015
[    85.713] (==) Using config file: "/etc/X11/xorg.conf"
[    85.713] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    85.713] (==) ServerLayout "aticonfig Layout"
[    85.713] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    85.713] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    85.714] (**) |   |-->Device "aticonfig-Device[0]-0"
[    85.714] (==) Automatically adding devices
[    85.714] (==) Automatically enabling devices
[    85.714] (==) Automatically adding GPU devices
[    85.714] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    85.714]    Entry deleted from font path.
[    85.714] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[    85.714] (==) ModulePath set to "/usr/lib/xorg/modules"
[    85.714] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    85.714] (II) Loader magic: 0x556a6b68dde0
[    85.714] (II) Module ABI versions:
[    85.714]    X.Org ANSI C Emulation: 0.4
[    85.714]    X.Org Video Driver: 19.0
[    85.714]    X.Org XInput driver : 21.0
[    85.714]    X.Org Server Extension : 9.0
[    85.719] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    85.722] (--) PCI:*(0:0:1:0) 1002:1318:17aa:5110 rev 0, Mem @ 0xe0000000/268435456, 0xf0000000/8388608, 0xf0b00000/262144, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[    85.722] (II) "glx" will be loaded by default.
[    85.722] (II) LoadModule: "glx"
[    85.723] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    85.723] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    85.723]    compiled for 6.9.0, module version = 1.0.0
[    85.723] (II) LoadModule: "fglrx"
[    85.724] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    85.759] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    85.759]    compiled for 1.4.99.906, module version = 15.20.3
[    85.759]    Module class: X.Org Video Driver
[    85.760] (II) Loading sub module "fglrxdrm"
[    85.760] (II) LoadModule: "fglrxdrm"
[    85.760] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    85.760] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    85.760]    compiled for 1.4.99.906, module version = 15.20.3
[    85.760] (II) AMD Proprietary Linux Driver Version Identifier:15.20.3
[    85.760] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-15.201.1151             
[    85.760] (II) AMD Proprietary Linux Driver Build Date: Sep  8 2015 15:06:35
[    85.760] (++) using VT number 1

[    85.760] (WW) Falling back to old probe method for fglrx
[    85.772] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    85.775] ukiDynamicMajor: failed to open /proc/ati/major
[    85.775] ukiDynamicMajor: failed to open /proc/ati/major
[    85.778] (--) Chipset Supported AMD Graphics Processor (0x1318) found
[    85.778] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
[    85.779] (II) fglrx(0): pEnt->device->identifier=0x556a6c8591f0
[    85.779] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === begin
[    85.780] (II) fglrx(0): FB driver is enabled
[    85.780] (II) Loading sub module "vgahw"
[    85.780] (II) LoadModule: "vgahw"
[    85.780] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[    85.780] (II) Module vgahw: vendor="X.Org Foundation"
[    85.780]    compiled for 1.17.3, module version = 0.1.0
[    85.780]    ABI class: X.Org Video Driver, version 19.0
[    85.781] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    85.781] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    85.781] (==) fglrx(0): Default visual is TrueColor
[    85.781] (**) fglrx(0): Option "DPMS" "true"
[    85.781] (==) fglrx(0): RGB weight 888
[    85.781] (II) fglrx(0): Using 8 bits per RGB
[    85.781] (==) fglrx(0): Buffer Tiling is ON
[    85.781] (II) Loading sub module "fglrxdrm"
[    85.781] (II) LoadModule: "fglrxdrm"
[    85.781] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    85.781] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    85.781]    compiled for 1.4.99.906, module version = 15.20.3
[    85.785] ukiDynamicMajor: failed to open /proc/ati/major
[    85.785] ukiDynamicMajor: failed to open /proc/ati/major
[    85.786] (**) fglrx(0): NoAccel = NO
[    85.786] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[    85.786] (--) fglrx(0): Chipset: "AMD Radeon(TM) R5 Graphics       " (Chipset = 0x1318)
[    85.786] (--) fglrx(0): (PciSubVendor = 0x17aa, PciSubDevice = 0x5110)
[    85.786] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[    85.786] (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
[    85.786] (--) fglrx(0): MMIO registers at 0xf0b00000
[    85.786] (--) fglrx(0): I/O port at 0x00003000
[    85.786] (==) fglrx(0): ROM-BIOS at 0x000c0000
[    85.814] (EE) fglrx(0): Cannot read int vect
[    85.814] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
[    85.814] (EE) fglrx(0): Invalid video BIOS signature!
[    85.814] (EE) fglrx(0): GetBIOSParameter failed
[    85.814] (EE) fglrx(0): PreInitAdapter failed
[    85.814] (EE) fglrx(0): PreInit failed
[    85.814] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
[    85.816] (II) UnloadModule: "fglrx"
[    85.816] (II) UnloadSubModule: "fglrxdrm"
[    85.816] (II) Unloading fglrxdrm
[    85.816] (II) UnloadSubModule: "vgahw"
[    85.816] (II) Unloading vgahw
[    85.816] (II) UnloadSubModule: "fglrxdrm"
[    85.816] (EE) Screen(s) found, but none have a usable configuration.
[    85.817] (EE)
Fatal server error:
[    85.817] (EE) no screens found(EE)
[    85.817] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    85.817] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    85.817] (EE)
[    85.821] (EE) Server terminated with error (1). Closing log file.

Offline kc1di

  • Newbie
  • *
  • Posts: 4
Re: module fglrx not found please help
« Reply #3 on: December 25, 2015, 02:59:28 pm »
Please go to a terminal and install inxi
Code: [Select]
sudo apt-get inxi
Then run the command
Code: [Select]
inxi -Fz and post the output here.

Living somewhere in Maine USA
Registered Linux User #462608

Offline travica77

  • Newbie
  • *
  • Posts: 27
Re: module fglrx not found please help
« Reply #4 on: December 25, 2015, 06:41:47 pm »
1;34mSystem:    Host: sparkuros Kernel: 4.3.0-1-amd64 x86_64 (64 bit) Console: tty 1 Distro: Sparky 4 Tyche
Machine:   System: LENOVO product: 20DHS00A00 v: ThinkPad E555
           Mobo: LENOVO model: 20DHS00A00 v: SDK0E50519 WIN Bios: LENOVO v: HTET45WW (1.17 ) date: 07/16/2015
CPU:       Quad core AMD A8-7100 Radeon R5 8 Compute Cores 4C+4G (-MCP-) cache: 8192 KB
           clock speeds: max: 1800 MHz 1: 1200 MHz 2: 1200 MHz 3: 1100 MHz 4: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R5 Graphics]
           Display Server: X.org 1.17.3 driver: (unloaded: fglrx) tty size: 170x48 Advanced Data: N/A out of X
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.3.0-1-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 250.1GB (34.2% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 77G used: 13G (18%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 145G used: 60G (44%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 49.8C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 146 Uptime: 0 min Memory: 221.6/6932.2MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.2.28 


Offline travica77

  • Newbie
  • *
  • Posts: 27
Re: module fglrx not found please help
« Reply #5 on: December 25, 2015, 08:24:18 pm »
Please help. Kernel 4.3.0.1 and fglrx not found. Any solution.

Offline kc1di

  • Newbie
  • *
  • Posts: 4
Re: module fglrx not found please help
« Reply #6 on: December 25, 2015, 11:46:48 pm »
from what I can tell here about kernel 4.3 , it no longer uses the fglrx module, but AMD driver is supposed to be resident in the kernel it self. however others have been having problems getting it to work also.  The only solution I know at the moment is to revert back to kernel 4.2 until it's gets patched or fixed.
The 4.3 kernel driver is working fine on my machine with an Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 7310]

good luck .
« Last Edit: December 25, 2015, 11:52:50 pm by kc1di »
Living somewhere in Maine USA
Registered Linux User #462608

Offline travica77

  • Newbie
  • *
  • Posts: 27
Re: module fglrx not found please help
« Reply #7 on: December 26, 2015, 10:01:05 pm »
Ok, thanks.
how to revert back to 4.2 kernel

Online paxmark1

  • Full Member
  • ***
  • Posts: 206
Re: module fglrx not found please help
« Reply #8 on: December 27, 2015, 04:23:36 pm »
To get a previous kernel that you have not deleted, reboot and then you can get it via the grub splash page - probably under "Advanced Options for Sparky Linux"  I presently have 4.3.0-1 and 4.2.0-1.  4.1 has been deleted via my usage of autoremove.  fwiw I always keep one older kernel. 

btw - did you install inxi as kc1di suggested.  It is a good tool.
« Last Edit: December 27, 2015, 04:27:44 pm by paxmark1 »
Don't make a FrankenDebian