Author Topic: Steam would not run after install but solved with script  (Read 2395 times)

Offline kulturedyobbo

  • Newbie
  • *
  • Posts: 12
  • Linux user 1999. PHP/MySQL http://barwinski.net
Steam would not run after install but solved with script
« on: October 25, 2015, 02:13:05 am »
Hi all

When I installed Steam (I was using Sparky 4.1, kernel 4.1, now Sparky 4.2, kernel 4.2.0-1-amd64), I found it would not run. However, after visiting an Ubuntu forum, I found that executing the following command from the command line:

LD_PRELOAD=’/usr/$LIB/libstdc++.so.6′ DIAPLAY=:0 steam

that steam would work. I have written this command into a script which is executed by clicking onto my edited steam shortcut. I am using SparkyLinux 4.2 Xfce x86_64, kernel 4.2.0-1-amd64 on an Acer Aspire 5745G Laptop using the xserver-xorg-video-nouveau 1:1.0.11-1+b1 amd64 X.Org X server -- Nouveau display driver.

Offline safensecure1176

  • Newbie
  • *
  • Posts: 5
Re: Steam would not run after install but solved with script
« Reply #1 on: January 13, 2016, 09:23:08 pm »
Hello:

I recently downloaded the latest XFCE version of Sparky Linux. However, after successfully installing Steam, the Steam launcher fails to load Steam. Nothing is displayed on the screen. I checked the /var/log/messages and see no error messages pertaining to this issue. I tried your script via CMD line and this still did not work. Do you have any further suggestions.

I'm using the 64bit version of Sparkly linux.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Steam would not run after install but solved with script
« Reply #2 on: January 15, 2016, 12:44:03 am »
Hi
Try to run steam in a text console and see the output.
Nothing is easy as it looks.

Offline safensecure1176

  • Newbie
  • *
  • Posts: 5
Re: Steam would not run after install but solved with script
« Reply #3 on: January 16, 2016, 04:10:52 am »
Here is the output:

/home/elitegaming/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
/home/elitegaming/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
Running Steam on sparky  64-bit
/home/elitegaming/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
awk: /home/elitegaming/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /lib/x86_64-linux-gnu/libreadline.so.6)
/bin/bash: /home/elitegaming/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
Installing breakpad exception handler for appid(steam)/version(1451690000)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Offline safensecure1176

  • Newbie
  • *
  • Posts: 5
Re: Steam would not run after install but solved with script
« Reply #4 on: January 17, 2016, 02:13:46 am »
From the error output. It appears the root cause is a video drive issue. Does anyone know the steps to resolve the issue?

Offline derekhess@live.ca

  • Newbie
  • *
  • Posts: 1
Re: Steam would not run after install but solved with script
« Reply #5 on: April 26, 2016, 07:41:24 pm »
Could you please shed some light on where and how to

" have written this command into a script which is executed by clicking onto my edited steam shortcut"

I am a nub and could not get the script to execute when i placed in the shortcut ?

i would appreciate any help. This has been frustrating me.