Author Topic: zswap failure?  (Read 2553 times)

Offline brian

  • Newbie
  • *
  • Posts: 23
zswap failure?
« on: October 01, 2015, 05:16:37 pm »
I have installed the v4 LXDE on my Lenovo W520 - i7 2960, 8GB Ram and 500GB Tosh HDD. I then updated the kernel to Licorix 4.2.2. through sparky.

I get error messages on the boot screens re. ZSWAP, ZBUD and ZPOOL.

Looking in the syslog I see:

Oct  1 09:39:39 t520sl4 kernel: zswap: loading zswap
Oct  1 09:39:39 t520sl4 kernel: input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
Oct  1 09:39:39 t520sl4 kernel: zpool: no driver for type zbud
Oct  1 09:39:39 t520sl4 kernel: zswap: zbud zpool not available
Oct  1 09:39:39 t520sl4 kernel: zswap: zpool creation failed

I understard that the ZSWAP stuff is designed to provide an intermediate to a swapfile to reduce the read/writes on SSDs.

My system seems to work fine, but the errors are a puzzle.

Any Comments?
« Last Edit: October 01, 2015, 06:29:50 pm by brian »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: zswap failure?
« Reply #1 on: October 01, 2015, 09:25:59 pm »
Can you try to install Sparky via the 4.1 image which is at Sourceforge now.
I uses newer kernel 4.1.6.
Nothing is easy as it looks.

Offline Alt

  • Newbie
  • *
  • Posts: 2
Re: zswap failure?
« Reply #2 on: October 01, 2015, 11:07:13 pm »
brian,
I have similar messages at boot (though using Linux Mint). Try 4.1 LTS, it should be fine. To do it whether change
Code: [Select]
deb http://liquorix.net/debian sid main
deb-src http://liquorix.net/debian sid main
to
Code: [Select]
deb http://liquorix.net/debian sid past
deb-src http://liquorix.net/debian sid past
or manualy download and install packages from here(/mirror)

Offline brian

  • Newbie
  • *
  • Posts: 23
Re: zswap failure?
« Reply #3 on: October 07, 2015, 06:27:25 pm »
Found this in the Liquorix web site forums. Looks like he hasn't got round to it.

"
=======================
Hi damentz,
Why are zram and zswap no longer configured in 4.0-1.dmz.1-liquorix-amd64?
I need them!
Back to top
=====================
Posted: Apr 30, 15, 18:22
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 598
Reply Quote
I disabled them thinking they contributed to the stalls that braveheartleo was affected by. However, after reading the description and reading some feedback, they look safe to keep enabled.

For example, zswap only compresses to swap partitions and zram has to be enabled specifically by the user. Since swap is normally slow, it should cause the system to stall _less_ due to the compression reducing the total number of bytes needed to write to disk, easily by a factor of 2. As for zswap, that's up to user discretion, so it was not my business to disable it.

Next release should have zswap and zram restored.
========================

""

This seems quite important for users with hybrid and SSD drives.

Regards.


Offline brian

  • Newbie
  • *
  • Posts: 23
Re: zswap failure?
« Reply #4 on: October 08, 2015, 04:47:33 pm »
Can you try to install Sparky via the 4.1 image which is at Sourceforge now.
I uses newer kernel 4.1.6.

The latest debian kernels 4.1...../4.2..... kernels have the ZSWAP stuff enabled. If you lok in the syslog you can see them being enabled.
I seems that its only the latest Liqorix kernels which have zswap stuff disabled as part of a trouble shooting exercise.(see comment by  "damentz" in my earlier post)

this could be important if you have an SSD or Hybrid drive - as it reduces the writes to the lifed solid state memory.
 




Offline Alt

  • Newbie
  • *
  • Posts: 2
Re: zswap failure?
« Reply #5 on: November 10, 2015, 01:51:08 pm »
Steven/damentz commented that there's need to configure zswap. I found how to do it here.
So few simple step:
1) Open grub config with your favourite text editor
Code: [Select]
sudo leafpad /etc/default/grub
Code: [Select]
sudo gedit /etc/default/grub2) add "zswap.zpool=zsmalloc" boot option
E.g.
Quote
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash zswap.zpool=zsmalloc"
3)
Code: [Select]
sudo update-grub