Author Topic: Bug? ALX ethernet falls down if used  (Read 911 times)

Offline rollinbeaver

  • Newbie
  • *
  • Posts: 15
Bug? ALX ethernet falls down if used
« on: July 30, 2015, 09:52:45 pm »
Hi,

on a new installation of Sparky 4.0 from today, a ALX driven Ethernet port starts a connection on the attached cable, but falls down after several Seconds, if used in earnest. Excerpt from my /var/log/syslog after the last reboot:
----
Jul 30 16:09:44 laptosh kernel: [    3.513874] alx 0000:01:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [00:26:6c:0d:4f:35]
Jul 30 16:09:44 laptosh kernel: [    3.593179] alx 0000:01:00.0 enp1s0: renamed from eth0
Jul 30 16:09:48 laptosh NetworkManager[802]: <info>  (enp1s0): new Ethernet device (driver: 'alx' ifindex: 2)
Jul 30 21:28:28 laptosh kernel: [15081.322495] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
Jul 30 21:28:38 laptosh kernel: [15091.605052] alx 0000:01:00.0 enp1s0: Link Down
Jul 30 21:28:58 laptosh kernel: [15111.680877] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
Jul 30 21:32:52 laptosh kernel: [15345.272119] alx 0000:01:00.0 enp1s0: Link Down
Jul 30 21:33:00 laptosh kernel: [15353.026848] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
Jul 30 21:38:06 laptosh kernel: [15659.201923] alx 0000:01:00.0 enp1s0: Link Down
----
Every time it went offline, i reconnected without problems. An "apt-get update" repeatedly stuck after some twenty lines or so, though.

Also, why the "renamed from eth0"? This plays havoc with any software expecting network interfaces to have 4 character names.
--
Regards,
-- rollinbeaver
--
regards, that rollinbeaver

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Bug? ALX ethernet falls down if used
« Reply #1 on: July 30, 2015, 10:38:04 pm »
Can you try to put the interface up manually, as root?
Code: [Select]
ifup eth0and show what happend.
Nothing is easy as it looks.

Offline rollinbeaver

  • Newbie
  • *
  • Posts: 15
Re: Bug? ALX ethernet falls down if used
« Reply #2 on: August 02, 2015, 07:21:17 pm »
Hi,

up to now, when the connection failed, i clicked it again in nm-applet's menu, causing a reconnection.
This restored the connection, but half an apt-get update later, it was down again.
Other than via Network Manager, i haven't tried the shell ifup and cannot now; i'm on the road and out of reach of a LAN cable for now.
So no, manual reconnection doesn't solve it IMHO.
--
Regards,
-- rollinbeaver

--
regards, that rollinbeaver

Offline paxmark1

  • Full Member
  • ***
  • Posts: 201
Re: Bug? ALX ethernet falls down if used
« Reply #3 on: August 03, 2015, 07:11:01 am »
Other forum elsewhere (siduction) had a post that systemd222 ( I believe it was 222) has new naming rules for networks.  I have not seen it yet (I am on sytemd223), possibly it only is applied for clean installs, will check more.  Not seen on Sparky4 enlightenment19 with connman (not network-manager) and systemd222-2 that has been up for a few weeks - sudo iwconfig shows wlan0  I will keep my eyes peeled for more on this.

Modified.  I couldn't find the thread on siduction, maybe it was on vsido.  But I found the same writer posting elsewhere

http://osdir.com/ ... is a mere reflection of https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=793374      I am not trying to understand all that they say, but the renaming thing might be fixed for you in 223-1

I am sorry I have no thoughts on the connection failing.  Except posibly "sudo ifup enp1s0" - but you have probably already tried that.
« Last Edit: August 03, 2015, 05:51:13 pm by paxmark1 »
Don't make a FrankenDebian