Author Topic: new e19 unavailable libbullet* in Sparky4.0  (Read 819 times)

Offline rollinbeaver

  • Newbie
  • *
  • Posts: 15
new e19 unavailable libbullet* in Sparky4.0
« on: July 30, 2015, 09:22:03 pm »
Hi,

noticed today that in my new Sparky 4.0 installation, e19 had several [UNAVAILABLE] dependencies, whose names all start with libbullet.
I had installed Sparky 4.0 and e19 once already, quite soon after the 4.0 release, and without a problem.
So i guess this is new. Could you please look into it, or alert the package maintainers?
Thank you.
--
Regards,
-- rollinbeaver
--
regards, that rollinbeaver

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: new e19 unavailable libbullet* in Sparky4.0
« Reply #1 on: July 30, 2015, 10:28:28 pm »
Hi
It happed because Debian devs removed libbullet* packages from the testing repos:
https://packages.debian.org/search?keywords=libbullet&searchon=names&suite=all&section=all&sourceid=mozilla-search
All the libbullet packs are available in stable and Sid repos in this moment, so enable Sid repo to install e19.

Let me know if the problem still exist - specially around libbullet*2.82 - 2.83
« Last Edit: July 30, 2015, 10:31:45 pm by pavroo »
Nothing is easy as it looks.

Offline rollinbeaver

  • Newbie
  • *
  • Posts: 15
Re: new e19 unavailable libbullet* in Sparky4.0
« Reply #2 on: August 02, 2015, 04:05:32 pm »
Hi pavroo,

your tip did indeed hit the spot: i got libbullet* from the stable branch no problem whatsoever. Thanks a bunch.
Now back to wrestling the systray position in my shelf...
--
Regards,
-- rollinbeaver
--
regards, that rollinbeaver

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: new e19 unavailable libbullet* in Sparky4.0
« Reply #3 on: August 05, 2015, 01:25:30 pm »
The new e19_0.19.99.20340 package of Enlightenment 0.19.7 needs libbullet* 2.83 instead of 2.82 so it shouldn't be a problem now.
Nothing is easy as it looks.

Offline rollinbeaver

  • Newbie
  • *
  • Posts: 15
Re: new e19 unavailable libbullet* in Sparky4.0
« Reply #4 on: August 05, 2015, 02:10:11 pm »
Hi,

quite so; v2.83 came without a hitch.
Hope sincerely that 0.19.7 fixes the WM losing window's focus and Systray and Appmenu showing nothing at all.

By the way: isn't that 66MB monolith e19 a rather un-debian-y way of packaging, since it supposedly contains several distinct components?
--
Regards,
-- rollinbeaver
--
regards, that rollinbeaver

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: new e19 unavailable libbullet* in Sparky4.0
« Reply #5 on: August 05, 2015, 11:21:26 pm »
Yes, the deb contains all the tools in one.
There is no excuse, and no time, I compile all of them at ones from the git repos.
Nothing is easy as it looks.