Author Topic: Problem After Dist-Upgrade With Exim4-base (Openbox Base)  (Read 1267 times)

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Problem After Dist-Upgrade With Exim4-base (Openbox Base)
« on: July 16, 2015, 06:54:41 pm »
Upgrade stopped with "Setting up exim4-base (4.86-RC4-2)".  Tried sudo dpkg --configure -a.  That did not do anything and apparently did not even launch.  Tried sudo dpkg-reconfigure exim4-config.   That launched a config program with many questions which I attempted to answer.  I do not think it completed, however.  To finish this long story, trying to use the terminal or synaptic for installing or removing purposes now just brings up:  "dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem".  As indicated that does not correct anything.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Problem After Dist-Upgrade With Exim4-base (Openbox Base)
« Reply #1 on: July 16, 2015, 11:57:05 pm »
Have you tried: sudo apt-get install -f
Nothing is easy as it looks.

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Problem After Dist-Upgrade With Exim4-base (Openbox Base)
« Reply #2 on: July 17, 2015, 12:48:23 am »
Unfortunately, any command that includes 'install", "remove", "fix", etc is stopped because I have not "corrected the problem",  to wit:
"sudo apt-get --no-remove -f install
[sudo] password for me:
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
me@e531:~$ sudo dpkg --configure -a
Setting up exim4-base (4.86~RC4-2) ..."

Then terminal freezes - let it sit for a long time, perhaps an hour or more.  Nothing happens.




Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Problem After Dist-Upgrade With Exim4-base (Openbox Base)
« Reply #3 on: July 17, 2015, 08:37:46 am »
I guess the problem has been fixed - at least apt-get, dpkg and synaptic are working normally; no packages are shown as broken and I have kernel 4.0.0-2.   I'll try to get a complete text copy of my terminal actions, which are quite long, up here in a day or two:  http://lxlinux.com/exim4-config.tex.

To sum up, I finally got sudo apt-get remove exim4-base to remove exim4-base along with bsd-mailx exim4  exim4-daemon-light.  After that I did sudo apt-get update and sudo apt-get upgrade and sudo apt-get autoremove.  Since I had more or less previously done the dist-upgrade, there were only 20 packages to upgrade and 1 package to autoremove.  Everything proceeded smoothly.

My question now is, am i going to be haunted in the future by the absence of these 4 exim packages?   I notice that exim4-config is still installed.

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Problem After Dist-Upgrade With Exim4-base (Openbox Base)
« Reply #4 on: July 23, 2015, 10:24:42 pm »
What does exim4 do that is important?  Did another dist-update yesterday on a different laptop, same Sparky system.  Again trouble with exim4.  Here is the end output:

"Setting up exim4-base (4.86~RC4-2) ...
[3945:3945:0722/012728:ERROR:desktop_window_tree_host_x11.cc(802)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)
ATTENTION: default value of option force_s3tc_enable overridden by environment.
/usr/local/bin/install: line 3: end: command not found
dpkg: error processing package exim4-base (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.86~RC4); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bsd-mailx:
 bsd-mailx depends on default-mta | mail-transport-agent; however:
  Package default-mta is not installed.
  Package exim4-daemon-light which provides default-mta is not configured yet.
  Package mail-transport-agent is not installed.
  Package exim4-daemon-light which provides mail-transport-agent is not configured yet.

dpkg: error processing package bsd-mailx (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4:
 exim4 depends on exim4-base (>= 4.86~RC4-2); however:
  Package exim4-base is not configured yet.
 exim4 depends on exim4-base (<< 4.86~RC4-2.1); however:
  Package exim4-base is not configured yet.
 exim4 depends on exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom; however:
  Package exim4-daemon-light is not configured yet.
  Package exim4-daemon-heavy is not installed.
  Package exim4-daemon-custom is not installed.

dpkg: error processing package exim4 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exim4-base
 exim4-daemon-light
 bsd-mailx
 exim4
E: Sub-process /usr/bin/dpkg returned an error code (1)"

However, this time apt-get and synaptic continued to function after warnings to fix exim.  In the end, I "fixed" them by just removing them.  Am I the only one with exim upgrading problems?

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Problem After Dist-Upgrade With Exim4-base (Openbox Base)[solved]
« Reply #5 on: July 25, 2015, 08:04:20 am »
Apparently mail transport agents are not important if your computer is not part of a big client-server network (https://en.wikipedia.org/wiki/Message_transfer_agent).   So I am replacing exim4, with the much lighter, simpler dma (dragonfly) agent.  Perhaps, at least Sparky Openbox, should consider doing the same in general.
« Last Edit: July 26, 2015, 06:35:29 pm by seppalta »