Author Topic: Sparky and Pipelight  (Read 809 times)

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Sparky and Pipelight
« on: July 08, 2015, 01:27:19 pm »
I love sparky a lot.  It's got openbox which i love for its simple looks and low resource.  Thought I do like to watch a movie on my computer and so i install pipelight.  Recently i installed Sparky 4.0 Openbox, advertised as no codecs.  This would be great if it were completely true.  Let me explain.  I have noticed that pipelight has stopped working with Sparky.  Help from the freenode chat with pipelight help has made it clear that multimedia codecs from the deb-multimedia.org repository are not compatible with multiarch and pipelight.  Fair enough, but on a new system that cam mean uninstalling a lot of your desktop.  So i propose that from now on, all files from that repo (deb-multimedia.org) not be used to ensure compatibility with with multiarch and programs that require the use of mulriarch compatible media drivers.  Also, i think it would be firring to move that repo into sources.list.d directory for people to activate later if they wish, like the many others there.  Now back to the files i deleted from openbox 4.0.  They weren't many and maybe they weren't from the deb-multimedia.org repo but i disabled the repo for my use just the same.  Here are the files I had to delete to install pipelight:  libasound2-plugins libavcodec56 libavresample2 libavutil54 libswresample1 pulseaudio pulseaudio-module-x11.  Small list to be sure but if you had a system loaded with codecs from deb-multimedia.org uninstalling those could have caused lots of other things to uninstall as well.  Food for thought to the powers that be.

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Sparky and Pipelight
« Reply #1 on: July 08, 2015, 07:46:04 pm »
Why do you need Pipelight?  I watch movies, videos, etc, online or downloaded.  I do not have Pipelight.  Of course, I do not use Ice Weasel/Firefox either.  Isn't that where the deficiency is?

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: Sparky and Pipelight
« Reply #2 on: July 09, 2015, 06:51:28 am »
the defeciency is in not in having an up to date flash, silverlight, and other options provided by pipelight.  HBO Now for example requires flash 17. pepperflash will not work with it, not even with a user agent overrider.

It isn't all movies either.  My healthcare provider's website uses silverlight and moonlight will not suffice. 

I thought since openbox is being purported as codec free it might be the place to ask about. 

Trying to install it on say lmde is tricky as i just tried it and had to remove 60 files that were in conflict with pipelight or dependent on files that are.