Author Topic: liquorix 4.0-4 & 4.0-5  (Read 1004 times)

Offline carlo

  • Full Member
  • ***
  • Posts: 199
liquorix 4.0-4 & 4.0-5
« on: June 09, 2015, 11:59:07 pm »
hi all
did you miss me?
today i've decided to install liquorix kernel as well: everything seemed so appealing
but...
to my discontent when i choose to boot from liquorix i get this message:

Code: [Select]
nvidiafb unable to setup mtrr
any clue if it is something i can easily fix, or it's soemthing which shall be fixed in next releases?

thank you

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: liquorix 4.0-4 & 4.0-5
« Reply #1 on: June 22, 2015, 11:33:24 am »
I hate those low-level issues. Sigh... ;)

Ok, let's see what we can try to do here. What is the output of this command (might need sudo):
Code: [Select]
cat /proc/mtrr
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline carlo

  • Full Member
  • ***
  • Posts: 199
Re: liquorix 4.0-4 & 4.0-5
« Reply #2 on: June 22, 2015, 11:44:20 am »
i've just found a way to solve it today frm mepis forum (so much to work today.. ::)):

it sounds like:
create /etc/modprobe.d/nvidiafb.conf
put "blacklist nvidiafb" in  it
depmode -ae
reboot
cross your fingers

it should depend on the fact that new liquorix (not that sure though) stuff loads the nouveau drivers in the earliest booting stages, much earlier than x can call nvidia/nouveau/whatever

so far it's working  ;D ;D ;D

what pisses me off is some kernel panic at booting, though i noticed that with previous version of normal kernel it was less bothering, the only way to make machine start pretty safely now is to switch it off as i get the kernel panic, mere rebooting will just change message
odd thing is that once the machine starts i get no freezing nor any other issue

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: liquorix 4.0-4 & 4.0-5
« Reply #3 on: June 22, 2015, 11:58:19 am »
We'll be getting the 4.0.5 Debian stock kernel soon, so you might want to try that one (I don't know if Pavroo already uploaded it or not) if Liqourix has problems.
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline carlo

  • Full Member
  • ***
  • Posts: 199
Re: liquorix 4.0-4 & 4.0-5
« Reply #4 on: June 22, 2015, 12:08:18 pm »
oh liquorix does work good, and looks faster than debian stock one...

actually both kernels don't work too good in booting
i start thinking it's the cheap motherboard which doesn't support two ram blocks too good...