Author Topic: using non unix auth with sparky tools such as update [Solved]  (Read 768 times)

Offline crypto

  • Newbie
  • *
  • Posts: 19
So fist i have to tell about my set up so someone can either direct me to ask in the right place, or know where i am to place the code..


So I do not use unix auth at all, i use pam usb only..... So when i go to run one of the sparky tools i get   

"
Failed to run /usr/bin/sparky-aptus-upgrade as user root.

Failed to communicate with gksu-run-helper.

Received:
 * Device "ADkey" is connected (good).
* Performing one time pad verification...

While expecting:
 gksu: waiting
"

Now i remeber seeing code that i could find again that was for gksu and pam usb ... i think it omitted the pam usb lines from the "password"


So the question is Where would i put that code to correct the above issue?


Or where should i be asking ?

Thanks     

« Last Edit: June 07, 2015, 11:54:34 pm by crypto »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: using non unix auth with sparky tools such as update
« Reply #1 on: June 07, 2015, 12:43:44 pm »
Change "remsu" for what you need:
/usr/share/applications/sparky-aptus-upgrade.desktop
Nothing is easy as it looks.

Offline crypto

  • Newbie
  • *
  • Posts: 19
Re: using non unix auth with sparky tools such as update [Solved]
« Reply #2 on: June 07, 2015, 11:55:40 pm »
Great, that was way easier than i thought it was going to be

Thanks.