Author Topic: volid option of ISO file  (Read 1033 times)

Offline patrick

  • Newbie
  • *
  • Posts: 3
volid option of ISO file
« on: June 02, 2015, 01:57:18 am »
I think the problem is I didn't comment out 64 bit option
and the ISO file was not created.     It looks like there is a
full /live and /isolinux directory's in /ISOTMP.

Can I manually make the ISO from there with genisoimage,
or is the whole process needed again ?     Filesystem.squash
is 912 MB.      I'm almost tempted to do a frugal install,
everything looks like it's there.

Advise ?

THX

edit: frugal setup boots but will not accept user/password at
graphic login screen.   
« Last Edit: June 02, 2015, 03:02:10 am by patrick »

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: volid option of ISO file
« Reply #1 on: June 02, 2015, 01:36:19 pm »
If you vave the squashfs made already, go to directory:
Code: [Select]
/ISOTEMP/ISOMOUNTand create the iso manually:
Code: [Select]
xorriso -as mkisofs -rock -omit-version-number -disable-deep-relocation -joliet -allow-leading-dots -volid "your-volid-name" -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -e boot/grub/efi.img -no-emul-boot -o "/patch-to-working-dir/new-image.iso" "/patch-to-working-dir/ISOTEMP/ISOMOUNT"
« Last Edit: June 02, 2015, 02:18:57 pm by pavroo »
Nothing is easy as it looks.

Offline patrick

  • Newbie
  • *
  • Posts: 3
Re: volid option of ISO file
« Reply #2 on: June 02, 2015, 10:13:11 pm »
Hi,

I think the iso refuses to create because the working
directory is another hard drive.    So I make an iso out
of /ISOTEMP and it refuses to login.      Boots into the
lightdm screen.         What next ?       It's stuck there
with incorrect password.

thanks for the response,

Patrick

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: volid option of ISO file
« Reply #3 on: June 03, 2015, 12:54:35 pm »
It happens when the live user's /home directory is to large.
Have you put extra files to /etc/skel dir or have you installed something what is installed in /home directory, such as steam or so?

The second possible reason is new version of live scripts. Have you upgraded packages of the chrooted system before making new iso?
« Last Edit: June 03, 2015, 01:20:06 pm by pavroo »
Nothing is easy as it looks.