Author Topic: did an upgrade had some broken packages  (Read 1053 times)

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
did an upgrade had some broken packages
« on: May 28, 2015, 11:37:06 am »
uninstalled some broken packages after an upgrade and now my .desktop icons with pkexec dont work.  cant find pkexec in synaptic to install it.  synaptic wont run from the icon, same for gparted gufw printer-settings etc.

also im on openbox

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: did an upgrade had some broken packages
« Reply #1 on: May 28, 2015, 11:53:56 am »
What have you uninstalled?

There in not 'pkexec' package in the repos.
Some tools use 'pkexec' to get root privileges, for example:
Code: [Select]
synaptic-pkexec
Nothing is easy as it looks.

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #2 on: May 28, 2015, 11:26:53 pm »
some lxde packages that were installed with openbox.  im not sure which ones now.  the pkexec isnt working with the apps anymore

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: did an upgrade had some broken packages
« Reply #3 on: May 28, 2015, 11:37:03 pm »
I don't think it's a problem with pkexec.
Show me the output of the commands:
Code: [Select]
apt-cache policy lxpolkit
apt-cache policy lxsession*
cat /var/log/apt/history.log
Have you installed (or tried) LXDE over the Openbox spin?
« Last Edit: May 28, 2015, 11:43:22 pm by pavroo »
Nothing is easy as it looks.

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #4 on: May 28, 2015, 11:59:47 pm »
ive seen the lkde spins in other distros.  i like openbox a lot.  the translucent tint2 the way i have it set up is minimal and nice looking.  Yes i struggled to get it that way but i have the config files saved and distro hopping from each openbox i learn something new and refine how i use it.

i have to reinstall the 64 bit.  give me a few minutes.  i have 32 bit installed and i think that's working ok.  I ran into trouble reinstalling the 64 and after i updated the system and installed steam first as i had learned to do, pipelight installation uninstalled half my system... 

the one thing i dont like about openbox is that when i adjust the monitor reolution it doesn't save it across reboots like other distros do.  using it on the meerkat connected to the tv the resolution returns to 1920x1080 and i have to adjust the resolution, nitrogen and conky every time, doesn'y matter the distro, it's openbox specific it seems.  even running lxrandr as root is of no use.

be back in a few...

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #5 on: May 29, 2015, 12:03:25 am »
i really don't like the lxde or xfce panels much

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: did an upgrade had some broken packages
« Reply #6 on: May 29, 2015, 12:42:29 am »
Quote
the one thing i dont like about openbox is that when i adjust the monitor reolution it doesn't save it
Read the post, should help:
http://sparkylinux.org/how-to-set-monitor-resolution/

In your case (Openbox), as the last think to do, add it to Openbox startup file:
Code: [Select]
~HOME/.config/openbox/autostart.sh
« Last Edit: May 29, 2015, 12:46:58 am by pavroo »
Nothing is easy as it looks.

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #7 on: May 29, 2015, 01:31:16 am »
thanks for that tip.  Im familiar with the autostart and use it previously with plank

the 32 bit wouldn't boot, even after parted magic boot fix,  installed 64 bit but pipelight wont install.  wine-staging errors


so i installed 3.6 openbox changed the repos to jessie from testing since it is jessie at that stage.  do a dist-upgrade first before pipelight install or not, just to have all of jessie?

aptitude reports this situation

Code: [Select]

      Remove the following packages:                           
1)      build-essential                                       
2)      g++                                                   
3)      g++-4.9                                               
4)      gcc                                                   
5)      gcc-4.7                                               
6)      gcc-4.8                                               
7)      gcc-4.9                                               
8)      libasound2-plugins                                     
9)      libavcodec56                                           
10)     libavresample2                                         
11)     libavutil54                                           
12)     libgcc-4.7-dev                                         
13)     libgcc-4.8-dev                                         
14)     libgcc-4.9-dev                                         
15)     libitm1                                               
16)     libmp3lame0                                           
17)     libstdc++-4.9-dev                                     
18)     libswresample1                                         
19)     libtxc-dxtn0                                           
20)     libx264-142                                           
21)     libxvidcore4                                           
22)     linux-wlan-ng-firmware                                 
23)     pulseaudio                                             
24)     pulseaudio-module-x11                                 

      Install the following packages:                         
25)     libgettextpo0:i386 [0.19.3-2 (stable)]                 
26)     libunistring0:i386 [0.9.3-5.2+b1 (stable)]             
27)     tcc [0.9.27~git20140923.9d7fb33-3 (stable)]           
28)     wine-staging:i386 [1.7.42~jessie (testing)]           

      Keep the following packages at their current version:   
29)     va-driver-all:i386 [Not Installed]                     
30)     vdpau-va-driver:i386 [Not Installed]                   
31)     wine-staging [Not Installed]                           
32)     wine-staging-amd64 [Not Installed]                     

      Upgrade the following packages:                         
33)     cpp-4.9 [4.9.1-19 (now) -> 4.9.2-10 (stable)]         
34)     cups [1.7.5-9 (now) -> 1.7.5-11 (stable)]             
35)     cups-client [1.7.5-9 (now) -> 1.7.5-11 (stable)]       
36)     cups-common [1.7.5-9 (now) -> 1.7.5-11 (stable)]       
37)     cups-core-drivers [1.7.5-9 (now) -> 1.7.5-11 (stable)]
38)     cups-daemon [1.7.5-9 (now) -> 1.7.5-11 (stable)]       
39)     cups-server-common [1.7.5-9 (now) -> 1.7.5-11 (stable)]
40)     libasan1 [4.9.1-19 (now) -> 4.9.2-10 (stable)]         
41)     libatomic1 [4.9.1-19 (now) -> 4.9.2-10 (stable)]       
42)     libc-dev-bin [2.19-13 (now) -> 2.19-18 (stable)]       
43)     libc6-dev [2.19-13 (now) -> 2.19-18 (stable)]         
44)     libcilkrts5 [4.9.1-19 (now) -> 4.9.2-10 (stable)]     
45)     libcupscgi1 [1.7.5-9 (now) -> 1.7.5-11 (stable)]       
46)     libcupsimage2 [1.7.5-9 (now) -> 1.7.5-11 (stable)]     
47)     libcupsmime1 [1.7.5-9 (now) -> 1.7.5-11 (stable)]     
48)     libcupsppdc1 [1.7.5-9 (now) -> 1.7.5-11 (stable)]     
49)     libgfortran3 [4.9.1-19 (now) -> 4.9.2-10 (stable)]     
50)     libgnutls-openssl27 [3.3.8-5 (now) -> 3.3.8-6 (stable)]
51)     libgomp1 [4.9.1-19 (now) -> 4.9.2-10 (stable)]         
52)     liblsan0 [4.9.1-19 (now) -> 4.9.2-10 (stable)]         
53)     libpam-systemd [215-7 (now) -> 215-17 (stable)]       
54)     libquadmath0 [4.9.1-19 (now) -> 4.9.2-10 (stable)]     
55)     libtsan0 [4.9.1-19 (now) -> 4.9.2-10 (stable)]         
56)     libubsan0 [4.9.1-19 (now) -> 4.9.2-10 (stable)]       
57)     locales [2.19-13 (now) -> 2.19-18 (stable)]           
58)     systemd [215-7 (now) -> 215-17 (stable)]               
59)     systemd-sysv [215-7 (now) -> 215-17 (stable)]         
60)     udev [215-7 (now) -> 215-17 (stable)]                 

      Leave the following dependencies unresolved:             
61)     dpkg-dev recommends build-essential                   


Accept this solution? [Y/n/q/?] 



Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #8 on: May 29, 2015, 03:21:40 am »
Quote
the one thing i dont like about openbox is that when i adjust the monitor reolution it doesn't save it
Read the post, should help:
http://sparkylinux.org/how-to-set-monitor-resolution/

In your case (Openbox), as the last think to do, add it to Openbox startup file:
Code: [Select]
~HOME/.config/openbox/autostart.sh

it's not working

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: did an upgrade had some broken packages
« Reply #9 on: May 29, 2015, 07:57:35 pm »
Show me an output of the command:
Code: [Select]
xrandr -q
Nothing is easy as it looks.

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #10 on: May 30, 2015, 12:41:23 am »
i found a bug in the autostart directory desktop file for lxradr that listed a line that says only show in lxde.  deleted that line and now it works.

Offline Lizbeth

  • Jr. Member
  • **
  • Posts: 68
Re: did an upgrade had some broken packages
« Reply #11 on: May 30, 2015, 12:43:02 am »
solved that but since you asked, here it is

Code: [Select]
xrandr -q
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 32767 x 32767
HDMI1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 880mm x 490mm
   1920x1080     60.00 +  50.00    59.94    24.00    23.98 
   1920x1080i    60.00    50.00    59.94 
   1680x1050     59.88 
   1600x900      59.98 
   1280x1024     75.02 
   1440x900      59.90*
   1360x768      60.02 
   1152x864      75.00 
   1280x720      60.00    50.00    59.94 
   1440x576i     50.00 
   1024x768      75.08    70.07    60.00 
   1440x480i     60.00    59.94 
   800x600       72.19    75.00    60.32    56.25 
   720x576       50.00 
   720x480       60.00    59.94    59.94 
   640x480       75.00    72.81    60.00    59.94 
   720x400       70.08 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)