Author Topic: [Solved] VMware Player/Workstation  (Read 4908 times)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
[Solved] VMware Player/Workstation
« on: March 26, 2015, 11:34:33 am »
Using APTus Extra/synaptic VMware Player module compiler runs and installs no problem ,
but when I try and install Workstation 10 the compiler fails at  virtual network device.
Anybody help please ?
« Last Edit: March 30, 2015, 11:29:58 pm by The Black Pig »

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #1 on: March 29, 2015, 08:45:18 am »
We can try to check what's going on, but some insight would be required. What does it output when it fails?
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: VMware Player/Workstation
« Reply #2 on: March 29, 2015, 02:09:45 pm »
OK - running latest version of JWM
Install sequence
http://i.imgur.com/kdDioj4.png
http://i.imgur.com/O3SD56U.png
http://i.imgur.com/ceoYbMv.png
and where it fails
http://i.imgur.com/wKDVHSK.png

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #3 on: March 30, 2015, 10:04:32 am »
Is there anything in the log file mentioned on the last screenshot?
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: VMware Player/Workstation
« Reply #4 on: March 30, 2015, 12:33:02 pm »
2015-03-30T10:22:49.303Z| vthread-3| I120: Log for VMware Workstation pid=22131 version=10.0.1 build=build-1379776 option=Release
2015-03-30T10:22:49.303Z| vthread-3| I120: The process is 64-bit.
2015-03-30T10:22:49.303Z| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
2015-03-30T10:22:49.303Z| vthread-3| I120: Host is Linux 3.16.0-4-amd64 Debian GNU/Linux 8.0 (jessie)
2015-03-30T10:22:49.303Z| vthread-3| I120: Msg_Reset:
2015-03-30T10:22:49.303Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2015-03-30T10:22:49.303Z| vthread-3| I120: ----------------------------------------
2015-03-30T10:22:49.303Z| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2015-03-30T10:22:49.303Z| vthread-3| I120: Msg_Reset:
2015-03-30T10:22:49.303Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/home/john/.vmware/config": No such file or directory.
2015-03-30T10:22:49.303Z| vthread-3| I120: ----------------------------------------
2015-03-30T10:22:49.303Z| vthread-3| I120: PREF Optional preferences file not found at /home/john/.vmware/config. Using default values.
2015-03-30T10:22:49.303Z| vthread-3| I120: PREF Unable to check permissions for preferences file.
2015-03-30T10:22:49.303Z| vthread-3| I120: Msg_Reset:
2015-03-30T10:22:49.303Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/home/john/.vmware/preferences": No such file or directory.
2015-03-30T10:22:49.303Z| vthread-3| I120: ----------------------------------------
2015-03-30T10:22:49.303Z| vthread-3| I120: PREF Failed to load user preferences.
2015-03-30T10:22:49.303Z| vthread-3| W110: Logging to /tmp/vmware-root/vmware-modconfig-22131.log
2015-03-30T10:22:49.316Z| vthread-3| I120: Obtaining info using the running kernel.
2015-03-30T10:22:49.316Z| vthread-3| I120: Created new pathsHash.
2015-03-30T10:22:49.316Z| vthread-3| I120: Setting header path for 3.16.0-4-amd64 to "/lib/modules/3.16.0-4-amd64/build/include".
2015-03-30T10:22:49.316Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.316Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.316Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.316Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.320Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.320Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.371Z| vthread-3| I120: Reading in info for the vmmon module.
2015-03-30T10:22:49.371Z| vthread-3| I120: Reading in info for the vmnet module.
2015-03-30T10:22:49.371Z| vthread-3| I120: Reading in info for the vmblock module.
2015-03-30T10:22:49.371Z| vthread-3| I120: Reading in info for the vmci module.
2015-03-30T10:22:49.371Z| vthread-3| I120: Reading in info for the vsock module.
2015-03-30T10:22:49.371Z| vthread-3| I120: Setting vsock to depend on vmci.
2015-03-30T10:22:49.371Z| vthread-3| I120: Invoking modinfo on "vmmon".
2015-03-30T10:22:49.372Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.373Z| vthread-3| I120: Invoking modinfo on "vmnet".
2015-03-30T10:22:49.374Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.374Z| vthread-3| I120: Invoking modinfo on "vmblock".
2015-03-30T10:22:49.375Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.375Z| vthread-3| I120: Invoking modinfo on "vmci".
2015-03-30T10:22:49.376Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.376Z| vthread-3| I120: Invoking modinfo on "vsock".
2015-03-30T10:22:49.377Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.
2015-03-30T10:22:49.387Z| vthread-3| I120: to be installed: vmmon status: 0
2015-03-30T10:22:49.387Z| vthread-3| I120: to be installed: vmnet status: 0
2015-03-30T10:22:49.394Z| vthread-3| I120: Obtaining info using the running kernel.
2015-03-30T10:22:49.394Z| vthread-3| I120: Setting header path for 3.16.0-4-amd64 to "/lib/modules/3.16.0-4-amd64/build/include".
2015-03-30T10:22:49.394Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.394Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.394Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.394Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.398Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.398Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.448Z| vthread-3| I120: Kernel header path retrieved from FileEntry: /lib/modules/3.16.0-4-amd64/build/include
2015-03-30T10:22:49.448Z| vthread-3| I120: Update kernel header path to /lib/modules/3.16.0-4-amd64/build/include
2015-03-30T10:22:49.448Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.448Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.448Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.448Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.453Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.453Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.453Z| vthread-3| I120: Found compiler at "/usr/bin/gcc"
2015-03-30T10:22:49.455Z| vthread-3| I120: Got gcc version "4.9.2".
2015-03-30T10:22:49.455Z| vthread-3| I120: GCC minor version 4 does not match Kernel GCC minor version 4.  But that is ok.
2015-03-30T10:22:49.455Z| vthread-3| I120: Using user supplied compiler "/usr/bin/gcc".
2015-03-30T10:22:49.457Z| vthread-3| I120: Got gcc version "4.9.2".
2015-03-30T10:22:49.457Z| vthread-3| I120: GCC minor version 4 does not match Kernel GCC minor version 4.  But that is ok.
2015-03-30T10:22:49.460Z| vthread-3| I120: Trying to find a suitable PBM set for kernel "3.16.0-4-amd64".
2015-03-30T10:22:49.460Z| vthread-3| I120: No matching PBM set was found for kernel "3.16.0-4-amd64".
2015-03-30T10:22:49.460Z| vthread-3| I120: GCC minor version 4 does not match Kernel GCC minor version 4.  But that is ok.
2015-03-30T10:22:49.460Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.460Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.460Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.460Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.464Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.464Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.465Z| vthread-3| I120: GCC minor version 4 does not match Kernel GCC minor version 4.  But that is ok.
2015-03-30T10:22:49.465Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.465Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.465Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.465Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.469Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.469Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.469Z| vthread-3| I120: Using temp dir "/tmp".
2015-03-30T10:22:49.470Z| vthread-3| I120: Obtaining info using the running kernel.
2015-03-30T10:22:49.470Z| vthread-3| I120: Setting header path for 3.16.0-4-amd64 to "/lib/modules/3.16.0-4-amd64/build/include".
2015-03-30T10:22:49.470Z| vthread-3| I120: Validating path "/lib/modules/3.16.0-4-amd64/build/include" for kernel release "3.16.0-4-amd64".
2015-03-30T10:22:49.470Z| vthread-3| I120: Failed to find /lib/modules/3.16.0-4-amd64/build/include/linux/version.h
2015-03-30T10:22:49.470Z| vthread-3| I120: /lib/modules/3.16.0-4-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-03-30T10:22:49.470Z| vthread-3| I120: using /usr/bin/gcc-4.8 for preprocess check
2015-03-30T10:22:49.474Z| vthread-3| I120: Preprocessed UTS_RELEASE, got value "3.16.0-4-amd64".
2015-03-30T10:22:49.474Z| vthread-3| I120: The header path "/lib/modules/3.16.0-4-amd64/build/include" for the kernel "3.16.0-4-amd64" is valid.  Whoohoo!
2015-03-30T10:22:49.525Z| vthread-3| I120: Invoking modinfo on "vmmon".
2015-03-30T10:22:49.526Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.526Z| vthread-3| I120: Invoking modinfo on "vmnet".
2015-03-30T10:22:49.527Z| vthread-3| I120: "/sbin/modinfo" exited with status 256.
2015-03-30T10:22:49.697Z| vthread-3| I120: Setting destination path for vmmon to "/lib/modules/3.16.0-4-amd64/misc/vmmon.ko".
2015-03-30T10:22:49.697Z| vthread-3| I120: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
2015-03-30T10:22:49.702Z| vthread-3| I120: Successfully extracted the vmmon source.
2015-03-30T10:22:49.702Z| vthread-3| I120: Building module with command "/usr/bin/make -j2 -C /tmp/modconfig-xren7A/vmmon-only auto-build HEADER_DIR=/lib/modules/3.16.0-4-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2015-03-30T10:22:51.915Z| vthread-3| I120: Successfully built vmmon.  Module is currently at "/tmp/modconfig-xren7A/vmmon.o".
2015-03-30T10:22:51.915Z| vthread-3| I120: Found the vmmon symvers file at "/tmp/modconfig-xren7A/vmmon-only/Module.symvers".
2015-03-30T10:22:51.915Z| vthread-3| I120: Installing vmmon from /tmp/modconfig-xren7A/vmmon.o to /lib/modules/3.16.0-4-amd64/misc/vmmon.ko.
2015-03-30T10:22:51.916Z| vthread-3| I120: Registering file "/lib/modules/3.16.0-4-amd64/misc/vmmon.ko".
2015-03-30T10:22:52.157Z| vthread-3| I120: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
2015-03-30T10:22:52.157Z| vthread-3| I120: Registering file "/usr/lib/vmware/symvers/vmmon-3.16.0-4-amd64".
2015-03-30T10:22:52.416Z| vthread-3| I120: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
2015-03-30T10:22:52.418Z| vthread-3| I120: Setting destination path for vmnet to "/lib/modules/3.16.0-4-amd64/misc/vmnet.ko".
2015-03-30T10:22:52.418Z| vthread-3| I120: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2015-03-30T10:22:52.424Z| vthread-3| I120: Successfully extracted the vmnet source.
2015-03-30T10:22:52.424Z| vthread-3| I120: Building module with command "/usr/bin/make -j2 -C /tmp/modconfig-xren7A/vmnet-only auto-build HEADER_DIR=/lib/modules/3.16.0-4-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2015-03-30T10:22:54.485Z| vthread-3| W110: Failed to build vmnet.  Failed to execute the build command.

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #5 on: March 30, 2015, 01:28:50 pm »
I've searched around a bit for the vmnet failure and it seems that VMP 10 doesn't support newer kernels or looking at it the other way around: the newer kernel code (above 3.13) has changed in the area with VMP uses to compile it's modules. Some people suggest patching a few files, for example:

https://communities.vmware.com/message/2484547#2484547

If for whatever reason you can't do it, I can try doing that later on today, after I get back from work.
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: VMware Player/Workstation
« Reply #6 on: March 30, 2015, 03:53:26 pm »
It's strange.
I have VMware Player 7 installed on Jessie 3.16.0-4-amd64 kernel.
Nothing is easy as it looks.

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #7 on: March 30, 2015, 03:56:33 pm »
I have VMware Player 7 installed on Jessie 3.16.0-4-amd64 kernel.

Yes. Version up to 8.x works (for what I have read). The problems start somewhere around 9.x and up. So it seems that it's not only the kernel code changes, but also VMWare code changes that create the problem. I'll have to install the exact same version (although I have the latest Liquorix kernel 3.19.2, but I guess I'll return to 3.16 for the time of testing) and try to recreate the issue.
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: VMware Player/Workstation
« Reply #8 on: March 30, 2015, 04:05:28 pm »
Yup I can install  VMware Player 7 on any new Sparky dist. but not Workstation.
The strange thing is I'm running it OK in Sparky RazorQT ver 3.3.1 !!
Would be grateful MoroS if you could look into it as reading that link I find a bit complicated for a 72yr old lol 

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1463
    • SparkyLinux
Re: VMware Player/Workstation
« Reply #9 on: March 30, 2015, 04:42:30 pm »
Quote
Yes. Version up to 8.x works
Right, I missed that it's workstation 10 not player.
Nothing is easy as it looks.

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #10 on: March 30, 2015, 05:00:24 pm »
I missed that it's workstation 10 not player.

I missed that it's Workstation overall a few posts earlier. :D Luckily there's a trial version available and I only need one for the sake of testing the setup and creating a patched file. ;)
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #11 on: March 30, 2015, 09:39:24 pm »
@The Black Pig: I've patched the vmnet.tar file to include changes for the Debian's 3.16 kernel. It's for the 10.0.5 version of VMWare Workstation, so make sure you have that one installed. You can download the modified tarball here:

(link two posts below)

The moment the installer asks you to build/install the modules, don't click "Install" yet. Go to the /usr/lib/vmware/modules/source folder, move the original vmnet.tar file out of the way (back it up somewhere, just in case) and place the downloaded tarball there instead. Then click "Install". The module building process should go without problems (I hope... I've tested it against the Debian's 3.16 kernel source, it the Sparky's default kernel).
« Last Edit: July 24, 2015, 06:45:52 pm by MoroS »
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: VMware Player/Workstation
« Reply #12 on: March 30, 2015, 11:29:02 pm »
@MoroS , you sir are a genius , followed your instructions installed Workstation no problem  ;D ;D ;D ;D

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 255
  • Problem solver ;)
Re: VMware Player/Workstation
« Reply #13 on: March 30, 2015, 11:41:55 pm »
installed Workstation no problem  ;D ;D ;D ;D

Glad it worked. :)

For future's sake (we will probably be seeing that kind of error when VMWare Workstation gets an update or someone has a different kernel version) I've renamed the file to mark the versions of VMW and Debian's kernel. The new link is:

EDIT: I moved the files to a public Google Drive folder. Here's the link:
https://drive.google.com/folderview?id=0B3uG8VMO0vocfjBZVmxqU0dTa2hhekREYndoZ3R5TUl0UmR2NG5mRjVVdnJpT09mYmZrTFU&usp=sharing&tid=0B3uG8VMO0vocfks1TzBGQXA1a1hUcUp1N3ppUUI0TnZXN2VieGstamdObDlzSFQySFRmV1k

If in the future a similar issue happens, I'll just prepare another package for a different version.  The person that downloads it will additionally have to rename the file to "vmnet.tar" and place it in the /usr/lib/vmware/modules/source folder prior to building/installing the modules.
« Last Edit: July 24, 2015, 06:49:39 pm by MoroS »
There isn't a single thing that's impossible. Just the things that we don't yet know how to deal with. ;)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: [Solved] VMware Player/Workstation
« Reply #14 on: March 31, 2015, 12:33:11 am »
This could be good publicity for Sparky as it's a very common (unsolved) problem,  ;) ;)