Author Topic: Unable to install E19 [SOLVED]  (Read 808 times)

Offline one23

  • Newbie
  • *
  • Posts: 26
Unable to install E19 [SOLVED]
« on: March 07, 2015, 05:54:28 pm »
I am unable to install latest reincarnation of Enlightenment.

Here's what I get

Code: [Select]
The following extra packages will be installed:
  radiance-e19-sparky
The following NEW packages will be installed:
  e19 radiance-e19-sparky
0 upgraded, 2 newly installed, 0 to remove and 24 not upgraded.
Need to get 0 B/58.6 MB of archives.
After this operation, 150 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package radiance-e19-sparky.
(Reading database ... 144485 files and directories currently installed.)
Preparing to unpack .../radiance-e19-sparky_0.1.2_all.deb ...
Unpacking radiance-e19-sparky (0.1.2) ...
Preparing to unpack .../e19_0.19.99.19581_amd64.deb ...
Unpacking e19 (0.19.99.19581) ...
dpkg: error processing archive /var/cache/apt/archives/e19_0.19.99.19581_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/edje_inspector', which is also in package libedje-bin 1.8.6-2.1+b2
Errors were encountered while processing:
 /var/cache/apt/archives/e19_0.19.99.19581_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


« Last Edit: March 08, 2015, 01:05:13 pm by one23 »

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1462
    • SparkyLinux
Re: Unable to install E19
« Reply #1 on: March 07, 2015, 11:07:13 pm »
Before installing e19 remove e17/e18 and all its components.
Nothing is easy as it looks.

Offline one23

  • Newbie
  • *
  • Posts: 26
Re: Unable to install E19
« Reply #2 on: March 07, 2015, 11:27:34 pm »
I did what you suggest. Unless I'm missing something obvious.
« Last Edit: March 07, 2015, 11:34:03 pm by one23 »

Online pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1462
    • SparkyLinux
Re: Unable to install E19
« Reply #3 on: March 07, 2015, 11:33:01 pm »
libedje-bin for example.
Try to find them in Synaptic using e17/e18/enlightenment keywords.
Nothing is easy as it looks.

Offline one23

  • Newbie
  • *
  • Posts: 26
Re: Unable to install E19 [SOLVED]
« Reply #4 on: March 08, 2015, 12:59:52 pm »
Removing all enlightenment related libraries solved the issue.

Many thanks
« Last Edit: March 08, 2015, 01:04:40 pm by one23 »