Author Topic: {Solved} Adding alsamixer to desktop or Wbar?  (Read 783 times)

Offline PNWDrew

  • Jr. Member
  • **
  • Posts: 50
{Solved} Adding alsamixer to desktop or Wbar?
« on: January 18, 2015, 06:02:13 am »
I have constant problems with audio, requiring me to start alsamixer in terminal and reselect the USB soundcard frequently (10+ per day).  Simply leaving alsamixer open between resets doesn't seem to work to correct the silence.
I'd like to simplify the process and either add a desktop icon or ideally a wbar icon to launch alsamixer without first launching terminal and typing alsamixer command...

It seems like a trivial step but I have to do this many times per day >:(, so anything to reduce the annoyance level is nice. I'm trying to avoid giving up on using these Logitech Z-5 USB speakers as I like them and don't want to spend $ on another set.

I tried the method I used to set up other shortcuts on wbar but it doesn't launch; ie ..using "alsamixer" as the command to open as I would in terminal. This worked for Chrome Beta, Iceweasel, VLC, etc...

What am I doing wrong?

Thanks,
Drew
« Last Edit: January 20, 2015, 06:47:06 am by PNWDrew »

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Adding alsamixer to desktop or Wbar?
« Reply #1 on: January 18, 2015, 08:09:36 am »
My logitech 5-way  external speakers generally work automatically without preliminary configuration.  But then I use pulse audio instead of alsa-mixer.  I would think that just setting your vlc player (audio>Audio Device)  to the 5-way choice should set it even with alsa.
http://lxlinux.com/#15

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Adding alsamixer to desktop or Wbar?
« Reply #2 on: January 18, 2015, 12:29:42 pm »
Alsamixer has to be open in a text console so the desktop or wbar launcher should be like that:
Code: [Select]
x-terminal-emulator -e alsamixer
Nothing is easy as it looks.

Offline PNWDrew

  • Jr. Member
  • **
  • Posts: 50
Re: Adding alsamixer to desktop or Wbar?
« Reply #3 on: January 18, 2015, 05:57:09 pm »
Alsamixer has to be open in a text console so the desktop or wbar launcher should be like that:
Code: [Select]
x-terminal-emulator -e alsamixer

Thanks! That worked. I knew it would be something simple. I've got a lot to learn.

 
My logitech 5-way  external speakers generally work automatically without preliminary configuration.  But then I use pulse audio instead of alsa-mixer.  I would think that just setting your vlc player (audio>Audio Device)  to the 5-way choice should set it even with alsa.
http://lxlinux.com/#15

Z-5 speakers are USB 2-way and I think USB may be what breaks audio. Usually I can get audio to work from any source, however if I switch sources it may not work in the next one.  When I was using Sparky 32bit it was fine out of box, but in 64bit it has never worked properly. 

So if I am streaming Play Music through browser then want to watch a video on VLC I have to shut down all processes that might want to use the speakers (whether or not anything is actually playing) and start alsamixer to reselect USB. Often I have to I manually close all Chrome processes, VLC, whatever in Task Manager. Even if I leave the volume control in panel it may not work. Sometimes I need to unplug the USB speakers briefly also.  It is rather annoying.

I tried pulse audio a while back but had other problems, I don't recall if it was on this install or not at this point.  I'm hesitant to try again as at least I have found a fragile ceasefire with my speakers.