Author Topic: [Solved]Boot  (Read 1614 times)

Offline Calatea

  • Newbie
  • *
  • Posts: 23
[Solved]Boot
« on: December 26, 2014, 10:33:53 pm »
Hi, I've installated Sparky LXDE on /dev/sda4, on /dev/sda 2 I've Lubuntu, but I can't choose at boot because this message appears: "debian has been blocked by the current security policy" [ok] you can only click on ok and Lubuntu boot. I'm not sure about grub and I write  sudo apt-get install grub after this the situation it's same at new boot the same message appears and then Lubuntu boot.
What I must doing? Where is the error?
Thanks for your help.
« Last Edit: December 30, 2014, 02:29:01 pm by Calatea »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: Boot
« Reply #1 on: December 26, 2014, 11:03:20 pm »
Do you have Win8 and EFI?
Nothing is easy as it looks.

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #2 on: December 27, 2014, 12:02:29 am »
No, I've Lubuntu on /dev/sda2 and Sparky on /dev/sda4. File system FAT 32 mounted /boot/EFI

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: Boot
« Reply #3 on: December 27, 2014, 12:15:45 am »
But it looks like your machine has EFI - /boot/EFI is there.
So the question is does Lubuntu use EFI too?
Check has Lubuntu installed grub-pc or grub-efi?
What else you have in /boot/EFI? Only debian.efi image?
Nothing is easy as it looks.

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #4 on: December 27, 2014, 04:50:09 pm »
1)  I think that Lubuntu use EFI
2) I don't know
3) I think so, because Lubuntu is the first SO installated on this PC (Acer Aspire E1-522)
in /boot I've: 2 folders /boot/efi and /boot/grub
in /boot/efi/EFI 2 folders /boot/efi/EFI/debian and /boot/efi/EFI/ubuntu
in /boot/grub 3 folders: /boot/grub/fonts, /boot/grub/locale, /boot/grub/x86_64-efi +  files: grub.cfg, grubenv, unicode.pf2
« Last Edit: December 27, 2014, 05:17:31 pm by Calatea »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: Boot
« Reply #5 on: December 27, 2014, 05:25:38 pm »
I don't have big experience with efi, my machines have bios. I only work with efi on virtual machines.
But mayby it's a question of secure boot?
Can you check in efi settings is the secure boot turned off?
« Last Edit: December 27, 2014, 07:08:15 pm by pavroo »
Nothing is easy as it looks.

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #6 on: December 28, 2014, 08:18:13 pm »
I've open the BIOS menu, I've changed in security menu Secure boot to UEFI at Legacy, press F10 and I've receive this message:


Intel UNDI, PXE 2.0 (build 083)
Copyrigth IC 1997-2000 Intel Corporation v 2.1.1.4 (01/18/13)
Check cable connetion!
PXE-M0F: Exiting Intel PXE ROM
No bootable device -- insert boot disk and press any key.
 
Thus I've rebboted and changed in default (UEFI)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: Boot
« Reply #7 on: December 29, 2014, 12:25:32 am »
I didn't say to turn it to Legacy.
The point is to turn the Secure Boot off.
http://acer--uk.custhelp.com/app/answers/detail/a_id/27071/~/how-to-enable-or-disable-secure-boot
It should be booted using efi image without secure boot.
By the way, if you don't have win8 why do you use efi if you can permanently turn it off and use legacy boot for all your OSes?
Nothing is easy as it looks.

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #8 on: December 29, 2014, 08:41:06 pm »
Ok,  tanks exact information :D :D now at boot I've Grub but,  when  load the  system and I've the Grub on screen I don't see the Lubuntu partition. I've read that Lubuntu is default, it's means that if I wait whitout make any choose Lubuntu boot automaticaly?
 

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #9 on: December 29, 2014, 09:28:56 pm »
Good evening guys,
now that the Grub in installated I've another problem at boot grub don't see the partition /dev/sda2 where's Lubuntu.
 What can I had to do for have, inside at the grub two option for choose: Lubuntu or Sparky?

Offline Calatea

  • Newbie
  • *
  • Posts: 23
Re: Boot
« Reply #10 on: December 30, 2014, 01:40:53 pm »
Solved!!! Was very easy:

#update grub

and now at boot I can see /dev/sda2 and /dev/sda4 at boot!!

Tanks and Happy New Year!

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: [Solved]Boot
« Reply #11 on: December 31, 2014, 01:59:16 am »
Cool :)
Nothing is easy as it looks.