Author Topic: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected  (Read 1582 times)

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« on: December 03, 2014, 10:14:06 am »
I searched the forums and found that issues existed with previous installers and GPT hard drives (extended partition flagged as lba).  However, according to the referenced bug reports, the issue was supposedly resolved.  Here is what I'm currently experiencing on a Dell Studio 1557 with a legacy AMD GPU.

The Sparky GUI installer freezes after clicking the Forward button after selecting the installation disk.  So, I tried the command line installer.  I get the error "Unsupported GPT (GUID Partition Table) detected.  Use GNU Parted." after selecting the installation disk.  Then a text-based partitioning system appears, but I didn't want to proceed at that point due to the error message.

So, is it possible to install SparkyLinux 3.5 Openbox 64-bit on my laptop?  I've never had the aforementioned issues installing other Linux distros on the same laptop.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #1 on: December 03, 2014, 12:47:18 pm »
Hi
The command line installer doesn't support GPT and EFI.
I don't improve it any more (mayby later).
Sparky 3.6rc Openbox has a newer version of GUI installer so you can try this.
Anyway the final version of Sparky 3.6 should be ready this week.
Nothing is easy as it looks.

Offline Chdslv

  • Newbie
  • *
  • Posts: 28
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #2 on: December 03, 2014, 07:39:53 pm »
I have installed the Sparky 3.6rc Openbox in one partition. Do I have to reinstall it, when you release the final version?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #3 on: December 03, 2014, 10:17:03 pm »
No, you don't have to.
I published 3.6rc to make sure the installer works fine.
Nothing is easy as it looks.

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #4 on: December 03, 2014, 10:33:44 pm »
Hi
The command line installer doesn't support GPT and EFI.
I don't improve it any more (mayby later).
Sparky 3.6rc Openbox has a newer version of GUI installer so you can try this.
Anyway the final version of Sparky 3.6 should be ready this week.
Okay...any idea why the GUI installer in 3.5 Openbox becomes unresponsive?  I installed 3.5 Openbox on an ASUS laptop without issue.

Offline dhinds

  • Full Member
  • ***
  • Posts: 154
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #5 on: December 03, 2014, 10:39:43 pm »
As a Sparky Ultra Openbox user this issue interests me also, since I have been avoiding updates in order to avoid breaking the system on my main desktop computer, since the Ultra Openbox version is no longer being developed and I intend to continue using Openbox on Sparky.

My question is, will I be able to safely upgrade or do I have to install v. 3.6 and then add the Sparky extras that the Ultra Openbox version has (i.e remastering), separately?

(My hard drives show lba for the extended partitions also, although the MB and CPU aren't AMD).

Also, I have been waiting for a 3.16 or above kernel, to avoid the problem I mentioned earlier with the 3.14 series. 

Which Linux kernel does Sparky 3.6 use, and will it be changed in an system update / upgrade or does that have to be done separately?

Thanks in advance, Pavroo.
« Last Edit: December 03, 2014, 10:45:12 pm by dhinds »

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #6 on: December 03, 2014, 10:55:33 pm »
@dhinds:  Regarding kernel 3.16 or greater, you have two possible options: (1) pull from the unstable repo, or (2) use SMXI.

http://smxi.org

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #7 on: December 03, 2014, 11:47:33 pm »
@KrunchTime
Quote
any idea why the GUI installer in 3.5 Openbox becomes unresponsive?
The big question is: have you used 3.5 or 3.5.1? 3.5 had an issue.

@dhinds
We spoke about upgrading your machine before :)
There is no change with that.
Upgrading after so looong time is risky, but possible.
Backup your personal files than do it in a terminal emulator:
Code: [Select]
apt-get update
apt-get dist-upgrde
apt-get install -f

Kernel 3.16 is in Debian testing repo so you can get it now.
Anyway you can try to upgrade the kernel first, for example via Synaptic: Reload, then install kernel 3.16, the reboot.
If something will be wrong, you can reboot and run the system using an older kernel.
If it'll be fine then try to upgrade all packages.
« Last Edit: December 03, 2014, 11:51:07 pm by pavroo »
Nothing is easy as it looks.

Offline dhinds

  • Full Member
  • ***
  • Posts: 154
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #8 on: December 04, 2014, 05:15:59 am »
OK.  I installed linux-doc3.16 and opened 00-INDEX, then "Changes
   - list of changes that break older software packages."

Then:

"Current Minimal Requirements
============================

Upgrade to at *least* these software revisions before thinking you've
encountered a bug!  If you're unsure what version you're currently
running, the suggested command should tell you."

I have run live sessions of new distributions that include the 3.16 and 3.17 kernels but I guess what counts is how the kernel combines with the rest of the system installed.  That said, since Jesse will be out soon and the new testing will be in place, maybe I should wait a bit longer.
« Last Edit: December 04, 2014, 08:03:45 pm by dhinds »

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #9 on: December 04, 2014, 06:21:57 am »
@KrunchTime
Quote
any idea why the GUI installer in 3.5 Openbox becomes unresponsive?
The big question is: have you used 3.5 or 3.5.1? 3.5 had an issue.
Whatever is available on the Downloads page.  I just attempted installation with 3.6rc and the GUI installer now becomes unresponsive after clicking the Forward button on the User Info screen.  I like the changes that have been made though.  The GUI installer looks a lot nicer and more polished.  Now you need to work on getting it to work.  ;)

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #10 on: December 04, 2014, 09:34:45 am »
@dhinds:  Good news; kernel 3.16 is available per the following post:

http://sparkylinux.org/forum/index.php/topic,2747.msg4557.html#msg4557

Offline dhinds

  • Full Member
  • ***
  • Posts: 154
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #11 on: December 04, 2014, 08:22:14 pm »
@dhinds:  Good news; kernel 3.16 is available per the following post:

http://sparkylinux.org/forum/index.php/topic,2747.msg4557.html#msg4557

Thanks.  That's encouraging.

I'll have to back up configurations and give it a try.

Offline KrunchTime

  • Newbie
  • *
  • Posts: 18
Re: Sparky 3.5 Openbox Installation Issue - Unsupported GPT Detected
« Reply #12 on: December 05, 2014, 12:27:39 pm »
I installed antiX on the same laptop that I'm having issues with the Sparky GUI Installer, so it is the installer.