Author Topic: [SOLVED] Unable to install Parcellite 1.1.9 from source  (Read 751 times)

Offline one23

  • Newbie
  • *
  • Posts: 26
[SOLVED] Unable to install Parcellite 1.1.9 from source
« on: October 17, 2014, 11:13:30 pm »
I was wondering why it was impossible to install Parcellite 1.1.9 from source (earlier version suffer from nasty bug which disallows you to clean the history).  After executing

Code: [Select]
./configure
terminal was spitting out

Code: [Select]
configure: error: Package requirements (gtk+-2.0 >= 2.10.0) were not met:

No package 'gtk+-2.0' found

I had no problem with using deb package though
« Last Edit: October 18, 2014, 11:13:53 am by one23 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Unable to install Parcellite 1.1.9 from source
« Reply #1 on: October 18, 2014, 12:03:09 am »
It should be 'libgtk2.0-dev' package missing.
Get it via Synaptic and try again.
Nothing is easy as it looks.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Unable to install Parcellite 1.1.9 from source
« Reply #2 on: October 18, 2014, 01:10:58 am »
If parcellite 1.1.9 is fixed you can install it from sid repository without compiling from source.
Nothing is easy as it looks.

Offline one23

  • Newbie
  • *
  • Posts: 26
Re: Unable to install Parcellite 1.1.9 from source
« Reply #3 on: October 18, 2014, 11:12:32 am »
Installing libgtk2.0-dev did resolve dependency issue and  could compile the program from source.

Just out of curiosity, why deb package was installed without libgtk2.0-dev being installed first? Is it something to do with the way that deb package installer handles package dependencies?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: [SOLVED] Unable to install Parcellite 1.1.9 from source
« Reply #4 on: October 18, 2014, 11:47:55 am »
It simple - if you'd like to compile something you need 'dev' libs.
If you install 'deb' package you don't need 'dev' just normal libs.
Nothing is easy as it looks.

Offline one23

  • Newbie
  • *
  • Posts: 26
Re: [SOLVED] Unable to install Parcellite 1.1.9 from source
« Reply #5 on: October 21, 2014, 10:56:07 pm »
Got it now. Thanks pavroo  :D