Author Topic: Re: Cannot complete shutdown [Solved]  (Read 1202 times)

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Cannot complete shutdown [Solved]
« on: October 14, 2014, 10:21:40 am »
Have 3.4-x86-64-base with latest upgrades.  Have tried sudo shutdown -h 0, wm-logout, lxsession-logout and some others.  Latest wm-logout is installed.  System goes down to a suspended state where the screen is a light blue and everything but the keyboard is frozen.  I am left with doing a hard kill, or rebooting with alt+PrtSc+R+E+I+S+U+B.  What can I do to regain a normal shutdown?
« Last Edit: October 15, 2014, 07:01:00 pm by seppalta »

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: Cannot complete shutdown
« Reply #1 on: October 14, 2014, 11:54:45 am »
sudo shutdown -h now
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: Cannot complete shutdown
« Reply #2 on: October 14, 2014, 12:00:18 pm »
Type in terminal:

    sudo -i (to get a root shell, sudo gedit is not recommended)

    gedit /etc/default/grub

    Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    Change this to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"


    Save the file and close the file.

    Finally, in terminal: update-grub

    exit (to end the root shell)

Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Cannot complete shutdown
« Reply #3 on: October 14, 2014, 02:35:03 pm »
Have you upgraded all packages to the newest version?
Systemd 215 is in testing repo now and the system shut down very quick now.
Nothing is easy as it looks.

Offline one23

  • Newbie
  • *
  • Posts: 26
Re: Cannot complete shutdown
« Reply #4 on: October 14, 2014, 10:19:27 pm »
and the system shut down very quick now.

A little bit off topic but it does indeed  ;D

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Cannot complete shutdown
« Reply #5 on: October 15, 2014, 01:43:04 am »
Quote
A little bit off topic but it does indeed
You right :)
Try:
Code: [Select]
sudo haltor
Code: [Select]
sudo poweroff
Nothing is easy as it looks.

Offline seppalta

  • Jr. Member
  • **
  • Posts: 96
Re: Cannot complete shutdown [Solved]
« Reply #6 on: October 15, 2014, 06:19:52 pm »
Thank you pavroo and way12go.  I had systemd215-5+b1 installed.  However, editing grub as way12go suggested has apparently forced lxsession-logout,  wm-logout, sudo poweroff, sudo shutdown -h 0 to do complete shutdowns.
« Last Edit: October 15, 2014, 06:59:28 pm by seppalta »

Offline nalsdixit

  • Newbie
  • *
  • Posts: 22
Re: Cannot complete shutdown -
« Reply #7 on: October 16, 2014, 01:19:21 pm »
i have the same problem, and tried same solution, however when i type
gedit /etc/default/grub

in the terminal it says
-bash: gedit: command not found

what shld i do ?

tks

nals

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Re: Cannot complete shutdown [Solved]
« Reply #8 on: October 16, 2014, 02:58:31 pm »
If you don't have gedit installed, you can run it.
Use other text editor you have, for example: leafpad, nano, mousepad, etc.
Nothing is easy as it looks.

Offline nalsdixit

  • Newbie
  • *
  • Posts: 22
Re: Cannot complete shutdown [Solved]
« Reply #9 on: October 16, 2014, 03:48:58 pm »
thank you, did figure that out, and used leafpad instead of gedit

however, thereafter on rebooting , i got something about grub not reading highlighted text or something. i guess that is because a did a copy/paste of 1waytogo post, and i should have rather just typed it in ?

tks

nals

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Re: Cannot complete shutdown [Solved]
« Reply #10 on: October 16, 2014, 05:41:32 pm »
Show your present /etc/default/grub file.
Nothing is easy as it looks.

Offline nalsdixit

  • Newbie
  • *
  • Posts: 22
Re: Cannot complete shutdown [Solved]
« Reply #11 on: October 17, 2014, 03:28:37 pm »
is even worse now, i cannot reboot, goes into a grub menu only

here is the output:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

nals