Author Topic: how to install flash player for chromium?  (Read 2088 times)

Offline nixfirst

  • Newbie
  • *
  • Posts: 4
how to install flash player for chromium?
« on: October 11, 2014, 10:30:25 am »
I just installed chromium but it didn't include flash player. :(
I currently using SparkyLinux Xfce x86_64.
« Last Edit: October 11, 2014, 10:36:42 am by nixfirst »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: how to install flash player for chromium?
« Reply #1 on: October 11, 2014, 12:04:34 pm »
The Flash player is preinstalled in Sparky LXDE, Xfce, MATE and Razor editions.
The point is that the Chromium browser can't see flash.
Mayby it's a question of Chromium settings.
Did you try to set the right patch for flash in Chromium settings panel?
Quote
    Type “about:plugins” (without the quotation marks) into the address bar at the top of a Chromium browser window.
    Click “Details” at the upper-right corner of the page.
    Find the “Flash” or “Shockwave Flash” listing on the Plug-ins page and click the corresponding “Enable” button.
    Close all Chromium windows and restart the browser.
« Last Edit: October 11, 2014, 01:13:52 pm by pavroo »
Nothing is easy as it looks.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: how to install flash player for chromium?
« Reply #2 on: October 11, 2014, 02:55:50 pm »
For Chromium and Chrome you need PEPPER FLASH and PEPPER FLASH is not for Firefox or Ice Weasel

Installing Pepper Flash Player

Debian

64 bits / amd64

    If not already done you must add backports to your sources.list. To do so follow those instructions.
    Using Terminal as Root run the following command to install Pepper Flash Player from Wheezy Backports

  sudo apt-get install pepperflashplugin-nonfree

    Still using Terminal run the following command to update Pepper Flash Player

    sudo update-pepperflashplugin-nonfree --install

    Close all your browser windows. Then open your browser. Flash should work.
    This step is optional. Still using Terminal run the following command to know what version of Pepper Flash Player you have installed.

    sudo update-pepperflashplugin-nonfree --status

Notes

    If Flash is still not working here are a few things you could try
        Ensure that all your Chromium or Chrome browser windows are closed. It's important to close all browser windows otherwise Flash will not work. Then open your browser to test Flash.
        If still not working try to reboot your computer. Sometime Chromium or Chrome windows seems all closed but one might still be open in the background, on another desktop, or frozen in memory.
        If still not working try to temporally deactivate all your Chrome or Chromium plugins and extensions. Then test flash.

    The Pepper Flash Player works in both Chrome and Chromium only. It does not yet work with Iceweasel or Firefox. For Flash to work with Iceweasel or Firefox you have to install another package. Read more here. Currently both packages can coexist.
« Last Edit: October 11, 2014, 03:08:15 pm by way12go »
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: how to install flash player for chromium?
« Reply #3 on: October 11, 2014, 02:58:14 pm »
I have

1. Ice Weasel [ Default Sparkylinux app ]

2. Google Chrome [ .deb package from google website ]

3. Chromium [ Installed from Synaptic package manager ]

and

4. TOR [ Installed from Synaptic package manager ]

I installed PEPPER FLASH from Synaptic package manager.
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline Slyvester

  • Newbie
  • *
  • Posts: 32
Re: how to install flash player for chromium?
« Reply #4 on: October 13, 2014, 04:50:53 pm »
Hello Way12go,

Read in your post : How to install mate desktop environment in Sparkylinux : " ... In the case of wheezy the backports repository has to be enabled as described in the official backport documentation...".
I must confess I didn't check the official backport documentation (by the way, a link would appreciated ... thanks !). I just added these two lines in my "/apt/sources.list" which are :
http://ftp.us.debia.org/debian/ wheezy-backports main non-free contrib &&
http://ftp.us.debia.org/debian/ wheezy-backports main non-free contrib (Code Source)
Did you do that to get the backports open ?

P.S. : Looks like it works ! From my terminal :
sudo update-pepperflashplugin-nonfree --status
Flash Player version installed on this system  : 15.0.0.152
Flash Player version available on upstream site: 15.0.0.152
Thanks a lot .. I'm gonna try it now by using Google-Chrome.
« Last Edit: October 13, 2014, 04:59:59 pm by Slyvester »
Slyvester