Author Topic: [solved] Don't update libglib2.0-* right now!  (Read 1419 times)

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
[solved] Don't update libglib2.0-* right now!
« on: October 03, 2014, 08:57:25 pm »
For details see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763787 and bug reports #758619, 762612 and 763602 for example.
This bug affects various programs (reportbug, mirage, pyrenamer, xpdf and others) which won't start any more if you update to current testing version 2.42.0-1  If you are already affected downgrade as mentioned in the link, it worked for me. Last working version seems to be 2.41.1-2
« Last Edit: October 21, 2014, 07:55:20 pm by py-thon »
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Don't update libglib2.0-* right now!
« Reply #1 on: October 04, 2014, 08:45:00 pm »
Thank's for the info.
I am almost ready with an update of sparky 3.5.1 e19 (final) but the installer can't starts.
I didn't detect what package (last upgrade problem) broken that but I will have a look into that.
Nothing is easy as it looks.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Don't update libglib2.0-* right now!
« Reply #2 on: October 07, 2014, 01:59:34 pm »
Just I'd like to confirm that the 'libglib2.0-2.42.x' makes me and the installer sick :(
Nothing is easy as it looks.

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Don't update libglib2.0-* right now!
« Reply #4 on: October 08, 2014, 12:22:18 am »
The problem is deeper that I was expected.
I installed the last version of sparky 3.5 base, didn't upgrade the libglib2.0 so I could run the installer but it doesn't work well.
Still searching...
Nothing is easy as it looks.

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Re: Don't update libglib2.0-* right now!
« Reply #5 on: October 17, 2014, 06:57:23 pm »
gtk2- and gtk3-packages have been changed to tolerate faulty programming.

gtk3 is already in testing (gir1.2-gtk-3.0 and other packages in version 3.14.1-1, the changelog doesn't give a clue, but according to the link to forums.linuxmint above it is fixed in 3.14)

gtk2 is currently in sid (gir1.2-gtk-2.0 and other packages in version 2.24.25-1, fixed according to changelog)
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Don't update libglib2.0-* right now!
« Reply #6 on: October 17, 2014, 08:09:06 pm »
Thank's for the info, I will upgrade it to test, specially gtk2 from sid.
I had to downgrade a few packages in sparky 3.5.1 e19 - even the installer didn't want to work.
Nothing is easy as it looks.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Saying something clever is easy,when you r stupid.
Re: Don't update libglib2.0-* right now!
« Reply #7 on: October 18, 2014, 02:45:06 am »
I reinstalled Sparkylinux, this time it's JWM flavour. Last time I had all DEs on LxDE base... All upgrades. I even installed E19 package. So my question is...

If E19 is buggy and installing LxDE and then going to E19 is okay...

Why don't we break the rules?
Saying something clever is easy, when you are stupid. - Sagar Gorijala.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Don't update libglib2.0-* right now!
« Reply #8 on: October 18, 2014, 11:44:54 am »
Quote
Why don't we break the rules?
I don't get it,  what do you mean?
Nothing is easy as it looks.

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Re: Don't update libglib2.0-* right now!
« Reply #9 on: October 21, 2014, 07:54:29 pm »
The fixed versions of gtk2 have entered testing. It should be safe to upgrade now.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE