Author Topic: Why does it take so long to switch the system out ?  (Read 2920 times)

Offline Slyvester

  • Newbie
  • *
  • Posts: 32
Why does it take so long to switch the system out ?
« on: October 03, 2014, 05:17:30 pm »
Hi everybody,

I just installed a few days ago this dynamique "SparkyLinux" OS on my hard drive. I'm very Happy with it but why does it take so long to log out of the system ? I've tried many different ways to switch my machine out : gui, sudo shutdown -h now, sudo halt, sudo logout, .... It still seems that it takes so long, about 1 minute and a half watching the screen "SparkyLinux" with a logo spinning round and round to finally stop.
Any suggestion to stop or log out in less time ? I've never had that before on any of my many other distros Linux : Slax, Linux Mint, Ubuntu, Lubuntu, Xubuntu, just to name a few.

Thanks in advance.
Slyvester.
« Last Edit: January 10, 2015, 11:35:06 am by Slyvester »
Slyvester

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Why does it take so long to switch the system out ?
« Reply #1 on: October 03, 2014, 07:13:22 pm »
Hi
The looong poweroff process is taken from Debian, pure Debian installations works the same.   
As you know Sparky is fully based on Debian testing so all the good and not so good things we get from Debian.
We have to wait for fixing that by Debian devs.
Nothing is easy as it looks.

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Why does it take so long to switch the system out ?
« Reply #2 on: October 03, 2014, 07:29:56 pm »
Just a quick note on this shutdown/reboot delay issue from Debian.  Its fixed in SID (I have another Sparky XFCE tracking SID).  Its mostly a systemd  Issue.  Will be fixed in Sparky with Debian Testing (the default) in a couple of weeks or so..

SID version below.
Code: [Select]
gene@sparky:~$ apt-cache policy systemd
systemd:
  Installed: 215-5+b1
  Candidate: 215-5+b1
  Version table:
 *** 215-5+b1 0
        100 /var/lib/dpkg/status
     208-8 0
        500 http://ftp.us.debian.org/debian/ testing/main amd64 Packages

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Re: Why does it take so long to switch the system out ?
« Reply #3 on: October 03, 2014, 09:06:39 pm »
It seems to need a combination of things to delay shutdown. I am delighted to find my new Sparky installation (using systemd 208-8) shutdown in five seconds, much quicker than my old LMDE installation which did not use systemd.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Why does it take so long to switch the system out ?
« Reply #4 on: October 03, 2014, 09:23:58 pm »
^^ py-thon

Shutdown itself was not usually not a problem for me, but re-boot (without a full shutdown) that took a while for me.  Like 2 minutes, as opposed to a few seconds on SID.

Is your re-boot working without the delay?  (I am using XFCE desktop)..

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Re: Why does it take so long to switch the system out ?
« Reply #5 on: October 03, 2014, 10:46:26 pm »
Reboot is not something I usually do, I'm not running Windows  ;D

But I logged out several times when I had problems with nm-applet's icon disappearing. I did not look at my watch but I'm sure it took only a few seconds to logout and have the login window shown (Mate desktop).

I suppose it is an Xfce+Debian-issue, see http://ubuntuforums.org/showthread.php?t=2241199
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Saying something clever is easy,when you r stupid.
Re: Why does it take so long to switch the system out ?
« Reply #6 on: October 04, 2014, 02:29:51 am »
I uninstalled "plymouth" package and the start and shutdown/restart are good to go...
Saying something clever is easy, when you are stupid. - Sagar Gorijala.

Offline Slyvester

  • Newbie
  • *
  • Posts: 32
Re: Why does it take so long to switch the system out ?
« Reply #7 on: October 04, 2014, 09:46:00 am »
Hi,

I forgot to say that I installed the gui "wm-logout" and even when using it : terminal + typing wm-logout, I got the same result : Looong shutdown.
It looks like the only thing to do right now is just to keep on waiting. That's what I'll do. I wonder what you guys thing of the idea or solution given by "way12go" : "I uninstalled "plymouth" package and the start and shutdown/restart are good to go...".

I don't remenber having that problem (or any problem) with LMDE. The only I know about LMDE (so stable !) is that it gave me the idea to try a Debian Distribution. When I installed SparkyLinux just a week ago, I didn't know it was based on Debian Testing and not Debian Stable. I truly believe it's a good experience so far but SparkyLinux is not to be advised to a Linux Neebie.

Thanks y' all for your answers !
Slyvester.
« Last Edit: October 04, 2014, 05:38:40 pm by Slyvester »
Slyvester

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Why does it take so long to switch the system out ?
« Reply #8 on: October 04, 2014, 01:32:05 pm »
Reboot is not something I usually do, I'm not running Windows  ;D

But I logged out several times when I had problems with nm-applet's icon disappearing. I did not look at my watch but I'm sure it took only a few seconds to logout and have the login window shown (Mate desktop).

I suppose it is an Xfce+Debian-issue, see http://ubuntuforums.org/showthread.php?t=2241199

That explains it..  Thanks..

I uninstalled "plymouth" package and the start and shutdown/restart are good to go...

Yes, Plymouth has always been somewhat of an issue for me (Nvidia) with debian.  I always remove it, but it did not fix the issue for me until I upgraded all of systemd from SID.  Thanks.

-----------------------------------

Hi,

I forgot to say that I installed the gui "wm-logout" and even when using it : terminal + typing wm-logout, I got the same result : Looong shutdown.
It looks like the only thing to do right now is just to keep on waiting. That's what I'll do. I wonder what you guys thing of the idea or solution given by "way12go" : "I uninstalled "plymouth" package and the start and shutdown/restart are good to go...".

I don't remenber having that problem (or any problem) with LMDE. The only I know about LMDE (so stable !) is that it gave the idea to try a Debian Distribution. When I installed SparkyLinux just a week ago, I didn't know it was based on Debian Testing and not Debian Stable. I truly believe it's a good experience so far but SparkyLinux is not to be advised to a Linux Neebie.

Thanks y' all for your answers !
Slyvester.

LMDE has not been upgraded in about 9 months.. and If I remember is not yet on systemd.  Hence it has not seen this issue yet.. ;)

Offline py-thon

  • Jr. Member
  • **
  • Posts: 68
Re: Why does it take so long to switch the system out ?
« Reply #9 on: October 04, 2014, 03:13:59 pm »
I wonder what you guys thing of the idea or solution given by "way12go" : "I uninstalled "plymouth" package and the start and shutdown/restart are good to go...".

I don't remenber having that problem (or any problem) with LMDE. The only I know about LMDE (so stable !) is that it gave the idea to try a Debian Distribution.
My LMDE-installation had problems with plymouth, I had to change some setting for the login window to make it work and still I always got red warnings at startup.
My installation was stable, but outdated for most of the time (this includes the complete lack of security updates other than Firefox, Thunderbird and Flash). For lots of people the installation of UPs broke their systems.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline Slyvester

  • Newbie
  • *
  • Posts: 32
Re: Why does it take so long to switch the system out ?
« Reply #10 on: October 04, 2014, 05:36:46 pm »
Plymouth : I used my "Root file manager" to open it : /etc/plymouth and found two 2 files  :
 1) plymouth.conf (which was active) :
# Administrator customizations go in this file
#[Daemon]
#Theme=text
#ShowDelay=0
[Daemon]
Theme=sparky
2) plymouth.conf.dpkg-old (inactive) :without the line #ShowDelay=0
I renamed the second file to make it active : plymouth.conf and I added "-old" to the first one to get rid of the line :  #ShowDelay=0
I saved the whole set and after reboot, shutdown in five seconds. I'm not sure I did the right thing but my problem seems to be solved. Anyway thanks to "Way12go" & GeneC who gave me the clue.
Slyvester.
Slyvester