Author Topic: Upgrade from xfce 3.4 32 bit to 3.5  (Read 1020 times)

Offline travica77

  • Newbie
  • *
  • Posts: 27
Upgrade from xfce 3.4 32 bit to 3.5
« on: September 29, 2014, 11:16:36 am »
When upgrading this error came up

Reading changelogs... Done
(Reading database ... 206269 files and directories currently installed.)
Preparing to unpack .../gnome-mines_1%3a3.14.0-1_i386.deb ...
Unpacking gnome-mines (1:3.14.0-1) over (1:3.12.2-2) ...
dpkg: error processing archive /var/cache/apt/archives/gnome-mines_1%3a3.14.0-1_i386.deb (--unpack):
 trying to overwrite '/usr/share/icons/HighContrast/256x256/apps/gnome-mines.png', which is also in package gnome-accessibility-themes 3.12.0-1
dpkg-deb: error: subprocess paste was killed by signal (Prekinjen cevovod)
Processing triggers for mime-support (3.56) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gnome-mines_1%3a3.14.0-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Upgrade from xfce 3.4 32 bit to 3.5
« Reply #1 on: September 29, 2014, 12:24:59 pm »
It looks like Debian devs put the same icon 'gnome-mines.png' into two packages: gnome-mines and gnome-accessibility-themes.
You can remove 'gnome-mines' packages (and gnome-games as well) to fix it before running the upgrade again.
Nothing is easy as it looks.

Offline travica77

  • Newbie
  • *
  • Posts: 27
Re: Upgrade from xfce 3.4 32 bit to 3.5
« Reply #2 on: September 29, 2014, 01:17:48 pm »
thanks.

Ho to activate this:
Added new repository and the public keys:
– virtualbox
– liquorix
– google earth
– google talk plugin
– google music manager

i can,t activate this repository

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Upgrade from xfce 3.4 32 bit to 3.5
« Reply #3 on: September 29, 2014, 01:48:10 pm »
It looks like Debian devs put the same icon 'gnome-mines.png' into two packages: gnome-mines and gnome-accessibility-themes.
You can remove 'gnome-mines' packages (and gnome-games as well) to fix it before running the upgrade again.

I can verify that this fix works for successful update.  We will have to wait for 'gnome-mines' to get patched if we want to re-install it. 'Gnome-games' is just a meta-package removing it does not remove other gnome games..

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Upgrade from xfce 3.4 32 bit to 3.5
« Reply #4 on: September 29, 2014, 02:14:15 pm »

It looks like Debian devs put the same icon 'gnome-mines.png' into two packages: gnome-mines and gnome-accessibility-themes.
You can remove 'gnome-mines' packages (and gnome-games as well) to fix it before running the upgrade again.

I can verify that this fix works for successful update.  We will have to wait for 'gnome-mines' to get patched if we want to re-install it and 'gnome-games.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Upgrade from xfce 3.4 32 bit to 3.5
« Reply #5 on: September 29, 2014, 04:58:43 pm »
@GeneC
That's right.
I should say that the gnome-mimes removes gnome-games package itself.
@travica77
The answer moved to:
http://sparkylinux.org/forum/index.php?topic=2631
« Last Edit: September 29, 2014, 05:02:28 pm by pavroo »
Nothing is easy as it looks.