Author Topic: [ Solved ] Lightdm-manager doesn't auto login  (Read 3324 times)

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
[ Solved ] Lightdm-manager doesn't auto login
« on: September 23, 2014, 07:16:49 am »
Lightdm-manager doesn't auto login

I searched the internet and found this solution. I haven't tried this solution as I need to go to bank. If this works I will not change the status of this post's subject.

Here it is...

Quote
http://siripong-computer-tips.blogspot.in/2011/09/enable-lightdm-autologin-debian-wheezy.html

 
Quote
enable lightdm autologin debian wheezy

alter /etc/lightdm/lightdm.conf to be

[SeatDefaults]
autologin-user={YOUR USER NAME}
autologin-user-timeout=0
pam-service=lightdm-autologin


create /etc/pam.d/lightdm-autologin (if not exist)
#%PAM-1.0
auth requisite pam_nologin.so
auth required pam_env.so readenv=1
auth required pam_env.so readenv=1 envfile=/etc/default/locale
auth required pam_succeed_if.so user != root quiet_success
auth required pam_permit.so
@include common-account
session required pam_limits.so
@include common-session
@include common-password


thanks
=======
« Last Edit: September 24, 2014, 09:29:32 am by way12go »
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: [ Solved ] Lightdm-manager doesn't auto login
« Reply #1 on: September 23, 2014, 07:18:59 am »
Auto login used to work after I changed a file related to auto login as in this post...

Quote
http://sparkylinux.org/forum/index.php?topic=2581.msg3791#msg3791

After I installed lidhtdm-manager auto login no longer works and the first post in this topic seems to be the solution...
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: Lightdm-manager doesn't auto login
« Reply #2 on: September 23, 2014, 10:46:07 am »
The above solution doesn't work. Light-dm manager auto login is enabled but it simply doesn't work.
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: Lightdm-manager doesn't auto login
« Reply #3 on: September 23, 2014, 10:56:24 am »
I have KDE, GNOME, LIGHT-DM and SLIM installed. Is this the cause why I couldn't autologin?
Existence is all about what matters and what doesn't. - Sagar Gorijala.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Lightdm-manager doesn't auto login
« Reply #4 on: September 23, 2014, 03:10:44 pm »
Quote
After I installed lidhtdm-manager auto login no longer works and the first post in this topic seems to be the solution
It looks like the Lightdm-manager doesn't solve the problem.
Mayby it's better to not install the manager and configure the lightdm configuration file manually.

Somebody asked me to add the manager to the iso but I am not sure that it's a good idea.
I just added the package to our repository.
Nothing is easy as it looks.

Offline way12go

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 476
  • Existence is all about what matters & what doesn't
Re: Lightdm-manager doesn't auto login
« Reply #5 on: September 24, 2014, 09:28:16 am »
I uninstalled "slim and slim-theme" and then I uninstalled "lightdm" and then I installed "lightdm" and now it works like a charm. All I have to do is uninstall it and install it... I suppose when there are login managers like kdm, gdm3, slim and lightdm, the last installed login manager that is installed should be lightdm and slim should be uninstalled.
Existence is all about what matters and what doesn't. - Sagar Gorijala.