Author Topic: Request: Add Compiz and Emerald for XFCE ?  (Read 1310 times)

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Request: Add Compiz and Emerald for XFCE ?
« on: August 19, 2014, 03:07:21 pm »
XFCE has always been my default desktop, but I like to spruce it up with Compiz, Fusion Icon and Emerald.  The problem is they have not been in Debian repos for quite a while and not generally available for installation.  I do think they would be a very valuable addition to Sparky and make it even more popular.

That said, I DO have it installed in my Sparky 64bit XFCE install.  I had saved some old debs from way back.
Code: [Select]
gene@sparky:~$ apt-cache policy compiz
compiz:
  Installed: 0.8.4-5.2
  Candidate: 0.8.4-5.2
  Version table:
 *** 0.8.4-5.2 0
        100 /var/lib/dpkg/status

http://i285.photobucket.com/albums/ll58/genecharb/Screenshot-08192014-090246AM.png
I dont know haw hard it would be, or how popular and addition it would be, but something to consider.  I often see folks asking for it on the many linux forums I cruise daily.... ;)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: Request: Add Compiz and Emerald for XFCE ?
« Reply #1 on: August 19, 2014, 04:43:35 pm »
If you have packages of Compiz and Emerald for Debian 32 and 64 bit or 'all' I can add them to sparky repo and to my new script aptus-extra so it'll be easy to install.
Nothing is easy as it looks.

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Request: Add Compiz and Emerald for XFCE ?
« Reply #2 on: August 19, 2014, 05:00:03 pm »
Sure, I could give them to you and that would be nice, BUT i have noticed one issue (very recently since I first installed them a month or so back).  Recent updates to 'metacity-common' want to remove compiz.  I had to lock the old version so it would not update and remove compiz.

I have all the necessary compiz and emerald files plus some themes zipped to a 18.6mb tar.gz file.
What would be the best way to get them to you?


PS
I am uploading them to Mediafire as I post this.  Will post the link when complete... :P

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Request: Add Compiz and Emerald for XFCE ?
« Reply #3 on: August 19, 2014, 05:16:10 pm »
[...]


Make a backup first.  This may break something in your system ( or not work at all--namely the metacity-common upgrade issue I mentioned)..

1.  Unzip package and read the READ ME first.  I wrote it for a friend who wanted it.  (I am no coder, or expert so take it slow).
2.  There is an issue (bug) with no fonts in CCSM, but there is a fix (see Compiz Settings Manager Text Fix in folder)
3.  Open the folder with debs (Compiz or Emerald) and from there in terminal run
Code: [Select]
sudo dpkg -i *.deb
to install files.
4.  Other text files are included with instruction to autostart compiz, and fusion icon
5.  I just put this together from old debs I had saved, and its all untested by others, so be warned.. ::)
But works for me..

Hope it works out to be easy to add to repo with no issues.  I feel it would be a big advantage to Sparky, as no Debian distro supplies Compiz or Emerald...
« Last Edit: August 26, 2014, 08:25:41 pm by GeneC »

Offline GeneC

  • Full Member
  • ***
  • Posts: 126
Re: Request: Add Compiz and Emerald for XFCE ?
« Reply #4 on: August 19, 2014, 05:29:26 pm »
PS

I just noticed that in my Compiz debs folder there is a 'metacity-common" deb.  Perhaps if this is NOT installed and the new one from Debian is, the issue I had will NOT crop up????
Wish I could be of more help, but am ignorant on this... :-[