Author Topic: how to fix broken packages  (Read 1033 times)

Offline hedgepig

  • Newbie
  • *
  • Posts: 6
how to fix broken packages
« on: May 29, 2014, 03:38:58 am »
Hi,

I use synaptic package manager to install some software.

It happens every now and then, that it sais something like "can't apply, please fix broken packages first." (my sparky is german, hopefully I translated it good enough...)

So finally I found The repair-option...and get a warning again!



E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.

E: Auflösen der Abhängigkeiten ist fehlgeschlagen



Try to translate...



E:interruptions caused by pkgProblemResolver::Resolve

could have happened because of restrained packages



E:resolve of dependencies failed



so, what can I do now?



If important for help, I try to install audacious.



thanks.

« Last Edit: May 29, 2014, 03:38:58 am by 588 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: how to fix broken packages
« Reply #1 on: May 29, 2014, 12:58:01 pm »
I saw that audacious has missing dependencies. It means it can't be installed in this moment.

If you tried to install it, the installation has been stopped and audacious is marked as broken.

Solution in Synaptic:

Find audacious or any package marked as red and unmark it.

In terminal run:

Code:

sudo apt-get remove audaciuos


It will remove the broken package.
« Last Edit: July 01, 2014, 03:59:46 pm by 14 »
Nothing is easy as it looks.

Offline hedgepig

  • Newbie
  • *
  • Posts: 6
Re: how to fix broken packages
« Reply #2 on: May 29, 2014, 11:29:30 pm »
Ok.

So when you say, it cant be installed because of missing dependencies, you mean it isn't my problem, but the problem of audacious. So its useless to go on trying to install it?

« Last Edit: July 01, 2014, 03:59:32 pm by 588 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: how to fix broken packages
« Reply #3 on: May 30, 2014, 12:36:17 am »
Open Synaptic-> Settings-> Repositories-> mark 3 lines of Debian Sid: deb -> sid, deb-src -> sid and deb multimedia sid.

Then Reload and find audacious.

The application can be installed now from Debian unstable Sid repo.

After installation go again to repositories and unmark the 3 lines and reload it again.
« Last Edit: July 01, 2014, 03:59:07 pm by 14 »
Nothing is easy as it looks.