Author Topic: POL+Sparky+Guild War  (Read 854 times)

Offline mrvamps

  • Newbie
  • *
  • Posts: 4
POL+Sparky+Guild War
« on: April 09, 2014, 03:34:11 am »
SO i installed Play on linux to handle my wine installs of different games i play.

i installed Guild Wars a few days ago, and now it seems that i'm not able to play it any more.

the error i'm gettin is that the 3d init cant be started. i had GW running prior, but all of a sudden, its a no go.

i've not made any hardware changes, and kept the system up to date.

so why am i not able to play guild wars any more?

any extra info you need i can get for ya.

Thanks for the help guys

Vamps
« Last Edit: April 09, 2014, 03:34:11 am by 454 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: POL+Sparky+Guild War
« Reply #1 on: April 09, 2014, 01:41:43 pm »
What is your sparky version - 32 or 64 bit?

When you were installing playonlinux, did it not remove any wine packages?

Let me know what wine packages you have installed now, show me a list of your all wine packs installed.
« Last Edit: July 01, 2014, 01:50:45 pm by 14 »
Nothing is easy as it looks.

Offline mrvamps

  • Newbie
  • *
  • Posts: 4
Re: POL+Sparky+Guild War
« Reply #2 on: April 09, 2014, 04:55:34 pm »
pavroo, thanks for the reply.

My Sparky is 32 bit. and i dont remember seeing any packages removed during POL install.

here is the output of dpkg-query -l 'wine*'

please let me know if there's any other info you need

Code:

root@beastlaptop:/home/richie# dpkg-query -l 'wine*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                   Version                  Architecture             Description
+++-======================================-========================-========================-=================================================================================
ii  wine                                   1.6.2-7                  i386                     Windows API implementation - standard suite
un  wine-bin                               <none>                   <none>                   (no description available)
un  wine-doc                               <none>                   <none>                   (no description available)
un  wine-unstable                          <none>                   <none>                   (no description available)
ii  wine32                                 1.6.2-7                  i386                     Windows API implementation - 32-bit binary loader
un  wine64                                 <none>                   <none>                   (no description available)
un  wine64-bin                             <none>                   <none>                   (no description available)


« Last Edit: July 01, 2014, 01:50:31 pm by 454 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: POL+Sparky+Guild War
« Reply #3 on: April 09, 2014, 05:15:29 pm »
It's fine, there is a little newer version of wine in the repo, but it does not make big changes.

Did you try to reinstall your game using wine? Maybe running playonlinux the first time made changes in wine configuration files.
« Last Edit: July 01, 2014, 01:50:08 pm by 14 »
Nothing is easy as it looks.

Offline mrvamps

  • Newbie
  • *
  • Posts: 4
Re: POL+Sparky+Guild War
« Reply #4 on: April 09, 2014, 05:19:36 pm »
maybe removing POL then autoremove and just install wine and try that?

« Last Edit: July 01, 2014, 01:49:51 pm by 454 »

Offline mrvamps

  • Newbie
  • *
  • Posts: 4
Re: POL+Sparky+Guild War
« Reply #5 on: April 09, 2014, 06:09:49 pm »

Quote:

Quote from mrvamps on April 9, 2014, 17:19

maybe removing POL then autoremove and just install wine and try that?




Pavroo,

I think that did it. I uninstall GuildWars thru POL, then apt-get remove playonlinux --purge then apt-get update then apt-get install wine winetricks and i now have it in fullscreen (without the DX 8 error) and currently downloading the image of the dat file.

thanks for the help.

I should remember that POL reacts differently per distro/flavor. On Arch, i have no problem with POL.

thanks for the help.
« Last Edit: July 01, 2014, 01:49:15 pm by 454 »