Author Topic: Sparky tools for Sparky base edition  (Read 1027 times)

Offline rmcellig

  • Newbie
  • *
  • Posts: 14
Sparky tools for Sparky base edition
« on: March 23, 2014, 06:35:40 pm »
I was wondering if the Sparky Tools are available for the Base Openbox edition.



Thanks!!
« Last Edit: March 23, 2014, 06:35:40 pm by 404 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky tools for Sparky base edition
« Reply #1 on: March 23, 2014, 07:22:41 pm »
The Sparky tools are available for all editions.

Open Synaptic, refresh package list and use Search box with 'sparky' key word to print all sparky packages.
« Last Edit: July 01, 2014, 01:24:25 am by 14 »
Nothing is easy as it looks.

Offline rmcellig

  • Newbie
  • *
  • Posts: 14
Re: Sparky tools for Sparky base edition
« Reply #2 on: March 23, 2014, 10:34:17 pm »
Thanks. When I reloaded synaptic and went to install the Sparky tools, I received this error:



E: Unable to correct problems, you have held broken packages.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

E: Unable to correct dependencies

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

E: Unable to correct dependencies



What should I do? This happened when I went to install Sparky center openbox.

« Last Edit: July 01, 2014, 01:24:10 am by 404 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky tools for Sparky base edition
« Reply #3 on: March 23, 2014, 10:46:24 pm »
Probably you have broken or not installed correctly packages.

Check "Broken packages" in the left sidebar of Synaptic and remove theme before installing new ones.

Also use the same command as for Skype to fix broken packages:

Code:

apt-get update
apt-get install -f


« Last Edit: July 01, 2014, 01:23:56 am by 14 »
Nothing is easy as it looks.

Offline rmcellig

  • Newbie
  • *
  • Posts: 14
Re: Sparky tools for Sparky base edition
« Reply #4 on: March 23, 2014, 11:13:10 pm »
Thanks! I can't see broken packages on the left side of Synaptic. I clicked on Status and don't see it in the list. I clicked on Custom filters-broken, and don't see any broken packages. I ran Sudo apt-get update as well as sudo apt-get install -f. Then I ran sudo apt-get install sparky-center-openbox and received this:



Code:

randy@sparky:~$ sudo apt-get install sparky-center-openbox
[sudo] password for randy:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sparky-center-openbox : Depends: gpointing-device-settings but it is not installable
E: Unable to correct problems, you have held broken packages.
randy@sparky:~$


« Last Edit: July 01, 2014, 01:23:41 am by 404 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Sparky tools for Sparky base edition
« Reply #5 on: March 23, 2014, 11:36:37 pm »
Package 'gpointing-device-settings' has been removed from Debian testing repository, but it's available in Sid repos.

1. Edit repository:

Code:

sudo leafpad /etc/apt/sources.list


2. Add Sid repo at the end of the file, under the last line:

Code:

## sid
deb http://ftp.debian.org/debian/ sid main contrib non-free  
deb-src http://ftp.debian.org/debian/ sid main contrib non-free  
deb http://www.deb-multimedia.org/ sid main non-free


3. Save the file, refresh packages list and install missing tool:

Code:

apt-get update
apt-get install gpointing-device-settings


5. Edit repository again and put '#' in the front of the 3 new Sid lines:

Code:

# deb http://ftp.debian.org/debian/ sid main contrib non-free  
# deb-src http://ftp.debian.org/debian/ sid main contrib non-free  
# deb http://www.deb-multimedia.org/ sid main non-free


6. Refresh packages list and install 'sparky-center-openbox':

Code:

apt-get update
apt-get install sparky-center-openbox


If any problem with installing, use:

Code:

apt-get install -f


« Last Edit: July 01, 2014, 01:23:26 am by 14 »
Nothing is easy as it looks.

Offline rmcellig

  • Newbie
  • *
  • Posts: 14
Re: Sparky tools for Sparky base edition
« Reply #6 on: March 24, 2014, 12:29:48 am »
Thanks!
« Last Edit: July 01, 2014, 01:23:09 am by 404 »