Author Topic: XBMC missing OpenGL  (Read 1010 times)

Offline iak92

  • Newbie
  • *
  • Posts: 4
XBMC missing OpenGL
« on: March 22, 2014, 12:41:00 am »
Hey,



I want to install XBMC on my SpakyLinux 3.3 with LXDE. Now I have the Problem that XBMC says: "XBMC needs hardware accelerate OpenGL rendering. Install an apprpiate graphics driver". I have the Linux Kernel 3.13.6 and have an ATI Mobile Readeon HD 5650 graphic card. I currently use the "xserver-xorg-video-radeon" driver I also tried the fglrx-driver but with this one my Monitor stood black. Anybody can help?



Thanks
« Last Edit: March 22, 2014, 12:41:00 am by 414 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1467
    • SparkyLinux
Re: XBMC missing OpenGL
« Reply #1 on: March 22, 2014, 01:47:55 am »
I don't use proprietary drivers and I don't want to tell you something wrong, but you can try:

Code:

sudo apt-get remove --purge fglrx*
sudo apt-get update && sudo apt-get install fglrx-driver fglrx-control
sudo /usr/bin/aticonfig --initial
Reboot


« Last Edit: July 01, 2014, 01:14:25 am by 14 »
Nothing is easy as it looks.

Offline iak92

  • Newbie
  • *
  • Posts: 4
Re: XBMC missing OpenGL
« Reply #2 on: March 23, 2014, 04:22:31 pm »
Hey



I tried it this way unfortunaly I still have the problem with the Blackscreen. The Blackscreen is also in recovery mode. So i googled a little bit. I ran the follow line

Code:

grep fglrx /etc/modprobe.d/*


it printed out. fglrx conflicts with the free radeon driver. So I uninstalled the other graphics driver and reconfig the xorg.confi with

Code:

aticonfig --initial --force


and rebootet the system. still blackscreen and the grep prints still out the same. some ideas?

« Last Edit: July 01, 2014, 01:14:12 am by 414 »