Author Topic: <SOLVED>Broadcom wifi not working on HP2133 netbook  (Read 3983 times)

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
<SOLVED>Broadcom wifi not working on HP2133 netbook
« on: February 20, 2014, 06:21:45 pm »
I havedoone a full install on an old 2133 notebook i have lying around, works fine exept i cant get the wifi to work, it dosent appear n the network menu, and i cant find any info on the driver online, can anyone help? please note i'm verry new to linx.
« Last Edit: February 20, 2014, 06:21:45 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #1 on: February 20, 2014, 07:15:16 pm »
Show me results of two commands from a terminal: 'lspci' and 'lsusb'.

« Last Edit: June 30, 2014, 06:56:21 pm by 14 »
Nothing is easy as it looks.

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #2 on: February 20, 2014, 07:50:48 pm »
https://docs.google.com/file/d/0BwUH__z8gjdHUmJZaWxpWEdOMFU/edit?usp=docslist_api
https://docs.google.com/file/d/0BwUH__z8gjdHckRTT2d2WE15UTA/edit?usp=docslist_api
sorry they are images, cant get online on hp yet, ethernet cable MIA
« Last Edit: June 30, 2014, 06:56:06 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #3 on: February 20, 2014, 10:22:08 pm »
It's OK.

But you can use Lxterminal or MATE-terminal, depence what desktop you have (what desktop/sparky version you have?)

Don't run the system in text mode, run it as normal mode and run from menu-> accesories-> terminal, log in as root:

Code:

su
modprobe -r b43


If it does not show any problems, run:

Code:

modprobe b43


Then check your wifi networks.
« Last Edit: June 30, 2014, 06:55:48 pm by 14 »
Nothing is easy as it looks.

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #4 on: February 20, 2014, 10:53:11 pm »
Thanks, I'm using ultra, stupid question, I'm a ubento user, how do you log in as root in the terminal?

I am running gui, just full screen xterm to make text fit, didn't know ther was a text only mode.

« Last Edit: June 30, 2014, 06:55:31 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #5 on: February 20, 2014, 11:03:22 pm »
If you have Ultra, you should running Openbox desktop.

If so, right click of your mouse-> choose "Terminal emulator".

Then type:

Code:

su


and type root/admin password you created during system installation on a hard drive.

Then type:

Code:

modprobe -r b43
modprobe b43


and check network icon on the panel - networks names should be displayed there.
« Last Edit: June 30, 2014, 06:55:08 pm by 14 »
Nothing is easy as it looks.

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #6 on: February 21, 2014, 12:28:55 am »
Thanks
« Last Edit: June 30, 2014, 06:54:48 pm by 272 »

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #7 on: February 23, 2014, 09:46:11 pm »
Ok, this works great, but isn't permanent, is there any way to get it to run automatically on startup, sort of .bat in startup equivalent?
« Last Edit: June 30, 2014, 06:54:33 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #8 on: February 24, 2014, 01:13:19 am »
Login as root/admin in a terminal emulator as before and edit 'modules' file, just copy the text and past it to the terminal:

Code:

leafpad /etc/modules


Add the text below to the file just before 'loop', so it has to looks like that:

Code:

b43
loop


Then save the file, close everything and reboot your machine.
« Last Edit: June 30, 2014, 06:54:15 pm by 14 »
Nothing is easy as it looks.

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #9 on: February 24, 2014, 09:07:28 pm »
Thank you, is ther a webpage anywhere explaining what the problem was? I'd like to know so if something similar happens again I can fix it.
« Last Edit: June 30, 2014, 06:53:47 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #10 on: February 25, 2014, 09:35:07 pm »
No, it is not.

It happens if a module of a device (a driver) is not loaded automatically.

That's why the forum exist for.
« Last Edit: June 30, 2014, 06:57:41 pm by 14 »
Nothing is easy as it looks.

Offline Linux_Newbi

  • Newbie
  • *
  • Posts: 45
Re: wifi not working on HP2133 netbook
« Reply #11 on: February 25, 2014, 09:41:42 pm »
Yes, but I feel bad bugging you all the time, and I want to learn.
« Last Edit: June 30, 2014, 06:57:27 pm by 272 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: wifi not working on HP2133 netbook
« Reply #12 on: February 25, 2014, 10:02:23 pm »
Don't be :)

« Last Edit: June 30, 2014, 06:57:05 pm by 14 »
Nothing is easy as it looks.

Offline kevjonesin

  • Newbie
  • *
  • Posts: 1
Re: Broadcom wifi not working on HP2133 netbook
« Reply #13 on: June 06, 2014, 12:01:21 am »
I just started playing with Sparkylinux 3.4 E18 (live usb) and noticed that a number of Broadcom drivers are 'blacklisted' by default in:



/etc/modprobe.d/broadcom-sta-common.conf



Which probably relates to Linux_Newb-i having had to manually enable the 'b43' driver.





As for myself, I just adapted the command ("modprobe -r b44 ...") to enable the 'b44' kernel module/driver to access my "Broadcom Corporation BCM4401 100Base-T (rev 01)" Ethernet controller. My wired connection is working now, but I thought I'd share the detail I learned while sorting it out.

« Last Edit: July 01, 2014, 04:14:40 pm by 592 »

Offline configX

  • Newbie
  • *
  • Posts: 17
Re: <SOLVED>Broadcom wifi not working on HP2133 netbook
« Reply #14 on: October 26, 2014, 06:26:15 pm »
What's interesting is that I had this same issue on an older Intel iMac with the LXDE edition but it worked out of the box with the JWM edition.