Author Topic: sparky cli jwm  (Read 979 times)

Offline fanis

  • Newbie
  • *
  • Posts: 14
sparky cli jwm
« on: February 17, 2014, 10:25:53 pm »
I have installed sparky cli. what I want to do is to run jwm but with no display manager. I installed jwm, I also installed xorg. but so far I can not run jwm. I also created .xinitrc with exec jwm in it but startx still does not work. I am a noob, so what I am missing please? I have not found more specific guide to this.



thank you
« Last Edit: February 17, 2014, 10:25:53 pm by 256 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: sparky cli jwm
« Reply #1 on: February 18, 2014, 12:23:19 am »
Create the file in your home directory:

Code:

.xsession


place it inside:

Code:

exec /usr/bin/jwm


Then:

Code:

chown you .xsession
chmod 755 .xsession


If still a problem do:

Code:

chmod a+x .xsession


« Last Edit: June 30, 2014, 06:52:39 pm by 14 »
Nothing is easy as it looks.

Offline fanis

  • Newbie
  • *
  • Posts: 14
Re: sparky cli jwm
« Reply #2 on: February 22, 2014, 06:47:40 pm »
thank you for the reply but this was not enough.



this is the error message I get



Code:



X.Org X Server 1.15.0
Release Date: 2013-12-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
Current Operating System: Linux rlyeh 3.12-1-486 #1 Debian 3.12.9-1 (2014-02-01) i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12-1-486 root=UUID=66a86655-5591-42de-8a63-89288431a699 ro quiet
Build Date: 07 February 2014  12:14:17PM
xorg-server 2:1.15.0-2 (http://www.debian.org/support)
Current version of pixman: 0.32.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 22 18:33:26 2014
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error




« Last Edit: June 30, 2014, 06:52:22 pm by 256 »

Offline fanis

  • Newbie
  • *
  • Posts: 14
Re: sparky cli jwm
« Reply #3 on: February 22, 2014, 06:53:58 pm »
I am trying to posto the Xorg.0.log but the forum refuses (seems there is a length limit)

it has a warning that it could not open nouveau and then an error that it failed to load module nouveau (and other errors later that seems to relate with that failure)
« Last Edit: June 30, 2014, 06:52:05 pm by 256 »

Offline garrick

  • Newbie
  • *
  • Posts: 1
Re: sparky cli jwm
« Reply #4 on: March 19, 2014, 11:13:45 pm »
meaby you dont have 'libgl1-mesa-dri' and 'libgl1-mesa-glx' on your system;)



http://paste.debian.net/
« Last Edit: June 30, 2014, 06:51:38 pm by 405 »