Author Topic: [SOLVED] Problems With New User  (Read 1281 times)

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
[SOLVED] Problems With New User
« on: October 04, 2013, 06:35:31 pm »
I've created a 'new user' in Users and Groups . (Running sparky Mate )

When I log in to the  New User everything works except synaptic - it will not launch.  :(



Any ideas ?
« Last Edit: October 04, 2013, 06:35:31 pm by 16 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Problems With New User
« Reply #1 on: October 04, 2013, 09:41:25 pm »
If you tried to launch it from the Menu - it has a small bug if I remember well.

Edit (as root) file: /usr/share/applications/synaptic.desktop and synaptic-kde.desktop

Change the line from:

Exec=synaptic

to:

Exec=synaptic-pkexec

or:

Exec=remsu synaptic
« Last Edit: June 29, 2014, 06:14:13 pm by 14 »
Nothing is easy as it looks.

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: Problems With New User
« Reply #2 on: October 04, 2013, 10:23:14 pm »
Tried both of those , still won't launch and I have just discovered I can't launch it using terminal



This is what I get in terminal



Password:

root@sparkyusb:/home/live# synaptic



(synaptic:4554): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable



(synaptic:4554): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.4/./gobject/gtype.c:4239: type id `0' is invalid



(synaptic:4554): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

Segmentation fault

« Last Edit: June 29, 2014, 06:13:54 pm by 16 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Problems With New User
« Reply #3 on: October 04, 2013, 11:00:22 pm »
Not sure, but try to change a desktop theme first.
« Last Edit: June 29, 2014, 06:13:37 pm by 14 »
Nothing is easy as it looks.

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: Problems With New User
« Reply #4 on: October 04, 2013, 11:30:18 pm »
Still no joy, I even added another user using the method in FAQ but that didn't work either
« Last Edit: June 29, 2014, 06:13:20 pm by 16 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Problems With New User
« Reply #5 on: October 04, 2013, 11:37:55 pm »
I still looks like a GTK problem of root user, check this:

http://crunchbang.org/forums/viewtopic.php?id=28574
« Last Edit: June 29, 2014, 06:13:04 pm by 14 »
Nothing is easy as it looks.

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: Problems With New User
« Reply #6 on: October 04, 2013, 11:55:49 pm »

Quote:

Quote from pavroo on October 4, 2013, 23:37

I still looks like a GTK problem of root user, check this:

http://crunchbang.org/forums/viewtopic.php?id=28574


You could be right but how do I change a GTK theme ?
« Last Edit: June 29, 2014, 06:12:41 pm by 16 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Problems With New User
« Reply #7 on: October 05, 2013, 12:04:48 am »
Launch lxappearance as root:

su

lxappearance

then choose a differen theme, try Sparky3 for example and Apply.
« Last Edit: June 29, 2014, 06:12:24 pm by 14 »
Nothing is easy as it looks.

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: Problems With New User
« Reply #8 on: October 05, 2013, 12:09:55 am »
Aha doing as you say I get



john@sparkyusb:~$ su

Password:

root@sparkyusb:/home/john# lxappearance

bash: lxappearance: command not found

root@sparkyusb:/home/john#

« Last Edit: June 29, 2014, 06:12:03 pm by 16 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1465
    • SparkyLinux
Re: Problems With New User
« Reply #9 on: October 05, 2013, 12:28:48 am »
Good Lord, I forgotten you have MATE not LXDE so run as root:

mate-appearance-properties

then try to choose Menta or TraditionaGreen or any different theme.
« Last Edit: June 29, 2014, 06:11:36 pm by 14 »
Nothing is easy as it looks.

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: Problems With New User
« Reply #10 on: October 05, 2013, 12:47:31 am »
As we english say BINGO - Menta didn't work BUT TraditionalGreen did !!!!!!!!!!!!!

Thanks
« Last Edit: June 29, 2014, 06:11:09 pm by 16 »

Offline The Black Pig

  • Global Moderator
  • Full Member
  • *****
  • Posts: 169
Re: [SOLVED] Problems With New User
« Reply #11 on: October 05, 2013, 01:07:19 am »
As we say in England BINGO - TraditionalGreen worked and now all the others are working including the one that didn't work before !!!!!!!!!!!!!!!
« Last Edit: June 29, 2014, 06:14:44 pm by 16 »