User Tools

Site Tools


repository_stable

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
repository_stable [2018/01/30 11:40]
pavroo
repository_stable [2019/01/03 12:20]
pavroo
Line 5: Line 5:
 ==== Repository ==== ==== Repository ====
  
-Users of Debian "​stable"​ branch should add Sparky **stable** and **testing** repositories to get access to Sparky repos.  +Users of Debian "​stable"​ branch should add Sparky **stable** and **core** repositories to get access to Sparky repos:
- +
-Sparky **stable** repository:+
  
    sudo nano /​etc/​apt/​sources.list.d/​sparky-stable.list    sudo nano /​etc/​apt/​sources.list.d/​sparky-stable.list
Line 15: Line 13:
    deb https://​sparkylinux.org/​repo stable main    deb https://​sparkylinux.org/​repo stable main
    ​deb-src https://​sparkylinux.org/​repo stable main    ​deb-src https://​sparkylinux.org/​repo stable main
- +   deb https://​sparkylinux.org/​repo ​core main 
-Sparky **testing** repository:​ +   ​deb-src https://​sparkylinux.org/​repo ​core main
- +
-   sudo nano /​etc/​apt/​sources.list.d/​sparky-testing.list +
- +
-and paste into the file: +
- +
-   deb https://​sparkylinux.org/​repo ​testing ​main +
-   ​deb-src https://​sparkylinux.org/​repo ​testing ​main+
  
 Create a preference file: Create a preference file:
Line 32: Line 23:
  
    ​Package:​ *    ​Package:​ *
-   Pin: release o=SparkyLinux,a=stable+   Pin: release o=SparkyLinux
    ​Pin-Priority:​ 1001    ​Pin-Priority:​ 1001
-    
-   ​Package:​ * 
-   Pin: release o=SparkyLinux,​a=testing 
-   ​Pin-Priority:​ 900 
  
 Otherwise, install '​sparky-apt'​ 4.x package to do so. Otherwise, install '​sparky-apt'​ 4.x package to do so.
Line 54: Line 41:
  
    wget -O - https://​sparkylinux.org/​repo/​sparkylinux.gpg.key | sudo apt-key add -    wget -O - https://​sparkylinux.org/​repo/​sparkylinux.gpg.key | sudo apt-key add -
- 
-<WRAP center info 100%> 
-Important ! 
-Sparky of the "​stable"​ line uses Sparky "​stable"​ and "​testing"​ repositories. 
-</​WRAP>​ 
  
 <WRAP center info 100%> <WRAP center info 100%>
 Make sure you have '​apt-transport-https'​ package installed (Sparky up to 4.x only). Make sure you have '​apt-transport-https'​ package installed (Sparky up to 4.x only).
 </​WRAP>​ </​WRAP>​
repository_stable.txt · Last modified: 2019/01/03 12:20 by pavroo