Advertising

Author Topic: xfwm4 -- why? and how to get rid of? [SOLVED]  (Read 2204 times)

Offline kendew

  • Newbie
  • *
  • Posts: 33
xfwm4 -- why? and how to get rid of? [SOLVED]
« on: April 28, 2019, 11:07:14 pm »
One of the things that attracted me to Sparky was I like Openbox and LXQt.  My memory may not be serving me well here, but I think Sparky was one of the first distros to have an LXQt version.  On the other hand, I don't care much for Xfce, though it is certainly a well developed DE that can run on little memory.  In particular, I suspect xfwm4 as a culprit in video tearing and poor performance.
I installed SparkyLinux 5.7.1 MinimalGUI, hoping it was, well, minimal.  I can install applications I need as I need them.  I'm not wanting Libre Office, loads of browsers, etc from the start.  I then installed LXQt and set up Openbox to fall back on in case there was a problem with LXQt.  However, if I look a lot of xfce4 related apps, like xfce4-power-manager preinstalled, although xfce4 itself is not.  I can live with xfce4-power-manager, but would rather not have xfwm4.  For window managers I want to rely on Compton enabled Openbox and Kwin. 
I'm worried xfwm4 conflict with these.  I wonder what exactly is xfwm4's purpose in Sparky.  Can I safely uninstall it without messing up something else?  Or did I install the wrong version of Sparky for my purposes?  Am I with the wrong distro?  Again, my focus is on Openbox, LXQt, and minimal applications.
Any insight appreciated.
« Last Edit: April 30, 2019, 05:44:47 am by kendew »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 627
Re: xfwm4 -- why? and how to get rid of?
« Reply #1 on: April 29, 2019, 01:13:58 am »
http://sparkylinux.org/forum/index.php/topic,4664.msg11937.html#msg11937    Reply 9              It has been answered before

It has been awhile now that xfwm4 is the default option in a LXQT install.  But every standard LXQT  install offers the choice of openbox or xfwm4. 
It is not about Sparky, it is the design of LXQT. 

xfwm4 and openbox are "agnostic" they are both designed to work in most standard environments.  xfwm4 is wayland compliant,  openbox is not, LXQT is pro-active and  designing  for the future. 

To change go to  Preferences >>  LXQT >> Session Settings >> Basic Settings  >> Window Manger>>  hit the upside down carat button  (  ^ is a carat ) you will have the option of xfwm4 or openbox.  ( I also have I3)..

After you select openbox open a terminal and    "sudo apt purge xfwm4" 

When done, please mark as solved.     


Don't make a FrankenDebian

Offline kendew

  • Newbie
  • *
  • Posts: 33
Re: xfwm4 -- why? and how to get rid of?
« Reply #2 on: April 30, 2019, 03:46:56 am »
Thank you for the reply.
The link given does answer the "why?" part of my question.
As for the how to get rid of part, you seem to feel purging it is okay.  My concern is whether purging xfwm4 might cause repercussions if other programs depend on it.  In fact, I had already purged it and on rebooting Sparky I only got as far as a CLI login prompt -- in other words, the X server didn't initiate.  I was concerned purging xfwm4 might have had something to do with that.  However, after logging in and rebooting, I found other problems, which fsck fixed, so I guessed the culprit was probably not a missing xfwm4.  I think it's great xfwm4 is wayland compliant.  My issue with it was the quality of graphics I found on older radeon chips.  My interest in getting rid of it was to be sure it wouldn't be running in the background or something.
What you told me about xfwm4 being about LXQt and not about Sparky was very helpful and I thank you for sharing that information. 

Offline kendew

  • Newbie
  • *
  • Posts: 33
Re: xfwm4 -- why? and how to get rid of?
« Reply #3 on: April 30, 2019, 05:43:57 am »
Well, okay, I discovered something new I'm going to post in case anyone else interested in this question stumbles across this thread.  As I already mentioned, I originally installed SparkyLinux 5.7.1 MinimalGUI, hoping to avoid apps I had no need of.  Just now I installed the LXQt version of Sparky 5.7.1, both in a VM and on a Lenovo X120e laptop.  I wanted to find out what Sparky's take on LXQt would be. 
Lo and behold, there was no xfwm4.  Also, a lot of the other xfce related packages such as xfce panel I noticed were not installed.  The only xfce related package I saw was xfburn and its dependencies.  When I installed lxqt onto the MinimalGUI version, I installed the package 'lxqt', the LXQt metapackage.  This brings in xfwm4 along with a number of other apps.  In the Sparky LXQt version, this metapackage was not installed.  As installed, this Sparky LXQt version leaves Openbox as the only option in the LXQt Session Settings dialog.
So, we have another answer to my question, how to get rid of xfwm4.  Do it the Sparky way and don't install it in the first place.  I am still experimenting, and will try installing Kwin as an alternative window manager and see if that helps improve video quality.  If it does, I'll add a note here, but for now I can feel that the problem has been solved.

« Last Edit: April 30, 2019, 05:46:41 am by kendew »

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 114
    • Sparky Community Repos
Re: xfwm4 -- why? and how to get rid of? [SOLVED]
« Reply #4 on: April 30, 2019, 11:08:27 am »
Hey kendew. Few words of clarification. Package lxqt comes from debian repo and set of applications it provides  has been picked by Debian folks not Sparky team. Next time install sparky-desktop-lxqt but this way you won't get Sparky configuration files. Best way of adding new desktop is to use APTus. APTus installs set of apps and sparky config files.

And as of why there are xfce apps in Sparky miniGUI . Answer is quite simple. Users were requesting some quality of life improvements like working screen brightness  and speaker volume function keys or tap to click working on touchpads. Some of those functionalities were added through config files some through additional apps like xfce4-power-manager.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net