Advertising

Author Topic: [RESOLU] Password sur Screener !  (Read 399 times)

Offline piotrfr

  • Newbie
  • *
  • Posts: 8
[RESOLU] Password sur Screener !
« on: December 24, 2018, 02:37:45 pm »
Hello all
 ;)
I am French so my English will be a translated version!
a thousand excuses for misunderstandings ...

When I put my screen in standby, if I want to regain control, he offers me a login but my password does not work, I have to "change user" then submit my login and password?
Would there be a solution for this?
thanks for the help coming

Good day to everyone
-------------------------------------------
Bonjour à toutes et tous
 ;)
je suis français donc mon anglais ne sera qu'une version traduite !
mille excuses pour les incompréhensions...

Lorsque je mets mon écran en veille, si je veux reprendre la main, il me propose un login mais mon mot de passe ne fonctionne pas, je dois faire "changer d'utilisateur" puis remettre mon login et mon mot de passe ?
Y aurait-il une solution pour cela ?
merci pour l'aide à venir

bonne journée à toutes et tous
« Last Edit: December 27, 2018, 01:34:24 pm by piotrfr »

Offline penguin

  • Jr. Member
  • **
  • Posts: 94
Re: Password sur Screener !
« Reply #1 on: December 26, 2018, 08:56:23 pm »
What version of sparky you are using ? What desktop ? This happens me times ago. I am not very sure but I think that in Terminal your sparky use another keyboard.What kind of keyboard you are using ? French or another one ? What kind of locker you are using Screen Saver that is installed by Sparky or another one ?( I use i3locker)

Execute in terminal the follow command:

setxkbmap -query and find way your keyboard.

I have described the similar problem in one of my posts in this forum.

Anyway . Execute in Terminal the follow command

localectl set-x11-keymap XX  ( replace XX with keyboard of your layout) that suppose to have the same results as editing of
/etc/vconsole.conf as sudo and change KEYMAP=XX where XX is your keyboard.

also see this
Code: [Select]
https://github.com/solus-project/budgie-desktop/issues/731 as follow:

Quote
got it working with this:
/etc/X11/xorg.conf.d/00-keyboard.conf:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbModel" "pc104"
        #Option "XkbLayout" "XX"
        Option "XkbLayout" "XX"
        Option "XkbVariant" "nodeadkeys"
EndSection



where XX is your keyboard

and do not forget to run in terminal sudo update-initramfs -u

and gave you all possibilities how to correct. Try and post your feedback

Offline lami07

  • Global Moderator
  • Newbie
  • *****
  • Posts: 49
    • Sparky Community Repos
Re: Password sur Screener !
« Reply #2 on: December 26, 2018, 09:11:26 pm »
Hi. Run in terminal
Code: [Select]
  ls -l /etc/shadow
Paste here the result.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline piotrfr

  • Newbie
  • *
  • Posts: 8
Re: Password sur Screener !
« Reply #3 on: December 26, 2018, 11:38:56 pm »
thank you for your help to both of you

@penguin I tried your proposals but nothing works?

@ lami07 here is the result:
~ $ ls -l / etc / shadow
-rw-r ----- 1 root root 1407 dec. 21 10:37 / etc / shadow
------------------------------------------
merci pour votre aide à tous les deux

@penguin j'ai tenté tes propositions mais rien ne fonctionne ?

@lami07 voici le resultat:
~$ ls -l /etc/shadow
-rw-r----- 1 root root 1407 déc.  21 10:37 /etc/shadow

Offline lami07

  • Global Moderator
  • Newbie
  • *****
  • Posts: 49
    • Sparky Community Repos
Re: Password sur Screener !
« Reply #4 on: December 27, 2018, 05:47:30 am »
Ok. Modify ownership of /etc/shadow with this command:
Code: [Select]
sudo chown root:shadow /etc/shadow It should help.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline piotrfr

  • Newbie
  • *
  • Posts: 8
Re: Password sur Screener !
« Reply #5 on: December 27, 2018, 01:33:20 pm »
 ;) ;) ;)

salut et mille mercis pour cette astuce qui fonctionne parfaitement !

merci beaucoup !

bonne journée à toutes et tous
 :)

Offline lami07

  • Global Moderator
  • Newbie
  • *****
  • Posts: 49
    • Sparky Community Repos
Re: [RESOLU] Password sur Screener !
« Reply #6 on: December 27, 2018, 02:20:12 pm »
 :) You're welcome.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net