Advertising

Author Topic: Touchpad On-Off (Humbled!)  (Read 378 times)

Offline zandoval

  • Newbie
  • *
  • Posts: 11
Touchpad On-Off (Humbled!)
« on: December 09, 2018, 08:06:28 pm »
In other LXDE distros I was able to turn the touchpad On or Off using - "synclient TouchpadOff=1" or "synclient TouchpadOff=0" This is not working on Sparky Ver 4.

After digging around also tried using various line commands in xinput, synaptics, and xserver, and luckily got everything back to normal after making a real mess.

Now this could be a hardware problem as I am using a DELL Lattitude E5530, but I keep thinking there should be a simple line command to turn this touchpad off or on...

Any Idias before I give up?

No mater where your at... There you are.

Offline lami07

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 79
    • Sparky Community Repos
Re: Touchpad On-Off (Humbled!)
« Reply #1 on: December 09, 2018, 09:53:33 pm »
In other LXDE distros I was able to turn the touchpad On or Off using - "synclient TouchpadOff=1" or "synclient TouchpadOff=0" This is not working on Sparky Ver 4.
It does not work because sparky 4 is using xserver-xorg-input-libinput driver instead  xserver-xorg-input-synaptics.

Try this:

1)install xinput
Code: [Select]
sudo apt install xinput2)check the device name with :
Code: [Select]
xinput list probably it will be "SynPS/2 Synaptics TouchPad"

3)Do the magic:
disable touchpad with
Code: [Select]
xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 0
enable touchpad with
Code: [Select]
xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 1
substitute "SynPS/2 Synaptics TouchPad" with your device name
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline zandoval

  • Newbie
  • *
  • Posts: 11
Re: Touchpad On-Off (Humbled!)
« Reply #2 on: December 10, 2018, 06:26:45 am »
IT WORKS!!!
Thank You...  after installing xinput the list showed "AlpsPS/2 ALPS GlidePoint" as the touchpad device. I just pasted it into the command line for off and on. Now by command line or bash I can have the touchpad on or off.

xinput set-prop "AlpsPS/2 ALPS GlidePoint" "Device Enabled" 0 (=Off)

xinput set-prop "AlpsPS/2 ALPS GlidePoint" "Device Enabled" 1 (=On)
No mater where your at... There you are.