Author Topic: cmus issue  (Read 1000 times)

Offline carlo

  • Full Member
  • ***
  • Posts: 212
cmus issue
« on: December 07, 2017, 11:28:35 pm »
hi all
i've met some issue with cmus in pc office: it says something like it cannot read the source; moreover the keyboard shortcuts to raise or lower volume didn't work to me, and the audio settings shortcut on cinnamon bar disappeared.
As far as i've understood there's some issue with pulseaudio, not sure what the cause might be

i could solve these issues by adding /usr/bin/pulseaudio to the list of programs which are started automatically by cinnamon (no: the other pulseaudio program cinnamon on its own isn't enough)

hope i've been useful

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 603
Re: cmus issue
« Reply #1 on: December 08, 2017, 09:22:25 pm »
I have no idea what pc office is. 

32 bit Sparky-Debian testing works for me.  LXQT version

when started from command line  it uses ncurses, not sure how to get error messages.  If you get error messages, from command line - post with mark up.  System details via inxi are also nice. 

Do you have cmus-plugin-ffmpeg installed?
Don't make a FrankenDebian

Offline carlo

  • Full Member
  • ***
  • Posts: 212
Re: cmus issue
« Reply #2 on: December 09, 2017, 10:00:31 am »
office pc is the pc i'm using in office and i can't access it before next monday evening

i'm running 64 bit sparky,
but i guess it's a cinnamon issue: at home i noticed something bad with the sound icon in the system tray, but i thought it was because cinnamon was "upset" by the upgrade, so i switched onto lxqt and even cmus works like a charm
at office i didn't notice anything wrong till i tried to lower volume with the "fn + vol-" keys, which did not work
then i goggled for the cmus error, and it was audiopulse related: on cinnamon there was something like "audiopulse--cli..." set to start whensession start, but it was fruitless: i tried to add /usr/bin/audiopulse and it worked
similarly it solved home pc cinnamon issue as well
that's why i suspect something in cinnamon changed and it wasn't supposed to be changed