Author Topic: Cannot change Desktop background... (SOLVED)  (Read 1182 times)

Offline tenfoot

  • Newbie
  • *
  • Posts: 31
Cannot change Desktop background... (SOLVED)
« on: May 10, 2017, 10:57:44 pm »
Sparky Linux on Lenovo Thinkpad T450s. I update the computer immediately after logon each morning.

I am using Variety background changer v0.6.3 and have the program pointing to two locations:  /usr/share/backgrounds and /home/zed/Backgrounds for the images.

This setup has worked perfectly together since I installed Sparky.

Booted the machine this morning and found that at completion all I had as a background was a black screen.  All the usual icons on the background displayed correctly, as did the Panel and the icons normally displayed on it.

Clicked on the screen with right mouse button pressed and chose "Change Desktop Background and the Appearance/Preferences menu displayed. Selected an image but it did not display.  Tried other images, with the same result.  Clicked on Add (to see whether I could add an image) and was able to do so.  However, when that image was selected it did not display on the Desktop.

Is anyone able to suggest which software update may have caused this problem and, even better, suggest a solution, please?
« Last Edit: June 07, 2017, 09:55:53 pm by tenfoot »
Dogs laugh, but they laugh with their tails.

Offline tenfoot

  • Newbie
  • *
  • Posts: 31
Re: Cannot change Desktop background...
« Reply #1 on: May 18, 2017, 12:52:18 am »
An update to my original request for help.

Since first seeking help with this problem on 10 May I have, in an endeavour to solve the problem

(1) uninstalled Variety and then shut down the computer and rebooted.  Problem not solved.

(2) Launched Synaptic and marked all MATE items for re-installation and applied the changes.  Shut down computer and then rebooted.  Problem not solved.

Although not a "deal breaker", as the computer functions normally otherwise, it is becoming very annoying.

Has no other user experienced this problem?

Dogs laugh, but they laugh with their tails.

Offline py-thon

  • Jr. Member
  • **
  • Posts: 76
Re: Cannot change Desktop background...
« Reply #2 on: May 18, 2017, 05:55:19 pm »
This is a bug of the most recent MATE 1.16 packages. I my case I now get the standard Debian background instead of my wallpaper, even though the settings show the wallpaper preview. I hope it gets solved with 1.18. But it seems we have to wait some time for 1.18 as it is not even in sid yet.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline tenfoot

  • Newbie
  • *
  • Posts: 31
Re: Cannot change Desktop background...
« Reply #3 on: May 18, 2017, 09:29:31 pm »
This is a bug of the most recent MATE 1.16 packages. I my case I now get the standard Debian background instead of my wallpaper, even though the settings show the wallpaper preview. I hope it gets solved with 1.18. But it seems we have to wait some time for 1.18 as it is not even in sid yet.

Thanks for  your quick response py-thon  I'm relieved to learn it's not something that I've done to cause the problem. Will now wait patiently for the experts to fix it.
Dogs laugh, but they laugh with their tails.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 308
Re: Cannot change Desktop background...
« Reply #4 on: May 20, 2017, 01:24:48 am »
And probably the mate 1.18 won't hit sid until after the release and end of the freeze.  Sparky might get it 5 days after it hits Sid.  Not listed on the Debian Transition page yet. 
Don't make a FrankenDebian

Offline Thor2020

  • Newbie
  • *
  • Posts: 2
Re: Cannot change Desktop background...
« Reply #5 on: May 29, 2017, 04:57:09 pm »
I have found this same problem.  I was about to delete Sparky and find a different Linux OS.  This is very annoying.  One would expect that a new update would fix any Sparky problems and not create new ones.  I did everything I knew to circumvent this problem with no success.  I will use my other operating system, Linus Mint, until this problem with Sparky is resolved.  Oh yes, why has not Sparky incorporated the Cinnamon Desktop? 

R. Coleman

Offline py-thon

  • Jr. Member
  • **
  • Posts: 76
Re: Cannot change Desktop background...
« Reply #6 on: May 30, 2017, 07:49:18 pm »
I was about to delete Sparky and find a different Linux OS.  This is very annoying.  One would expect that a new update would fix any Sparky problems and not create new ones.  I did everything I knew to circumvent this problem with no success.  I will use my other operating system, Linus Mint, until this problem with Sparky is resolved.  Oh yes, why has not Sparky incorporated the Cinnamon Desktop? 
Did you have a bad day today? We are talking about the desktop background, not some essential functionality.
This is not Sparky's fault. The bug lies upstream with Debian and/or MATE, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862174 .
Due to the current freeze of Debian to finish Stretch packages for MATE 1.18 have not been put into sid yet. Stretch will probably be published on 17.06., so the background problem might be fixed by the end of June.

The reason why there is no Cinnamon version of Sparky (but you can install almost any DE you like, Cinnamon as well) is probably that Cinnamon uses a lot of RAM with Debian (see https://sparkylinux.org/forum/index.php?topic=2975.0 ) and pavroo's day has 24 hours only. He can't provide everything and then some.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline py-thon

  • Jr. Member
  • **
  • Posts: 76
Re: Cannot change Desktop background...
« Reply #7 on: June 07, 2017, 04:16:17 pm »
Latest updates within Mate 1.16 have solved the problem.
Tower: Sparky 64bit MATE
Netbook: Sparky 32bit MATE

Offline tenfoot

  • Newbie
  • *
  • Posts: 31
Re: Cannot change Desktop background...
« Reply #8 on: June 07, 2017, 09:55:15 pm »
Latest updates within Mate 1.16 have solved the problem.

Delighted to confirm that.  After applying updates a few minutes ago  and then  rebooting, it is nice to have a familiar desktop again.

Have marked this subject as solved,
Dogs laugh, but they laugh with their tails.