Author Topic: Kernel Panic with SparkyLinux 4.5.2 i686  (Read 743 times)

Offline maks

  • Newbie
  • *
  • Posts: 6
Kernel Panic with SparkyLinux 4.5.2 i686
« on: January 13, 2017, 08:23:49 pm »
Hi there!

First post here. :) I consider myself still fairly new-ish to Linux, although I have a Linux backup server running at home for some time now and recently installed Linux Mint as my everyday OS.
Now I'm trying to revive an old Laptop of mine from 2003, a HP nx7000: CPU Intel Pentium M 1.4GHz, GPU ATI Radeon 9000M and 768MB of RAM.
So far I was able to run Lubuntu 10.04 and Puppy Linux on it. But Ideally I'd like to find a more recent distro that's still supported. I came across SparkyLinux today, so I would like to give it a try, since by default it supports non pae 32bit systems. When I try to boot into the live image on a USB stick in verbose mode, I run into a kernel panic. It already takes a good 5mn or longer to get past the "Loading /live/initrd.img..." line, don't know if this is normal already. Past that, the screen before the kernel panic looks as follows:
http://i.imgur.com/vlnOJab.jpg
This happens with the sparkylinux-4.5.2-i686-lxde.iso as well as with sparkylinux-4.5.2-i686-mate.iso, md5sum verified. Is my laptop just too old, or maybe it doesn't have anough RAM? Any idea? Thanks! :)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1582
    • SparkyLinux
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #1 on: January 13, 2017, 11:13:46 pm »
Hi
I am not pretty sure, but it looks like that the Pentium M needs older Linux kernel then i686.
I had similar problem with laptop Compaq Evo with Pentium M too.
I successfully installed Debian stable Jessie 32 bit on it, with i586 kernel.
And it still running.
Nothing is easy as it looks.
Danielle Steel

Offline maks

  • Newbie
  • *
  • Posts: 6
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #2 on: January 14, 2017, 12:20:13 am »
Thanks for your reply pavroo. That's what I suspect as well... I'll continue to try to find out what's the latest kernel that would support the Pentium M. The thing is, as I said, that I'd like to find a distro that's still supported and that receives security updates, which is not the case with those older distros. With that said, Debian Jessie is a recent release, which surely has a recent kernel too, doesn't it? So, did you downgrade the kernel? And if yes, how, and isn't doing so a problem? Sorry, in that regard I'm still a noob... ;)
« Last Edit: January 14, 2017, 03:09:00 am by maks »

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 279
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #3 on: January 14, 2017, 01:04:17 am »
Another place to get decent information from some great people would be at the BunsenLab forums.  Possibly
https://forums.bunsenlabs.org/search.php?search_id=1341076753     ##Bunsen is a Stable-Jessie Debian variant that is light, openbox, tint2, and is the successor to #! (CrunchBang linux)    You could maybe give bl-Hydrogen-i386+NonPAE_20160710.iso a go.  Like Sparky they provide the non-free components to simplify the install.  I somehow resurrected my old (2008) EEE which had #! and it presently has Puppy on it until I get another 16gb SDHC. Might try Bunsen on it. Too many irons in thefire.  Sigh.  Peace out.
Don't make a FrankenDebian

Offline maks

  • Newbie
  • *
  • Posts: 6
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #4 on: January 14, 2017, 03:08:28 am »
Thanks paxmark1, will check. As for Debian Jessie, I'm still a bit confused. As far as I can see it comes with Kernel 3.16. If Jessie runs on an old Pentium M CPU, does that mean that the 3.16 kernel still supports the i586 architecture? I'm trying to google what Kernels support what architecture, but that info is not easily found...

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 279
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #5 on: January 14, 2017, 05:03:16 am »
Kernel 3.16.36 is ancient.   It should work.  Basic page for info on Debian kernels.
https://tracker.debian.org/pkg/linux   The Back-ported kernel 4.8.15-2 might even also work.  This would apply to Jessie and the Bunsenlabs.  Jessie will be going to long-term-support sometime next year, and will continue to receive security fixes. 
Don't make a FrankenDebian

Offline maks

  • Newbie
  • *
  • Posts: 6
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #6 on: January 14, 2017, 07:20:57 am »
Hi, thanks for all that info. I tried Bunsenlabs, and it looked very promising at first, I was able to boot into the live image and I really liked the stylish desktop. Unfortunately the installation returned an unknown error. Now I'm running Debian 8.6.0 i386, which installed fine, so that's great! Interestingly the kernel info says 3.16.0-4-686-pae. I thought i686 wouldn't run on my system. Anyways, Debian seems to be the way to go, and I'm happy I can make use again of my elderly laptop. It will mainly serve as a secondary machine for my family, for browsing and basic tasks, so Debian is almost a bit overkill here ;) But if it will be going LTS, than that's more than what I was hoping for to get for this old machine. So thanks again guys for your help and tips! Cheers! :)

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 279
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #7 on: January 14, 2017, 05:09:44 pm »
After you get it set up and used to how it works, you might want to enable Backports.   

https://wiki.debian.org/Backports    ##note old It uses Lennie for an example, but it should work if you mentally think of Jessie for each instance - It shows you how to install via synaptic.

Myself, I prefer updating and upgrading via the command line, The above will work,  The link below has the correct wording, it uses Jessie. 

https://backports.debian.org/Instructions/

Quote
Backports cannot be tested as extensively as Debian stable, and backports are provided on an as-is basis, with risk of incompatibilities with other components in Debian stable. Use with care!

It is therefore recommended to select single backported packages that fit your needs, and not use all available backports.
« Last Edit: January 14, 2017, 05:17:05 pm by paxmark1 »
Don't make a FrankenDebian

Offline maks

  • Newbie
  • *
  • Posts: 6
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #8 on: January 14, 2017, 06:22:39 pm »
That's interesting. I'll look into this, thanks.

Offline maks

  • Newbie
  • *
  • Posts: 6
Re: Kernel Panic with SparkyLinux 4.5.2 i686
« Reply #9 on: January 15, 2017, 02:54:21 am »
Now this is interesting: My initial attempts to install the latest Mint 18.1 Mate, or any other recent Ubuntu spins (with the non pae option) all failed. That's why I started to look around for other distros and eventually concluded that it must be a kernel issue, as documented in this thread: the old Pentium M simply not working with recent 4.x kernels. Now, after the successful Debian episode, I gave the Debian spin of Mint a try, LMDE2, which, with the i586 kernel version, also worked. Since Debian or LMDE are lacking some things that I am used to in regular Mint versions, I then gave Mint 17.3 with kernel 3.19 a try, which worked as well and is supported until 2019, so this would have been a good compromise. Now I though, what the heck (maybe out of a gut feeling), I'll give Mint 18.1 Mate another try, and... it now works as well! Go figure... Oh well, maybe this old WinXP Laptop had to be slowly accustomed to Linux first... ;) Anyway, sorry if this thread is increasingly getting off topic for SparkyLinux (which I might give another try too now ;)), but I thought I'd share this, since it somehow baffles me. :p Cheers!